summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest')
-rw-r--r--dev-python/pytest/pytest-4.6.10.ebuild27
-rw-r--r--dev-python/pytest/pytest-5.4.2.ebuild19
2 files changed, 16 insertions, 30 deletions
diff --git a/dev-python/pytest/pytest-4.6.10.ebuild b/dev-python/pytest/pytest-4.6.10.ebuild
index f2ba4fb76432..327ad7d9b45f 100644
--- a/dev-python/pytest/pytest-4.6.10.ebuild
+++ b/dev-python/pytest/pytest-4.6.10.ebuild
@@ -45,18 +45,16 @@ RDEPEND="
DEPEND="
test? (
${RDEPEND}
- $(python_gen_cond_dep '
- dev-python/argcomplete[${PYTHON_USEDEP}]
- >=dev-python/hypothesis-3.56[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/pexpect[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- !!dev-python/flaky
- !!dev-python/pytest-aiohttp
- !!dev-python/pytest-asyncio
- !!dev-python/pytest-django
- ' python2_7 python3_{6,7,8} pypy3)
+ dev-python/argcomplete[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-3.56[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ !!dev-python/flaky
+ !!dev-python/pytest-aiohttp
+ !!dev-python/pytest-asyncio
+ !!dev-python/pytest-django
$(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' -2)
)"
@@ -75,11 +73,6 @@ python_prepare_all() {
}
python_test() {
- if [[ ${EPYTHON} == python3.9 ]]; then
- einfo "Skipping py3.9 due to unported deps"
- return
- fi
-
distutils_install_for_testing
# In v4.1.1, pytest started being picky about its own verbosity options.
diff --git a/dev-python/pytest/pytest-5.4.2.ebuild b/dev-python/pytest/pytest-5.4.2.ebuild
index c53483cbfc67..fccc727d16e5 100644
--- a/dev-python/pytest/pytest-5.4.2.ebuild
+++ b/dev-python/pytest/pytest-5.4.2.ebuild
@@ -39,14 +39,12 @@ RDEPEND="
# flake cause a number of tests to fail
DEPEND="${RDEPEND}
test? (
- $(python_gen_cond_dep '
- >=dev-python/hypothesis-3.56[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/xmlschema[${PYTHON_USEDEP}]
- !!dev-python/flaky
- ' python2_7 python3_{6,7,8} pypy3)
+ >=dev-python/hypothesis-3.56[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/xmlschema[${PYTHON_USEDEP}]
+ !!dev-python/flaky
)"
PATCHES=(
@@ -65,11 +63,6 @@ python_prepare_all() {
}
python_test() {
- if [[ ${EPYTHON} == python3.9 ]]; then
- einfo "Skipping py3.9 due to unported deps"
- return
- fi
-
distutils_install_for_testing
"${EPYTHON}" -m pytest -vv --lsof -rfsxX \