summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python3-xapp')
-rw-r--r--dev-python/python3-xapp/python3-xapp-2.4.0-r1.ebuild (renamed from dev-python/python3-xapp/python3-xapp-2.4.0.ebuild)8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-python/python3-xapp/python3-xapp-2.4.0.ebuild b/dev-python/python3-xapp/python3-xapp-2.4.0-r1.ebuild
index b3eb90892128..762ca8e68990 100644
--- a/dev-python/python3-xapp/python3-xapp-2.4.0.ebuild
+++ b/dev-python/python3-xapp/python3-xapp-2.4.0-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{8,9,10,11} )
+PYTHON_COMPAT=( python3_{8..11} )
inherit meson python-r1
@@ -27,7 +27,7 @@ RDEPEND="
"
src_prepare() {
- echo "option('python', type: 'string', value: 'python3')" >> meson_options.txt
+ echo "option('python', type: 'string', value: 'python3')" >> meson_options.txt || die
sed -i "s/find_installation('python3')/find_installation(get_option('python'))/" meson.build || die
default
}
@@ -44,6 +44,10 @@ src_compile() {
python_foreach_impl meson_src_compile
}
+src_test() {
+ python_foreach_impl meson_src_test
+}
+
src_install() {
installing() {
meson_src_install