summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pythran')
-rw-r--r--dev-python/pythran/pythran-0.14.0.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/dev-python/pythran/pythran-0.14.0.ebuild b/dev-python/pythran/pythran-0.14.0.ebuild
index b15f2a17d6e0..8ae4f640ebee 100644
--- a/dev-python/pythran/pythran-0.14.0.ebuild
+++ b/dev-python/pythran/pythran-0.14.0.ebuild
@@ -52,11 +52,18 @@ BDEPEND="
distutils_enable_tests pytest
src_configure() {
- cat >> setup.cfg <<-EOF
+ cat >> setup.cfg <<-EOF || die
[build_py]
no_boost = True
no_xsimd = True
EOF
+
+ if use test ; then
+ sed -i \
+ -e 's|blas=blas|blas=cblas|' \
+ -e 's|libs=|libs=cblas|' \
+ pythran/pythran-*.cfg || die
+ fi
}
python_test() {