summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/jupyterlab-lsp/Manifest1
-rw-r--r--dev-python/jupyterlab-lsp/jupyterlab-lsp-3.9.2.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/jupyterlab-lsp/Manifest b/dev-python/jupyterlab-lsp/Manifest
index 4656c4d56e9a..d5438107a1fc 100644
--- a/dev-python/jupyterlab-lsp/Manifest
+++ b/dev-python/jupyterlab-lsp/Manifest
@@ -1 +1,2 @@
DIST jupyterlab-lsp-3.9.1.tar.gz 262645 BLAKE2B cd3377ea3abbb3f877b257140d5ac6b162aa9d4229cb58f67fa60a9b7f5db43de6873af381bac5bbf6103a47a53863ae322ad200550d73e5c19baa5eb2866aa2 SHA512 0289dc666a3ec3d93d276c67e95c19b0427e45a4f1e001180df4af9a72f7e81dddc8bdd175684f857dfc8e02935dbd31b454bfd0ee1431a8e702f662365c747e
+DIST jupyterlab-lsp-3.9.2.tar.gz 263499 BLAKE2B 2ece934e68b27e28161ee3218af2d11bd5b286b4c517ff8feb4f9ec10c261e51a95fb4d52de7717d896a7c4dbca9be168aa75ed8ab7728dd4844640417f31365 SHA512 c41045736cbf511f72668dc03c0fd1265c2b2e2f60a4e987fecd8e23be0a6af1ae7b341f6b0c47fb4f5956f00cbb982f8cd9f31ebca8098ce01cc21a8f0df357
diff --git a/dev-python/jupyterlab-lsp/jupyterlab-lsp-3.9.2.ebuild b/dev-python/jupyterlab-lsp/jupyterlab-lsp-3.9.2.ebuild
new file mode 100644
index 000000000000..832007567c54
--- /dev/null
+++ b/dev-python/jupyterlab-lsp/jupyterlab-lsp-3.9.2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Coding assistance for JupyterLab with Language Server Protocol"
+HOMEPAGE="https://github.com/jupyter-lsp/jupyterlab-lsp"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/jupyterlab-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/jupyterlab-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-lsp-1.4.0[${PYTHON_USEDEP}]
+"