summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/geodesy')
-rw-r--r--dev-ros/geodesy/Manifest1
-rw-r--r--dev-ros/geodesy/geodesy-0.5.6.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-ros/geodesy/Manifest b/dev-ros/geodesy/Manifest
index 901d771b1248..6e4508144646 100644
--- a/dev-ros/geodesy/Manifest
+++ b/dev-ros/geodesy/Manifest
@@ -1 +1,2 @@
DIST geographic_info-0.5.5.tar.gz 27762 BLAKE2B 9235911d6a2b010e47722268f5aa14b2bd10dac73bf4445bcd6585c5094947e9ea43ee2ccb6d6a3b0ae788d149fcc546e6618f0097e4bde32d69ed9baacbf255 SHA512 a1699778cd85960603435e7b7d46831c7c5ac4b57f4a06e9f394933799151a5ebf95c59bc109ca05eeb9376763aae8c77bc9150081c81170f1778730145910ec
+DIST geographic_info-0.5.6.tar.gz 28130 BLAKE2B 4d7013543db91c02c470c6b6dcb6e00070d5356f91ace20b3bb97aafa71eff2b525fc11994796f2de103b1df40efe8358d19a7e8fc0b1290c73cc28c791f22ce SHA512 d2f41320d2b094c2ea04593941e35d2b5581b84cc2f599099880dd671255dd59bc8787ad4a5640539cc25a13592df2ec7a887e3ea171398cfeafeccc669bd7f0
diff --git a/dev-ros/geodesy/geodesy-0.5.6.ebuild b/dev-ros/geodesy/geodesy-0.5.6.ebuild
new file mode 100644
index 000000000000..52d160f557de
--- /dev/null
+++ b/dev-ros/geodesy/geodesy-0.5.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-geographic-info/geographic_info"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Python and C++ interfaces for manipulating geodetic coordinates"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/angles
+ dev-ros/geographic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/tf
+ dev-ros/unique_id
+ dev-ros/uuid_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ $(python_gen_cond_dep "dev-python/pyproj[\${PYTHON_USEDEP}]")
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/geographic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ test? (
+ dev-ros/rosunit[${PYTHON_SINGLE_USEDEP}]
+ dev-cpp/gtest
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
+ )"
+PATCHES=( "${FILESDIR}/py3.patch" )