summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/roswtf')
-rw-r--r--dev-ros/roswtf/Manifest2
-rw-r--r--dev-ros/roswtf/roswtf-1.15.7.ebuild27
-rw-r--r--dev-ros/roswtf/roswtf-1.15.8.ebuild33
-rw-r--r--dev-ros/roswtf/roswtf-9999.ebuild20
4 files changed, 47 insertions, 35 deletions
diff --git a/dev-ros/roswtf/Manifest b/dev-ros/roswtf/Manifest
index 5d86517495e4..00d95d9416dc 100644
--- a/dev-ros/roswtf/Manifest
+++ b/dev-ros/roswtf/Manifest
@@ -1 +1 @@
-DIST ros_comm-1.15.7.tar.gz 1080092 BLAKE2B d5c0dd1f54eac7aa11be21bbc680f85f988cc9328382c0c675b7d5986e888be603ed82affa5f51a270974d07044debe3ecf86f5647fd59cb29e8e791a227feb9 SHA512 67dc100e8ed03a25ea228cc7d456ec2203324098f9e11c9a249299df73bfc34efc75b1221c0fb6fceb38fece627f1dc5f2c23be93c9a1c85b1075784a45ff20e
+DIST ros_comm-1.15.8.tar.gz 1080826 BLAKE2B c1a1e085225a96cf0b50309cb78e1ccdabefce1f23ee669393b7fc747537c7e39bfb6ad382b0d24e3b5507b1d0f3eaf2051a1bee90507b0e724e06a83df301a2 SHA512 b1c34ab6548400fc014eda496e5d1e1c7d134b9062a031386ac4eac3245ca83b034f74f0a189ccf9ec6933c18d6df0ae1a93d05f1526d09debf70c25aa25b6b9
diff --git a/dev-ros/roswtf/roswtf-1.15.7.ebuild b/dev-ros/roswtf/roswtf-1.15.7.ebuild
deleted file mode 100644
index 6bad78a650a1..000000000000
--- a/dev-ros/roswtf/roswtf-1.15.7.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-ROS_REPO_URI="https://github.com/ros/ros_comm"
-KEYWORDS="~amd64 ~arm"
-ROS_SUBDIR=utilities/${PN}
-
-inherit ros-catkin
-
-DESCRIPTION="Tool for diagnosing issues with a running ROS system"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- dev-python/paramiko[${PYTHON_USEDEP}]
- dev-ros/roslib[${PYTHON_USEDEP}]
- dev-python/rospkg[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? (
- dev-ros/rostest[${PYTHON_USEDEP}]
- dev-util/rosdep[${PYTHON_USEDEP}]
- dev-util/rosinstall[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- )"
diff --git a/dev-ros/roswtf/roswtf-1.15.8.ebuild b/dev-ros/roswtf/roswtf-1.15.8.ebuild
new file mode 100644
index 000000000000..f29c9e72edb3
--- /dev/null
+++ b/dev-ros/roswtf/roswtf-1.15.8.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=utilities/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Tool for diagnosing issues with a running ROS system"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ $(python_gen_cond_dep "dev-python/paramiko[\${PYTHON_USEDEP}]")
+ dev-ros/roslib[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep "dev-python/rospkg[\${PYTHON_USEDEP}]")
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep "dev-util/rosdep[\${PYTHON_USEDEP}]")
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
+ )"
+
+src_test() {
+ # Needed for tests to find internal launch file
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}
diff --git a/dev-ros/roswtf/roswtf-9999.ebuild b/dev-ros/roswtf/roswtf-9999.ebuild
index 6bad78a650a1..f29c9e72edb3 100644
--- a/dev-ros/roswtf/roswtf-9999.ebuild
+++ b/dev-ros/roswtf/roswtf-9999.ebuild
@@ -15,13 +15,19 @@ SLOT="0"
IUSE=""
RDEPEND="
- dev-python/paramiko[${PYTHON_USEDEP}]
- dev-ros/roslib[${PYTHON_USEDEP}]
- dev-python/rospkg[${PYTHON_USEDEP}]"
+ $(python_gen_cond_dep "dev-python/paramiko[\${PYTHON_USEDEP}]")
+ dev-ros/roslib[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep "dev-python/rospkg[\${PYTHON_USEDEP}]")
+"
DEPEND="${RDEPEND}
test? (
- dev-ros/rostest[${PYTHON_USEDEP}]
- dev-util/rosdep[${PYTHON_USEDEP}]
- dev-util/rosinstall[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep "dev-util/rosdep[\${PYTHON_USEDEP}]")
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
)"
+
+src_test() {
+ # Needed for tests to find internal launch file
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}