summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rex-registry/rex-registry-0.1.0.ebuild')
-rw-r--r--dev-ruby/rex-registry/rex-registry-0.1.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/rex-registry/rex-registry-0.1.0.ebuild b/dev-ruby/rex-registry/rex-registry-0.1.0.ebuild
new file mode 100644
index 000000000000..e56c41455817
--- /dev/null
+++ b/dev-ruby/rex-registry/rex-registry-0.1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+#RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Rex library for parsing offline registry files from a Windows machine"
+HOMEPAGE="https://rubygems.org/gems/rex-registry"
+
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+# doesn't seem to actually run any tests
+RESTRICT=test
+
+all_ruby_install() {
+ ruby_fakegem_binwrapper console ${PN}-console
+ ruby_fakegem_binwrapper setup ${PN}-setup
+}