summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rmagick')
-rw-r--r--dev-ruby/rmagick/Manifest1
-rw-r--r--dev-ruby/rmagick/rmagick-6.1.0.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/dev-ruby/rmagick/Manifest b/dev-ruby/rmagick/Manifest
index 00eac6e0181d..5230f9aafcfa 100644
--- a/dev-ruby/rmagick/Manifest
+++ b/dev-ruby/rmagick/Manifest
@@ -1,2 +1,3 @@
DIST rmagick-5.5.0.tar.gz 2045116 BLAKE2B 018d4e940043210238b6026a8bc0b65656633aaaf559954b666c75dda74c0f0fd33319a13fd6c494a6a51a3cfac67aac283e3e79d06dc90b6d4581464805e476 SHA512 f813104c347867b14281b044135fd626805d35d2afa3167c25d5e31179b31e985c5cc75deb630f8a64d20b877d8c42ce13e31e137f573467d3c5f3f2453d514f
DIST rmagick-6.0.1.tar.gz 2045860 BLAKE2B e36ed9c2719df593cce32591111010a8d64e54ff4348ed22ebf9d840ca6f7ceec91b8097b5258bb0a195db63c422373e408f5995cef8944eac42e71d6fd00c4e SHA512 a6fdecd4ad6d17045438a9a14fc6c0a8b9d18224d6d3d0af2ade6fcba1bd0c889710f03d8b2f9738214023d87c504f7a7017f49b467a778fa3d97a14aa2bfeb3
+DIST rmagick-6.1.0.tar.gz 2048383 BLAKE2B 2d032dac7ce7d6d684ae3ed9f894dfa8e6b5d061b17d6a9118bae5bf7824da50f67cce809d26e3d68fdfcf0bc188f134891880e2fb79cd0f35269f05ef801b2c SHA512 8b00e888481991a7e991c7616e1b2575ec9e08da4d5620436439bf0cbe9cb38fa3a5b24986ba0d943c565d73dd0bf675e703a70b7fc3420df6fb932bc7bd2ccb
diff --git a/dev-ruby/rmagick/rmagick-6.1.0.ebuild b/dev-ruby/rmagick/rmagick-6.1.0.ebuild
new file mode 100644
index 000000000000..565929110967
--- /dev/null
+++ b/dev-ruby/rmagick/rmagick-6.1.0.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="rmagick.gemspec"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/RMagick/extconf.rb)
+
+MY_PV=RMagick_${PV//\./-}
+
+inherit ruby-fakegem
+
+DESCRIPTION="An interface between Ruby and the ImageMagick(TM) image processing library"
+HOMEPAGE="https://github.com/rmagick/rmagick"
+SRC_URI="https://github.com/rmagick/rmagick/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="rmagick-${MY_PV}"
+
+LICENSE="Artistic"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=media-gfx/imagemagick-6.9.0:="
+DEPEND=">=media-gfx/imagemagick-6.9.0 test? ( >=media-gfx/imagemagick-7.1.0:=[jpeg,lqr,lcms,postscript,tiff,webp,xml] media-fonts/dejavu )"
+
+# observer is a default gem packaged with ruby
+
+ruby_add_bdepend "dev-ruby/pkg-config"
+
+all_ruby_prepare() {
+ # Avoid unused dependency on rake-compiler. This also avoids an
+ # extra compile during tests.
+ sed -i -e '/extensiontask/ s:^:#:' \
+ -e '/ExtensionTask/,/end/ s:^:#:' \
+ -e '/compile/ s:^:#:' Rakefile || die
+ sed -i -e '/pry/ s:^:#:' -e '5irequire "tempfile"' spec/spec_helper.rb || die
+ sed -e 's/git ls-files/find */' \
+ -e '/pkg-config/ s:^:#:' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Squelch harmless warning about imagemagick installation.
+ sed -i -e '/prefix/ s:ImageMagick:ImageMagick-6:' ext/RMagick/extconf.rb || die
+
+ # Create directory used for a test
+ mkdir tmp
+}
+
+each_ruby_test() {
+ # Borrowed from media-gfx/gscan2pdf
+ # Needed to avoid test failures on e.g. ppc, bug #815856
+ # (Unclear why it doesn't manifest on amd64 here at least)
+ local confdir="${HOME}/.config/ImageMagick"
+ mkdir -p "${confdir}" || die
+ cat > "${confdir}/policy.xml" <<-EOT || die
+ <policymap>
+ <policy domain="coder" rights="read|write" pattern="PDF" />
+ <policy domain="coder" rights="read" pattern="PS" />
+ </policymap>
+ EOT
+
+ RSPEC_VERSION="3" ruby-ng_rspec
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc examples/*
+
+ if use doc ; then
+ docinto .
+ dodoc -r doc
+ fi
+}