summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/sasm/sasm-3.10.1.ebuild')
-rw-r--r--dev-util/sasm/sasm-3.10.1.ebuild20
1 files changed, 8 insertions, 12 deletions
diff --git a/dev-util/sasm/sasm-3.10.1.ebuild b/dev-util/sasm/sasm-3.10.1.ebuild
index 90ca72d53168..7b82aa3b818b 100644
--- a/dev-util/sasm/sasm-3.10.1.ebuild
+++ b/dev-util/sasm/sasm-3.10.1.ebuild
@@ -1,17 +1,17 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit qmake-utils
-if [[ ${PV} == 9999 ]]; then
+if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="https://github.com/Dman95/SASM.git"
- SRC_URI=""
inherit git-r3
else
SRC_URI="https://github.com/Dman95/SASM/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/SASM-${PV}"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${P^^}"
fi
DESCRIPTION="Simple crossplatform IDE for NASM assembly language"
@@ -19,13 +19,9 @@ HOMEPAGE="http://dman95.github.io/SASM/"
LICENSE="GPL-3"
SLOT="0"
-[[ ${PV} == 9999 ]] || \
-KEYWORDS="~amd64 ~x86"
IUSE=""
-PATCHES=(
- "${FILESDIR}"/${P}-unbundle-qtsingleapplication.patch
-)
+PATCHES=( "${FILESDIR}"/${P}-unbundle-qtsingleapplication.patch )
DEPEND="
dev-qt/qtcore:5
@@ -42,13 +38,13 @@ REPEND="${DEPEND}
QA_PREBUILT="usr/bin/fasm usr/bin/listing"
src_prepare() {
+ default
+
# To recompress it with gentoo tools
gunzip Linux/share/doc/sasm/changelog.gz || die
sed -e 's@changelog.gz@changelog@g' \
-e '/docfiles.path/s@doc/sasm@doc/'${PF}'@g' \
-i SASM.pro || die
-
- default
}
src_configure() {