summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/uftrace/uftrace-0.9.3.ebuild')
-rw-r--r--dev-util/uftrace/uftrace-0.9.3.ebuild25
1 files changed, 15 insertions, 10 deletions
diff --git a/dev-util/uftrace/uftrace-0.9.3.ebuild b/dev-util/uftrace/uftrace-0.9.3.ebuild
index d48d238c8012..51506dbff692 100644
--- a/dev-util/uftrace/uftrace-0.9.3.ebuild
+++ b/dev-util/uftrace/uftrace-0.9.3.ebuild
@@ -1,11 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 )
-
-inherit python-single-r1
+inherit bash-completion-r1
DESCRIPTION="Function (graph) tracer for user-space"
HOMEPAGE="https://github.com/namhyung/uftrace"
@@ -14,25 +12,32 @@ SRC_URI="https://github.com/namhyung/uftrace/archive/v${PV}.tar.gz -> ${P}.tar.g
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="capstone"
-REQUIRED_USE=${PYTHON_REQUIRED_USE}
+IUSE="bash-completion capstone luajit"
RESTRICT="test"
RDEPEND="
- ${PYTHON_DEPS}
- sys-devel/gcc:*[cxx]
sys-libs/ncurses:=
virtual/libelf:=
capstone? ( dev-libs/capstone:0= )
+ luajit? ( dev-lang/luajit )
"
DEPEND="${RDEPEND}"
src_prepare() {
default
- sed -i -e "s/ARCH/MYARCH/g" -e "/ldconfig/d" Makefile || die
+ sed -i -e "s/ARCH/MYARCH/g" -e "/ldconfig/d" -e "/bash.completion/d" Makefile || die
}
src_configure() {
- econf $(use_with capstone)
+ econf \
+ $(use_with capstone) \
+ $(use_with luajit libluajit) \
+ --without-libpython
+}
+
+src_install() {
+ default
+ dodoc doc/*.{md,gif,png}
+ use bash-completion && newbashcomp misc/bash-completion.sh uftrace
}