summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/maturin/maturin-0.13.0.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-util/maturin/maturin-0.13.0.ebuild b/dev-util/maturin/maturin-0.13.0.ebuild
index 64d1038971fb..f1203825d536 100644
--- a/dev-util/maturin/maturin-0.13.0.ebuild
+++ b/dev-util/maturin/maturin-0.13.0.ebuild
@@ -384,13 +384,13 @@ src_prepare() {
# ensure rustls is disabled on arches where ring crate is problematic,
# keep in sync with src_configure below (bug #859577)
- if use ppc64 || use s390; then
+ if use ppc || use ppc64 || use s390; then
sed -i '/^if platform.machine/s/^if/if True or/' setup.py || die
fi
}
src_configure() {
- if use ppc64 || use s390; then
+ if use ppc || use ppc64 || use s390; then
local myfeatures=( upload log human-panic ) # sync with setup.py
cargo_src_configure --no-default-features
fi