summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/amphetamine')
-rw-r--r--games-arcade/amphetamine/Manifest2
-rw-r--r--games-arcade/amphetamine/amphetamine-0.8.10.ebuild39
-rw-r--r--games-arcade/amphetamine/files/amphetamine-0.8.10-64bit.patch72
-rw-r--r--games-arcade/amphetamine/files/amphetamine-0.8.10-build.patch33
-rw-r--r--games-arcade/amphetamine/metadata.xml8
5 files changed, 154 insertions, 0 deletions
diff --git a/games-arcade/amphetamine/Manifest b/games-arcade/amphetamine/Manifest
new file mode 100644
index 000000000000..ce51d856f7f8
--- /dev/null
+++ b/games-arcade/amphetamine/Manifest
@@ -0,0 +1,2 @@
+DIST amphetamine-0.8.10.tar.bz2 72324 SHA256 6cf7542d7a6b1c3f3cc660164961aa3fecd90fc3ebd7f9b640bf73dfca6aa677 SHA512 eb3106df6070e207ffb3293ac4701bba8222603c0e399667505bad29b6f6433dc9ec008499b5180f713a724d3b686fead15536a20927195bc57780be16a860ef WHIRLPOOL a9b2706c0b8418d14fb87ad8451a2ea6a72c8e8ad1ecceaf72fa34458f3368b21541aaadafb24cf11f7128373679c70e9cc7e79ef420c0145896f8222ecc5c11
+DIST amphetamine-data-0.8.6.tar.bz2 928775 SHA256 b51a0edaf3271008a5e0b3061556898e3d0e27a554803d53caaaec14ecb730aa SHA512 0feb86f420b4816064594756bb30bb6e02ae5062f03ef175b3262a8f30043340933f6f1b1894e2b2cfad70befc76d3ed1e0d2777c2dc2f7461459e8a93efeaf1 WHIRLPOOL 09fab6986514a13d3341cccdc557a4110714a66bd352e9166f8c7f935aeb20eb3f2f3cac84400384cb640f9a53451845ffd6c8b653ba8f1c06c4c69bf43090f4
diff --git a/games-arcade/amphetamine/amphetamine-0.8.10.ebuild b/games-arcade/amphetamine/amphetamine-0.8.10.ebuild
new file mode 100644
index 000000000000..73d9b27173cc
--- /dev/null
+++ b/games-arcade/amphetamine/amphetamine-0.8.10.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils games
+
+DESCRIPTION="a cool Jump'n Run game offering some unique visual effects"
+HOMEPAGE="http://homepage.hispeed.ch/loehrer/amph/amph.html"
+SRC_URI="http://homepage.hispeed.ch/loehrer/amph/files/${P}.tar.bz2
+ http://homepage.hispeed.ch/loehrer/amph/files/${PN}-data-0.8.6.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="media-libs/libsdl[sound,video]
+ x11-libs/libXpm"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-build.patch
+ "${FILESDIR}"/${P}-64bit.patch
+)
+
+src_compile() {
+ emake INSTALL_DIR="${GAMES_DATADIR}"/${PN}
+}
+
+src_install() {
+ newgamesbin amph ${PN}
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r ../amph/*
+ newicon amph.xpm ${PN}.xpm
+ make_desktop_entry ${PN} Amphetamine ${PN}
+ dodoc BUGS ChangeLog NEWS README
+ prepgamesdirs
+}
diff --git a/games-arcade/amphetamine/files/amphetamine-0.8.10-64bit.patch b/games-arcade/amphetamine/files/amphetamine-0.8.10-64bit.patch
new file mode 100644
index 000000000000..b7588face714
--- /dev/null
+++ b/games-arcade/amphetamine/files/amphetamine-0.8.10-64bit.patch
@@ -0,0 +1,72 @@
+--- amphetamine-0.8.10.orig/src/Shape.cpp
++++ amphetamine-0.8.10/src/Shape.cpp
+@@ -56,12 +56,12 @@
+ */
+ #ifdef __OPT_MEM_ACCESS__
+
+-#define GET_LONG(adr) *(unsigned long *)adr
+-#define SET_LONG(adr, l) *(unsigned long *)adr = l
++#define GET_LONG(adr) *(uint32_t *)adr
++#define SET_LONG(adr, l) *(uint32_t *)adr = l
+
+ #else
+
+-#define GET_LONG(adr) ((long)((unsigned char *)(adr))[0] << 24) + ((long)((unsigned char *)(adr))[1] << 16) + ((long)((unsigned char *)(adr))[2] << 8) + ((long)((unsigned char *)(adr))[3])
++#define GET_LONG(adr) ((uint32_t)((unsigned char *)(adr))[0] << 24) + ((uint32_t)((unsigned char *)(adr))[1] << 16) + ((uint32_t)((unsigned char *)(adr))[2] << 8) + ((uint32_t)((unsigned char *)(adr))[3])
+ #define SET_LONG(adr, l) ((unsigned char *)adr)[0] = (unsigned char)((l) >> 24); \
+ ((unsigned char *)adr)[1] = (unsigned char)((l) >> 16); \
+ ((unsigned char *)adr)[2] = (unsigned char)((l) >> 8); \
+@@ -116,7 +116,7 @@
+ {
+ // store the location of this line start
+ lineStartPtr = destPtr;
+- destPtr += sizeof( unsigned long );
++ destPtr += sizeof( uint32_t );
+
+ // at the beginning of each row we are not in any run
+ drawRunFlag = kFalse;
+@@ -160,7 +160,7 @@
+ // create the skip token
+ //*( ( unsigned long * )destPtr ) = ( kSkipPixelsToken << 24 ) + runCounter;
+ SET_LONG(destPtr, ( kSkipPixelsToken << 24 ) + runCounter);
+- destPtr += sizeof( unsigned long );
++ destPtr += sizeof( uint32_t );
+ }
+
+ // are we in a draw run
+@@ -179,7 +179,7 @@
+
+ // save the location of the token (so we can fill it in later)
+ runTokenPtr = destPtr;
+- destPtr += sizeof( unsigned long );
++ destPtr += sizeof( uint32_t );
+
+ // copy the pixel
+ *destPtr = *srcPtr;
+@@ -215,7 +215,7 @@
+
+ // create the end of shape token
+ SET_LONG(destPtr, kEndShapeToken << 24);
+- destPtr += sizeof( unsigned long );
++ destPtr += sizeof( uint32_t );
+
+ // Resize the handle to match the real size of the shape
+ //SetHandleSize( shapeHandle, destPtr - ( unsigned char * )( *shapeHandle ) );
+@@ -280,7 +280,7 @@
+ // get a token
+ tokenOp = GET_LONG(srcPtr ) >> 24;
+ tokenData = GET_LONG(srcPtr ) & 0x00ffffff;
+- srcPtr += sizeof( unsigned long );
++ srcPtr += sizeof( uint32_t );
+
+ // depending on the token
+ switch( tokenOp )
+@@ -435,7 +435,7 @@
+ // get a token
+ tokenOp = GET_LONG(srcPtr) >> 24;
+ tokenData = GET_LONG(srcPtr) & 0x00ffffff;
+- srcPtr += sizeof( unsigned long );
++ srcPtr += sizeof( uint32_t );
+
+ // depending on the token
+ switch( tokenOp )
diff --git a/games-arcade/amphetamine/files/amphetamine-0.8.10-build.patch b/games-arcade/amphetamine/files/amphetamine-0.8.10-build.patch
new file mode 100644
index 000000000000..2c0185f3ff01
--- /dev/null
+++ b/games-arcade/amphetamine/files/amphetamine-0.8.10-build.patch
@@ -0,0 +1,33 @@
+--- Makefile
++++ Makefile
+@@ -26,8 +26,8 @@
+
+ # makemake variables
+
+-LINKER := g++
+-DEPENDFLAGS := -g ${SEARCHDIRS}
++LINKER = $(CXX) $(CXXFLAGS)
++DEPENDFLAGS := ${SEARCHDIRS}
+ TOUCHHEADERS := ${MYCODEDIR}/*.h
+
+ # C
+@@ -37,8 +37,8 @@
+
+ # C++
+
+-CXX := g++
+-CXXFLAGS = ${DEPENDFLAGS} -O9 -funroll-loops -fomit-frame-pointer -ffast-math -Wcast-align
++CXX ?= g++
++CXXFLAGS += ${DEPENDFLAGS}
+
+ %.o : %.cpp
+ ${CXX} ${CPPFLAGS} -c $< ${CXXFLAGS} -o $@
+@@ -66,7 +66,7 @@
+ LOADLIBES := $(LOADLIBES) -lXpm -lXt
+ endif
+
+-LDFLAGS = -L/usr/lib -L/usr/local/lib -L/usr/X11R6/lib
++LDFLAGS += -L/usr/lib -L/usr/local/lib -L/usr/X11R6/lib
+
+ .PHONY : default
+ default : amph
diff --git a/games-arcade/amphetamine/metadata.xml b/games-arcade/amphetamine/metadata.xml
new file mode 100644
index 000000000000..65706f28dade
--- /dev/null
+++ b/games-arcade/amphetamine/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<longdescription lang="en">
+Amphetamine is a cool Jump'n Run game offering some unique visual effects.
+</longdescription>
+</pkgmetadata>