summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/vecx-jg')
-rw-r--r--games-emulation/vecx-jg/Manifest1
-rw-r--r--games-emulation/vecx-jg/metadata.xml24
-rw-r--r--games-emulation/vecx-jg/vecx-jg-1.2.2.ebuild46
-rw-r--r--games-emulation/vecx-jg/vecx-jg-9999.ebuild46
4 files changed, 117 insertions, 0 deletions
diff --git a/games-emulation/vecx-jg/Manifest b/games-emulation/vecx-jg/Manifest
new file mode 100644
index 000000000000..f5bcfe15b07d
--- /dev/null
+++ b/games-emulation/vecx-jg/Manifest
@@ -0,0 +1 @@
+DIST vecx-1.2.2.tar.bz2 50154 BLAKE2B 33ca097213771d6e57ece20594e1472d1f98aabe1c9892c73b648baf0180f56e9bb11282a64f2bfdde17236e265fc7e226dec74a9ae1b736e4b94d6f87067a75 SHA512 adaf1b2706fa6e893191e0444d10934a80b25d5e6936a262be4b5dc0ae070577668909a6ac7c246294556e0bc4e72bb881ae6f29a727302907fd2c73fe8e5b98
diff --git a/games-emulation/vecx-jg/metadata.xml b/games-emulation/vecx-jg/metadata.xml
new file mode 100644
index 000000000000..d8cfced3e4a3
--- /dev/null
+++ b/games-emulation/vecx-jg/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'https://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>orbea@riseup.net</email>
+ <name>orbea</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ Vecx JG is an emulator for the Vectrex. This is a fork
+ of the original, unmodified vecx sources made available
+ by Valavan Manohararajah. Many new features have been
+ added since the fork was created. The emulator now
+ contains a new renderer, save states, and support for
+ PSG and DAC based audio.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://gitlab.com/jgemu/vecx/-/issues</bugs-to>
+ <remote-id type="gitlab">jgemu/vecx</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-emulation/vecx-jg/vecx-jg-1.2.2.ebuild b/games-emulation/vecx-jg/vecx-jg-1.2.2.ebuild
new file mode 100644
index 000000000000..0b16a1dacb1e
--- /dev/null
+++ b/games-emulation/vecx-jg/vecx-jg-1.2.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PN=${PN%-*}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Jolly Good Fork of vecx"
+HOMEPAGE="https://gitlab.com/jgemu/vecx"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/jgemu/${MY_PN}.git"
+else
+ SRC_URI="https://gitlab.com/jgemu/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
+ S="${WORKDIR}/${MY_P}"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="1"
+
+DEPEND="
+ media-libs/jg:1=
+ media-libs/speexdsp
+"
+RDEPEND="
+ ${DEPEND}
+ games-emulation/jgrf
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_compile() {
+ emake CC="$(tc-getCC)" PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ emake install \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}"/usr \
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+}
diff --git a/games-emulation/vecx-jg/vecx-jg-9999.ebuild b/games-emulation/vecx-jg/vecx-jg-9999.ebuild
new file mode 100644
index 000000000000..0b16a1dacb1e
--- /dev/null
+++ b/games-emulation/vecx-jg/vecx-jg-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PN=${PN%-*}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Jolly Good Fork of vecx"
+HOMEPAGE="https://gitlab.com/jgemu/vecx"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/jgemu/${MY_PN}.git"
+else
+ SRC_URI="https://gitlab.com/jgemu/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
+ S="${WORKDIR}/${MY_P}"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="1"
+
+DEPEND="
+ media-libs/jg:1=
+ media-libs/speexdsp
+"
+RDEPEND="
+ ${DEPEND}
+ games-emulation/jgrf
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_compile() {
+ emake CC="$(tc-getCC)" PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ emake install \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}"/usr \
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+}