summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-rpg/bastion')
-rw-r--r--games-rpg/bastion/Manifest1
-rw-r--r--games-rpg/bastion/bastion-20120620-r1.ebuild88
-rw-r--r--games-rpg/bastion/metadata.xml6
3 files changed, 95 insertions, 0 deletions
diff --git a/games-rpg/bastion/Manifest b/games-rpg/bastion/Manifest
new file mode 100644
index 000000000000..350d44e061f2
--- /dev/null
+++ b/games-rpg/bastion/Manifest
@@ -0,0 +1 @@
+DIST Bastion-HIB-2012-06-20.sh 1055161705 SHA256 f1e67f8e8dd0ba823cab0f16f2269dc8d9230ebca7a304927ff540320169c431 SHA512 e81b5dfa6f61ec2b35b30693c156a612cd3242c2169f4414b6d66839b7d8cc2e6ea8776f55baae67fa8131ee96bc221e1a15004410612eecaa9f7204dcc673ad WHIRLPOOL 2ec712724f263d9cbd181a128a0adc22f38465447db03f1d382aa231bad98e637b27ec2e73b2acf66a5775f53b0406c82cf0cd36befdc13f6afc5434887ac040
diff --git a/games-rpg/bastion/bastion-20120620-r1.ebuild b/games-rpg/bastion/bastion-20120620-r1.ebuild
new file mode 100644
index 000000000000..3bc473de6962
--- /dev/null
+++ b/games-rpg/bastion/bastion-20120620-r1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils gnome2-utils check-reqs unpacker games
+
+TIMESTAMP=${PV:0:4}-${PV:4:2}-${PV:6:2}
+DESCRIPTION="An original action role-playing game set in a lush imaginative world"
+HOMEPAGE="http://supergiantgames.com/?page_id=242"
+SRC_URI="Bastion-HIB-${TIMESTAMP}.sh"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE=""
+RESTRICT="bindist fetch splitdebug"
+
+MYGAMEDIR=${GAMES_PREFIX_OPT}/${PN}
+QA_PREBUILT="${MYGAMEDIR#/}/Bastion.bin*
+ ${MYGAMEDIR#/}/lib/*
+ ${MYGAMEDIR#/}/lib64/*"
+
+# mono shit: vague dependencies
+RDEPEND="
+ virtual/opengl
+ media-libs/freealut
+ media-libs/openal
+ media-libs/sdl-gfx
+ media-libs/sdl-image
+ media-libs/sdl-mixer
+ media-libs/sdl-net
+ media-libs/sdl-ttf
+ media-libs/smpeg
+ x11-libs/libX11
+ x11-libs/libXft"
+
+CHECKREQS_DISK_BUILD="2400M"
+
+pkg_nofetch() {
+ einfo "Please buy & download ${SRC_URI} from:"
+ einfo " ${HOMEPAGE}"
+ einfo "and move it to ${DISTDIR}"
+}
+
+src_unpack() {
+ myarch=$(usex amd64 "x86_64" "x86")
+
+ unpack_makeself
+
+ mv instarchive_all{,.tar.lzma} || die
+ mv instarchive_linux_${myarch}{,.tar.lzma} || die
+
+ mkdir ${P} || die
+ cd ${P} || die
+
+ unpack ./../instarchive_{all,linux_${myarch}}.tar.lzma
+}
+
+src_install() {
+ insinto "${MYGAMEDIR}"
+ doins -r *
+
+ newicon -s 256 Bastion.png ${PN}.png
+ make_desktop_entry ${PN}
+ games_make_wrapper ${PN} "./Bastion.bin.${myarch}" "${MYGAMEDIR}" "${MYGAMEDIR}/$(get_libdir)"
+
+ fperms +x "${MYGAMEDIR}"/Bastion.bin.${myarch}
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ elog "If you are using opensource drivers you should consider installing:"
+ elog " media-libs/libtxc_dxtn"
+
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-rpg/bastion/metadata.xml b/games-rpg/bastion/metadata.xml
new file mode 100644
index 000000000000..01a746edb196
--- /dev/null
+++ b/games-rpg/bastion/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+</pkgmetadata>
+