summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy/wesnoth')
-rw-r--r--games-strategy/wesnoth/files/wesnothd.rc-r123
-rw-r--r--games-strategy/wesnoth/wesnoth-1.14.1-r1.ebuild (renamed from games-strategy/wesnoth/wesnoth-1.14.1.ebuild)4
2 files changed, 25 insertions, 2 deletions
diff --git a/games-strategy/wesnoth/files/wesnothd.rc-r1 b/games-strategy/wesnoth/files/wesnothd.rc-r1
new file mode 100644
index 000000000000..c1a0d9d20167
--- /dev/null
+++ b/games-strategy/wesnoth/files/wesnothd.rc-r1
@@ -0,0 +1,23 @@
+#!/sbin/openrc-run
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ use net
+}
+
+start() {
+ checkpath -q -d -m 0750 -o wesnoth:wesnoth /run/wesnothd
+ ebegin "Starting wesnothd"
+ start-stop-daemon --start --quiet -b -m \
+ --pidfile /run/wesnothd/wesnothd.pid \
+ -c wesnoth:wesnoth \
+ --exec /usr/bin/wesnothd
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping wesnothd"
+ start-stop-daemon --stop --quiet --pidfile /run/wesnothd/wesnothd.pid
+ eend $?
+}
diff --git a/games-strategy/wesnoth/wesnoth-1.14.1.ebuild b/games-strategy/wesnoth/wesnoth-1.14.1-r1.ebuild
index 7372ade39d66..5a1f6c5af2e9 100644
--- a/games-strategy/wesnoth/wesnoth-1.14.1.ebuild
+++ b/games-strategy/wesnoth/wesnoth-1.14.1-r1.ebuild
@@ -108,7 +108,7 @@ src_configure() {
src_install() {
DOCS="README.md changelog.md players_changelog.md" cmake-utils_src_install
if use dedicated || use server; then
- keepdir "/run/wesnothd"
- newinitd "${FILESDIR}"/wesnothd.rc wesnothd
+ rmdir "${ED%/}/run/wesnothd" || die
+ newinitd "${FILESDIR}"/wesnothd.rc-r1 wesnothd
fi
}