summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/bcg729/bcg729-4.3.0_beta.ebuild')
-rw-r--r--media-libs/bcg729/bcg729-4.3.0_beta.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-libs/bcg729/bcg729-4.3.0_beta.ebuild b/media-libs/bcg729/bcg729-4.3.0_beta.ebuild
new file mode 100644
index 000000000000..d2a80e7d2145
--- /dev/null
+++ b/media-libs/bcg729/bcg729-4.3.0_beta.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit cmake-utils
+
+DESCRIPTION="encoder and decoder of the ITU G729 Annex A/B speech codec"
+HOMEPAGE="https://github.com/BelledonneCommunications/bcg729"
+SRC_URI="${HOMEPAGE}/archive/${PV/_/-}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc64 ~x86"
+IUSE="static-libs"
+RDEPEND="
+ !media-plugins/mediastreamer-bcg729
+"
+S=${WORKDIR}/${P/_/-}
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.3.0_beta-cmake-build.patch
+)
+
+src_configure() {
+ mycmakeargs=(
+ -DENABLE_STATIC=$(usex static-libs)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ find "${ED}" -name '*.la' -delete || die
+}