summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/partio/partio-1.1.0_p20170829.ebuild12
-rw-r--r--media-libs/partio/partio-1.5.4.ebuild2
-rw-r--r--media-libs/partio/partio-9999.ebuild2
3 files changed, 8 insertions, 8 deletions
diff --git a/media-libs/partio/partio-1.1.0_p20170829.ebuild b/media-libs/partio/partio-1.1.0_p20170829.ebuild
index ee193c6eb05f..6302f670077d 100644
--- a/media-libs/partio/partio-1.1.0_p20170829.ebuild
+++ b/media-libs/partio/partio-1.1.0_p20170829.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
+EAPI=7
+PYTHON_COMPAT=( python3_{7,8} )
-inherit cmake-utils vcs-snapshot python-single-r1
+inherit cmake vcs-snapshot python-single-r1
DESCRIPTION="A library for particle IO and manipulation"
HOMEPAGE="https://www.disneyanimation.com/technology/partio.html"
@@ -39,16 +39,16 @@ DEPEND="${RDEPEND}
PATCHES=( "${FILESDIR}/${PN}-1.1.0-Rename-partconv.patch" )
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
sed -e '/ADD_SUBDIRECTORY (src\/tests)/d' -i CMakeLists.txt || die
}
src_configure() {
local mycmakeargs=(
- $(cmake-utils_use_find_package doc Doxygen)
+ $(cmake_use_find_package doc Doxygen)
-DCMAKE_INSTALL_DOCDIR="share/doc/${PF}"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
diff --git a/media-libs/partio/partio-1.5.4.ebuild b/media-libs/partio/partio-1.5.4.ebuild
index 0ddd8b103c2e..d4bc76916ca9 100644
--- a/media-libs/partio/partio-1.5.4.ebuild
+++ b/media-libs/partio/partio-1.5.4.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{7,8} )
inherit cmake python-single-r1
if [[ ${PV} == *9999 ]]; then
diff --git a/media-libs/partio/partio-9999.ebuild b/media-libs/partio/partio-9999.ebuild
index 6552a1f56fd1..011f45bc931b 100644
--- a/media-libs/partio/partio-9999.ebuild
+++ b/media-libs/partio/partio-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{7,8} )
inherit cmake python-single-r1
if [[ ${PV} == *9999 ]]; then