summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns/dnsmasq')
-rw-r--r--net-dns/dnsmasq/dnsmasq-2.83-r1.ebuild (renamed from net-dns/dnsmasq/dnsmasq-2.83.ebuild)8
-rw-r--r--net-dns/dnsmasq/dnsmasq-2.83-r101.ebuild (renamed from net-dns/dnsmasq/dnsmasq-2.83-r100.ebuild)8
2 files changed, 10 insertions, 6 deletions
diff --git a/net-dns/dnsmasq/dnsmasq-2.83.ebuild b/net-dns/dnsmasq/dnsmasq-2.83-r1.ebuild
index 374fe7bd87e8..99cb4bc13be5 100644
--- a/net-dns/dnsmasq/dnsmasq-2.83.ebuild
+++ b/net-dns/dnsmasq/dnsmasq-2.83-r1.ebuild
@@ -53,8 +53,10 @@ RDEPEND="${COMMON_DEPEND}
REQUIRED_USE="
dhcp-tools? ( dhcp )
+ dnssec? ( !nettlehash )
lua? ( script )
- libidn2? ( idn )"
+ libidn2? ( idn )
+"
use_have() {
local no_only
@@ -111,8 +113,8 @@ src_configure() {
$(use_have lua luascript)
$(use_have -n script)
$(use_have -n tftp)
- $(use_have -n dnssec)
- $(use_have -n nettlehash)
+ $(use_have dnssec)
+ $(use_have nettlehash)
$(use_have static dnssec_static)
$(use_have -n dumpfile)
)
diff --git a/net-dns/dnsmasq/dnsmasq-2.83-r100.ebuild b/net-dns/dnsmasq/dnsmasq-2.83-r101.ebuild
index 71ebbbf4e3e7..17dff7c71fc1 100644
--- a/net-dns/dnsmasq/dnsmasq-2.83-r100.ebuild
+++ b/net-dns/dnsmasq/dnsmasq-2.83-r101.ebuild
@@ -55,11 +55,13 @@ RDEPEND="${COMMON_DEPEND}
REQUIRED_USE="
dhcp-tools? ( dhcp )
+ dnssec? ( !nettlehash )
lua? (
script
${LUA_REQUIRED_USE}
)
- libidn2? ( idn )"
+ libidn2? ( idn )
+"
use_have() {
local no_only
@@ -116,8 +118,8 @@ src_configure() {
$(use_have lua luascript)
$(use_have -n script)
$(use_have -n tftp)
- $(use_have -n dnssec)
- $(use_have -n nettlehash)
+ $(use_have dnssec)
+ $(use_have nettlehash)
$(use_have static dnssec_static)
$(use_have -n dumpfile)
)