summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/mu')
-rw-r--r--net-mail/mu/Manifest5
-rw-r--r--net-mail/mu/files/70mu-gentoo.el3
-rw-r--r--net-mail/mu/metadata.xml14
-rw-r--r--net-mail/mu/mu-0.9.9.5.ebuild86
-rw-r--r--net-mail/mu/mu-0.9.9.6.ebuild89
-rw-r--r--net-mail/mu/mu-0.9.9.ebuild95
6 files changed, 292 insertions, 0 deletions
diff --git a/net-mail/mu/Manifest b/net-mail/mu/Manifest
new file mode 100644
index 000000000000..74307ee4b730
--- /dev/null
+++ b/net-mail/mu/Manifest
@@ -0,0 +1,5 @@
+DIST mu-0.9.9.5.tar.gz 1230322 SHA256 17e29a68c020a84441a38033067f6f538217b5d691b9c475f9593ab47ca493c3 SHA512 bd9814c670391f28a5be4b7c064f2bfc6a9428d94c88476539323688fc86df72f600cec30a87fb2b242dbeb717eb3a39c95ac09091c4c05c1886824e3052972b WHIRLPOOL bad0439b44524254a5113522cf2eafeb68604300dbc6822a9170c0ef4c336f1874428df0bfa25c7b2e7657b49d2a74cf06ce7ebb88e4e21458b87971fc178045
+DIST mu-0.9.9.6.tar.gz 2172349 SHA256 4ae4ca7f433dcfc6dfd85a41873914c1bda5c43de02ad2a030cd449f84d629cb SHA512 0213033aa7599a5120c38a4b9ec018357ebd63a3c4828e0f9d7af41529dc1b001db8d506408b0341e0efe9835fbd21dbf23c836920c98ae2caabcb0cdc7dac2b WHIRLPOOL 577e5eef5874d6cdc667e967a6722308d4e99035b8265f24030ced851d976a215bdd9ce209510a75d362af76d15116a475af6e5abb5d5be04b95f549d5ecb901
+DIST mu-0.9.9.tar.gz 1185624 SHA256 83f8e2814ba1a89a3153ab3dcd21105cc62e1386c176c5312ccb6bae0af02013 SHA512 1dc8608a77381d6ad0f26e3729f17a0c5bc2a90cbefa217159c8dc432c2bb9f7d495d08053852bf10451a3b5ac40e325ad44cb7d9f032f8337cd094b121da143 WHIRLPOOL de9406c0995bfe6592cb411eeb03b6681f79e15df0633857beb502bf2825b7974c79039298f5cf682be9e45d6237b463a5dcd3b5930ebb99456cbf0b1497890a
+DIST mu4e-manual-0.9.9.5.pdf 396250 SHA256 581d2440f79caca197ac82b6b9a9077fdae7815adc503fb6e185cef78e2a9f99 SHA512 ef9d36a1d9c7a397d89ce5a01072408165dc37b1cc7bb90658f35421cd0dfe28c8fa932cc602f5150c7947aa09c94a470924c98fcae3d9caa7d92fb1d47f7e7e WHIRLPOOL 806bd735de7e0dee31375aa956436ea67b140bd65be0bbee13a2b85b4218133efd4a87d1281307fb43107a559745ce19803cdb5d51a0e965efcc595bbdf3c605
+DIST mu4e-manual-0.9.9.pdf 379708 SHA256 75c76d736d0e3df39f654e3343cd6b5d861946bc7f570237dcd677ef79c39455 SHA512 fb8f8e94694969fc9d616177ddbb78d17b103446b2859806578255eaa954368973ef3a4fa6d8b410c8143f0b8e7ff51374f9bd3de6292fc2fd4c5cc3479b6979 WHIRLPOOL ab0ca516486bd6bab29776d665991a1c2a9120c191066b6e564b620228f81bab97b6137d1972a61c8bf5b60131755ffe6f005c99ec1d95a60ce97d4f02e2a8f2
diff --git a/net-mail/mu/files/70mu-gentoo.el b/net-mail/mu/files/70mu-gentoo.el
new file mode 100644
index 000000000000..ce445f1c559e
--- /dev/null
+++ b/net-mail/mu/files/70mu-gentoo.el
@@ -0,0 +1,3 @@
+(add-to-list 'load-path "/usr/share/emacs/site-lisp/mu4e")
+(require 'mu4e)
+
diff --git a/net-mail/mu/metadata.xml b/net-mail/mu/metadata.xml
new file mode 100644
index 000000000000..d2dfa9216a2a
--- /dev/null
+++ b/net-mail/mu/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-mail</herd>
+ <longdescription lang="en">'mu' is a set of command-line tools for Linux/Unix that enable you to quickly find the e-mails you
+are looking for, assuming that you store your e-mails in Maildirs. It also includes an emacs based mail client mu4e.</longdescription>
+ <use>
+ <flag name="gui">Build and install the experimental gui 'mug'.</flag>
+ <flag name="emacs">Install the mu4e mail client.</flag>
+ </use>
+ <upstream>
+ <remote-id type="google-code">mu0</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-mail/mu/mu-0.9.9.5.ebuild b/net-mail/mu/mu-0.9.9.5.ebuild
new file mode 100644
index 000000000000..1ed331c002c2
--- /dev/null
+++ b/net-mail/mu/mu-0.9.9.5.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit base elisp-common
+
+DESCRIPTION="Set of tools to deal with Maildirs, in particular, searching and indexing"
+HOMEPAGE="http://www.djcbsoftware.nl/code/mu/"
+SRC_URI="http://mu0.googlecode.com/files/${P}.tar.gz
+ doc? ( http://mu0.googlecode.com/files/mu4e-manual-${PV}.pdf )"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc emacs gui"
+
+# net-mail/mailutils also installes /usr/bin/mu. Block it until somebody
+# really wants both installed at the same time.
+DEPEND="
+ dev-libs/gmime:2.6
+ dev-libs/xapian
+ dev-libs/glib:2
+ gui? (
+ x11-libs/gtk+:3
+ net-libs/webkit-gtk:3 )
+ emacs? ( >=virtual/emacs-23 )
+ !net-mail/mailutils"
+RDEPEND="${DEPEND}"
+
+SITEFILE="70mu-gentoo.el"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ if use doc ; then
+ cp "${DISTDIR}"/mu4e-manual-${PV}.pdf "${S}" || die
+ fi
+}
+
+src_configure() {
+ # Todo: Make a guile USE-flag as soon as >=guile-2 is avaiable
+ # Note: --disable-silent-rules is included in EAPI-5
+ econf --disable-guile \
+ --disable-silent-rules \
+ $(use_enable gui webkit) \
+ $(use_enable gui gtk) \
+ $(use_enable emacs mu4e)
+}
+
+src_install () {
+ base_src_install
+ # Installing the guis is not supported by upstream
+ if use gui; then
+ dobin toys/mug/mug || die
+ fi
+ dodoc AUTHORS HACKING NEWS TODO README ChangeLog INSTALL
+ if use doc; then
+ dodoc mu4e-manual-${PV}.pdf
+ fi
+ if use emacs; then
+ elisp-install ${PN} mu4e/*.el mu4e/*.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+src_test () {
+ emake check
+}
+
+pkg_postinst() {
+ if use emacs; then
+ einfo "To use mu4e you need to configure it in your .emacs file"
+ einfo "See the manual for more information:"
+ einfo "http://www.djcbsoftware.nl/code/mu/mu4e/Getting-started.html"
+ fi
+
+ elog "If you upgrade from an older major version,"
+ elog "then you need to rebuild your mail index."
+
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/net-mail/mu/mu-0.9.9.6.ebuild b/net-mail/mu/mu-0.9.9.6.ebuild
new file mode 100644
index 000000000000..3cff6feb111f
--- /dev/null
+++ b/net-mail/mu/mu-0.9.9.6.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils base elisp-common
+
+DESCRIPTION="Set of tools to deal with Maildirs, in particular, searching and indexing"
+HOMEPAGE="http://www.djcbsoftware.nl/code/mu/"
+SRC_URI="https://github.com/djcb/mu/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ doc? ( http://mu0.googlecode.com/files/mu4e-manual-0.9.9.5.pdf )"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc emacs gui"
+
+# net-mail/mailutils also installes /usr/bin/mu. Block it until somebody
+# really wants both installed at the same time.
+DEPEND="
+ dev-libs/gmime:2.6
+ dev-libs/xapian
+ dev-libs/glib:2
+ gui? (
+ x11-libs/gtk+:3
+ net-libs/webkit-gtk:3 )
+ emacs? ( >=virtual/emacs-23 )
+ !net-mail/mailutils"
+RDEPEND="${DEPEND}"
+
+SITEFILE="70mu-gentoo.el"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ if use doc ; then
+ cp "${DISTDIR}"/mu4e-manual-0.9.9.5.pdf "${S}" || die
+ fi
+}
+
+src_prepare(){
+ eautoreconf
+}
+
+src_configure() {
+ # Todo: Make a guile USE-flag as soon as >=guile-2 is avaiable
+ # Note: --disable-silent-rules is included in EAPI-5
+ econf --disable-guile \
+ $(use_enable gui webkit) \
+ $(use_enable gui gtk) \
+ $(use_enable emacs mu4e)
+}
+
+src_install () {
+ base_src_install
+ # Installing the guis is not supported by upstream
+ if use gui; then
+ dobin toys/mug/mug
+ fi
+ dodoc AUTHORS HACKING NEWS TODO README ChangeLog
+ if use doc; then
+ dodoc mu4e-manual-0.9.9.5.pdf
+ fi
+ if use emacs; then
+ elisp-install ${PN} mu4e/*.el mu4e/*.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+src_test () {
+ emake check
+}
+
+pkg_postinst() {
+ if use emacs; then
+ einfo "To use mu4e you need to configure it in your .emacs file"
+ einfo "See the manual for more information:"
+ einfo "http://www.djcbsoftware.nl/code/mu/mu4e/Getting-started.html"
+ fi
+
+ elog "If you upgrade from an older major version,"
+ elog "then you need to rebuild your mail index."
+
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/net-mail/mu/mu-0.9.9.ebuild b/net-mail/mu/mu-0.9.9.ebuild
new file mode 100644
index 000000000000..2705a19cb82b
--- /dev/null
+++ b/net-mail/mu/mu-0.9.9.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit base elisp-common
+
+DESCRIPTION="Set of tools to deal with Maildirs, in particular, searching and indexing"
+HOMEPAGE="http://www.djcbsoftware.nl/code/mu/"
+SRC_URI="http://mu0.googlecode.com/files/${P}.tar.gz
+ doc? ( http://mu0.googlecode.com/files/mu4e-manual-${PV}.pdf )"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc emacs gui"
+
+# Without webkit-gtk there is no pdf-preview functionality, everything
+# else works as of 0.9.8.5
+# net-mail/mailutils also installes /usr/bin/mu. Block it until somebody
+# really wants both installed at the same time.
+DEPEND="
+ dev-libs/gmime:2.6
+ dev-libs/xapian
+ dev-libs/glib:2
+ gui? (
+ x11-libs/gtk+:3
+ net-libs/webkit-gtk:3 )
+ emacs? ( >=virtual/emacs-23 )
+ !net-mail/mailutils"
+RDEPEND="${DEPEND}"
+
+SITEFILE="70mu-gentoo.el"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ if use doc ; then
+ cp "${DISTDIR}"/mu4e-manual-${PV}.pdf "${S}" || die
+ fi
+}
+
+src_configure() {
+ local guiconf
+ if use gui; then
+ guiconf="--with-gui=gtk3"
+ else
+ guiconf="--with-gui=none"
+ fi
+
+ # Todo: Make a guile USE-flag as soon as >=guile-2 is avaiable
+ # Note: --disable-silent-rules is included in EAPI-5
+ econf --disable-guile \
+ --disable-silent-rules \
+ $(use_enable gui webkit) \
+ $(use_enable emacs mu4e) \
+ ${guiconf}
+}
+
+src_install () {
+ base_src_install
+ # Installing the guis is not supported by upstream
+ if use gui; then
+ dobin toys/mug/mug || die
+ fi
+ dodoc AUTHORS HACKING NEWS TODO README ChangeLog INSTALL
+ if use doc; then
+ dodoc mu4e-manual-${PV}.pdf
+ fi
+ if use emacs; then
+ elisp-install ${PN} mu4e/*.el mu4e/*.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+src_test () {
+ emake check
+}
+
+pkg_postinst() {
+ if use emacs; then
+ einfo "To use mu4e you need to configure it in your .emacs file"
+ einfo "See the manual for more information:"
+ einfo "http://www.djcbsoftware.nl/code/mu/mu4e/Getting-started.html"
+ fi
+
+ elog "If you upgrade from an older major version,"
+ elog "then you need to rebuild your mail index."
+
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}