summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/rss2email')
-rw-r--r--net-mail/rss2email/Manifest2
-rw-r--r--net-mail/rss2email/files/rss2email-2.69-config-location.patch16
-rw-r--r--net-mail/rss2email/metadata.xml14
-rw-r--r--net-mail/rss2email/rss2email-2.71.ebuild62
4 files changed, 94 insertions, 0 deletions
diff --git a/net-mail/rss2email/Manifest b/net-mail/rss2email/Manifest
new file mode 100644
index 000000000000..4aedd0a23a05
--- /dev/null
+++ b/net-mail/rss2email/Manifest
@@ -0,0 +1,2 @@
+DIST rss2email-2.71.tar.gz 63268 SHA256 d5245197a5034410405f1f5794610b84bf26c0c40c8d05fe0895116797a99b31
+DIST rss2email_2.65-1.diff.gz 8626 SHA256 76f599bba817ac9922993a76bdb4c444a6091e1171e58a6c89353526962b10a9
diff --git a/net-mail/rss2email/files/rss2email-2.69-config-location.patch b/net-mail/rss2email/files/rss2email-2.69-config-location.patch
new file mode 100644
index 000000000000..215c1725a9c1
--- /dev/null
+++ b/net-mail/rss2email/files/rss2email-2.69-config-location.patch
@@ -0,0 +1,16 @@
+--- rss2email.py 2010-11-25 02:22:14.607431246 +0100
++++ rss2email.py 2010-11-25 02:26:54.478306015 +0100
+@@ -254,7 +254,12 @@
+
+ # Read options from config file if present.
+ import sys
+-sys.path.insert(0,".")
++import os
++_conf_dir = os.path.expanduser('~/.rss2email')
++if not os.path.exists(os.path.join(_conf_dir, 'config.py')):
++ _conf_dir = '/etc/rss2email'
++sys.path.insert(0, _conf_dir)
++
+ try:
+ from config import *
+ except:
diff --git a/net-mail/rss2email/metadata.xml b/net-mail/rss2email/metadata.xml
new file mode 100644
index 000000000000..ab44329e146f
--- /dev/null
+++ b/net-mail/rss2email/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-mail</herd>
+ <maintainer>
+ <email>sping@gentoo.org</email>
+ <name>Sebastian Pipping</name>
+ </maintainer>
+ <longdescription>
+ rss2email is a simple Python script that lets you subscribe to a
+ list of XML newsfeeds (RSS or Atom) and get new items sent to
+ you by email.
+ </longdescription>
+</pkgmetadata>
diff --git a/net-mail/rss2email/rss2email-2.71.ebuild b/net-mail/rss2email/rss2email-2.71.ebuild
new file mode 100644
index 000000000000..aa74a26056f5
--- /dev/null
+++ b/net-mail/rss2email/rss2email-2.71.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit eutils python
+
+DEBIAN_PV="2.65"
+
+DESCRIPTION="A python script that converts RSS/Atom newsfeeds to email"
+HOMEPAGE="http://www.allthingsrss.com/rss2email"
+SRC_URI="http://www.allthingsrss.com/${PN}/${P}.tar.gz
+ mirror://debian/pool/main/r/${PN}/${PN}_${DEBIAN_PV}-1.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-util/patchutils"
+RDEPEND=">=dev-python/feedparser-5.0.1
+ >=dev-python/html2text-3.01"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.69-config-location.patch
+
+ # Extract man page from Debian patch
+ zcat "${DISTDIR}"/${PN}_${DEBIAN_PV}-1.diff.gz \
+ | filterdiff -i '*/r2e.1' \
+ > "${S}"/r2e.1.patch || die
+ EPATCH_OPTS="-p1" epatch r2e.1.patch
+}
+
+src_install() {
+ my_install() {
+ insinto "$(python_get_sitedir)"/${PN}
+ newins rss2email.py main.py || die
+ }
+ python_execute_function my_install
+
+ insinto /etc/${PN}
+ doins config.py.example || die
+
+ dodoc CHANGELOG readme.html || die
+ doman r2e.1 || die
+
+ # Replace r2e wrapper
+ cat <<-"EOF" >r2e
+ #! /bin/sh
+ SITE_PACKAGES=`python2 -c "from distutils.sysconfig import get_python_lib; print get_python_lib()"`
+ CONF_DIR=${HOME}/.rss2email
+ mkdir -p "${CONF_DIR}"
+ exec python2 "${SITE_PACKAGES}"/rss2email/main.py "${CONF_DIR}"/feeds.dat $*
+ EOF
+
+ dobin r2e || die
+}