summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-print/fax4cups')
-rw-r--r--net-print/fax4cups/Manifest1
-rw-r--r--net-print/fax4cups/fax4cups-1.29-r1.ebuild48
-rw-r--r--net-print/fax4cups/metadata.xml13
3 files changed, 62 insertions, 0 deletions
diff --git a/net-print/fax4cups/Manifest b/net-print/fax4cups/Manifest
new file mode 100644
index 000000000000..d395bd062b94
--- /dev/null
+++ b/net-print/fax4cups/Manifest
@@ -0,0 +1 @@
+DIST fax4CUPS-1.29.tar.gz 15347 BLAKE2B 7ae33ce3c60d2e6283a958bafcba9bc441dd50517bbd508050822354130d8ac02e5fbf4c1d6662e2a84962af202032bcb3b1fb26a473a65006a9b324a09ab1b6 SHA512 b3548095c58bafa3e35a4ad26f7d9fc95538bd0a94f40b248e2ab10adf726a23ff2b6a274085278ef3e0379a4f67b43e31d604491cf1a45ca0fbc163fc4a774b
diff --git a/net-print/fax4cups/fax4cups-1.29-r1.ebuild b/net-print/fax4cups/fax4cups-1.29-r1.ebuild
new file mode 100644
index 000000000000..37f2f9ce8f78
--- /dev/null
+++ b/net-print/fax4cups/fax4cups-1.29-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Fax backend for CUPS"
+HOMEPAGE="http://vigna.dsi.unimi.it/fax4CUPS/"
+SRC_URI="http://vigna.dsi.unimi.it/fax4CUPS/fax4CUPS-${PV}.tar.gz"
+S="${WORKDIR}/fax4CUPS-${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="+hylafax mgetty-fax efax"
+REQUIRED_USE="|| ( hylafax mgetty-fax efax )"
+
+DEPEND="net-print/cups"
+RDEPEND="${DEPEND}
+ || (
+ hylafax? ( net-misc/hylafaxplus )
+ efax? ( net-misc/efax )
+ mgetty-fax? ( net-dialup/mgetty )
+ )
+ app-admin/sudo
+"
+BDEPEND="net-print/cups"
+
+src_install() {
+ doman fax4CUPS.1
+
+ exeinto $(cups-config --serverbin || die)/backend
+ insinto /usr/share/cups/model
+
+ local i
+ for i in hylafax efax mgetty-fax; do
+ if use ${i}; then
+ # Backend
+ doexe ${i}
+ # PPD
+ doins ${i}.ppd
+ fi
+ done
+}
+
+pkg_postinst() {
+ elog "Please execute '${EROOT}/etc/init.d/cups restart'"
+ elog "to get the *.ppd files working properly"
+}
diff --git a/net-print/fax4cups/metadata.xml b/net-print/fax4cups/metadata.xml
new file mode 100644
index 000000000000..7d4c6c8278ba
--- /dev/null
+++ b/net-print/fax4cups/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>printing@gentoo.org</email>
+ <name>Gentoo Printing Project</name>
+</maintainer>
+<use>
+ <flag name="hylafax">Install net-misc/hylafax backend</flag>
+ <flag name="efax">Install <pkg>net-misc/efax</pkg> backend</flag>
+ <flag name="mgetty-fax">Install <pkg>net-dialup/mgetty</pkg> backend</flag>
+</use>
+</pkgmetadata>