summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/gr-ieee802154/gr-ieee802154-9999.ebuild')
-rw-r--r--net-wireless/gr-ieee802154/gr-ieee802154-9999.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/net-wireless/gr-ieee802154/gr-ieee802154-9999.ebuild b/net-wireless/gr-ieee802154/gr-ieee802154-9999.ebuild
index e99620f1b2aa..f398a0ebda3d 100644
--- a/net-wireless/gr-ieee802154/gr-ieee802154-9999.ebuild
+++ b/net-wireless/gr-ieee802154/gr-ieee802154-9999.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python2_7 )
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
inherit cmake-utils python-single-r1
@@ -14,7 +14,7 @@ if [[ ${PV} == 9999* ]]; then
EGIT_REPO_URI="https://github.com/bastibl/gr-ieee802-15-4.git"
KEYWORDS=""
else
- COMMIT="c969b3fd2059472a28dee6f911083dd03d1dd569"
+ COMMIT="a3c79af96e18de3eb3a76659e1669a370efccf17"
SRC_URI="https://github.com/bastibl/gr-ieee802-15-4/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/gr-ieee802-15-4-${COMMIT}"
KEYWORDS="~amd64 ~x86"
@@ -23,15 +23,13 @@ fi
LICENSE="GPL-3"
SLOT="0/${PV}"
-RDEPEND=">=net-wireless/gnuradio-3.7_rc:0=[${PYTHON_SINGLE_USEDEP}]
+RDEPEND="=net-wireless/gnuradio-3.8*:0=[${PYTHON_SINGLE_USEDEP}]
$(python_gen_cond_dep '
dev-libs/boost:=[${PYTHON_MULTI_USEDEP}]
')
${PYTHON_DEPS}"
DEPEND="${RDEPEND}
dev-lang/swig:0"
-#cppunit is listed in cmake, but only needed for tests and there are no tests
-# dev-util/cppunit"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
@@ -40,10 +38,14 @@ src_prepare() {
sed -i 's#FATAL_ERROR "CppUnit#MESSAGE "CppUnit#' CMakeLists.txt
sed -i '/${CPPUNIT_INCLUDE_DIRS}/d' CMakeLists.txt
sed -i '/${CPPUNIT_LIBRARY_DIRS}/d' CMakeLists.txt
+ sed -i '/GR_PKG_DOC_DIR/d' CMakeLists.txt
cmake-utils_src_prepare
}
src_configure() {
- mycmakeargs=( -DPYTHON_EXECUTABLE="${PYTHON}" )
+ mycmakeargs=(
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ -DGR_PKG_DOC_DIR="/usr/share/doc/${P}"
+ )
cmake-utils_src_configure
}