summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/pals/pals-1.0-r2.ebuild')
-rw-r--r--sci-biology/pals/pals-1.0-r2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sci-biology/pals/pals-1.0-r2.ebuild b/sci-biology/pals/pals-1.0-r2.ebuild
new file mode 100644
index 000000000000..8f251d2b82ab
--- /dev/null
+++ b/sci-biology/pals/pals-1.0-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Pairwise Aligner for Long Sequences"
+HOMEPAGE="http://www.drive5.com/pals/"
+SRC_URI="http://www.drive5.com/pals/pals_source.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.0-fix-build-system.patch )
+
+src_configure() {
+ tc-export CXX
+}
+
+src_install() {
+ dobin pals
+}