summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/clipper2/clipper2-1.4.0.ebuild')
-rw-r--r--sci-mathematics/clipper2/clipper2-1.4.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sci-mathematics/clipper2/clipper2-1.4.0.ebuild b/sci-mathematics/clipper2/clipper2-1.4.0.ebuild
new file mode 100644
index 000000000000..530396047bdf
--- /dev/null
+++ b/sci-mathematics/clipper2/clipper2-1.4.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="Clipper2"
+MY_P=${MY_PN}_${PV}
+
+inherit cmake
+
+DESCRIPTION="Polygon Clipping and Offsetting"
+HOMEPAGE="https://www.angusj.com/clipper2/Docs/Overview.htm"
+SRC_URI="https://github.com/AngusJohnson/Clipper2/archive/refs/tags/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${MY_P}/CPP"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RESTRICT="mirror"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCLIPPER2_UTILS=OFF
+ -DCLIPPER2_EXAMPLES=OFF
+ -DCLIPPER2_TESTS=OFF
+ -DCLIPPER2_USINGZ=OFF # manifold src/third_party/CMakeLists.txt
+ )
+ cmake_src_configure
+}