summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/dnotify')
-rw-r--r--sys-apps/dnotify/Manifest1
-rw-r--r--sys-apps/dnotify/dnotify-0.18.0.ebuild33
-rw-r--r--sys-apps/dnotify/files/dnotify-0.18.0-glibc-212.patch12
-rw-r--r--sys-apps/dnotify/files/dnotify-0.18.0-nls.patch10
-rw-r--r--sys-apps/dnotify/metadata.xml5
5 files changed, 61 insertions, 0 deletions
diff --git a/sys-apps/dnotify/Manifest b/sys-apps/dnotify/Manifest
new file mode 100644
index 000000000000..a0944bbb67d1
--- /dev/null
+++ b/sys-apps/dnotify/Manifest
@@ -0,0 +1 @@
+DIST dnotify-0.18.0.tar.gz 187909 RMD160 76836ad6025149d1063b20d438bd81100f818acb SHA1 47e36a7f01c65ea68e3e7955c617bd3187f4d24d SHA256 2c1a1aeb3b6471d9c17b769e86235fed4020f2009c6f6841728b94020df67bf1
diff --git a/sys-apps/dnotify/dnotify-0.18.0.ebuild b/sys-apps/dnotify/dnotify-0.18.0.ebuild
new file mode 100644
index 000000000000..74d8613ac83d
--- /dev/null
+++ b/sys-apps/dnotify/dnotify-0.18.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="Execute a command when the contents of a directory change"
+HOMEPAGE="http://directory.fsf.org/project/dnotify/"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~mips ppc -sparc x86"
+IUSE="nls"
+
+RDEPEND=""
+DEPEND="nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-nls.patch \
+ "${FILESDIR}"/${P}-glibc-212.patch
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS TODO NEWS README
+}
diff --git a/sys-apps/dnotify/files/dnotify-0.18.0-glibc-212.patch b/sys-apps/dnotify/files/dnotify-0.18.0-glibc-212.patch
new file mode 100644
index 000000000000..6cc6e6f40092
--- /dev/null
+++ b/sys-apps/dnotify/files/dnotify-0.18.0-glibc-212.patch
@@ -0,0 +1,12 @@
+http://bugs.gentoo.org/336649
+
+--- src/main.c
++++ src/main.c
+@@ -19,6 +19,7 @@
+
+ #include <config.h>
+ #include <sys/types.h>
++#include <sys/stat.h>
+ #include <sys/wait.h>
+ #include <stdarg.h>
+ #include <errno.h>
diff --git a/sys-apps/dnotify/files/dnotify-0.18.0-nls.patch b/sys-apps/dnotify/files/dnotify-0.18.0-nls.patch
new file mode 100644
index 000000000000..7721ac1ee411
--- /dev/null
+++ b/sys-apps/dnotify/files/dnotify-0.18.0-nls.patch
@@ -0,0 +1,10 @@
+--- src/gettext.h.orig 2006-01-27 18:23:31.000000000 +0100
++++ src/gettext.h 2006-01-27 18:25:07.000000000 +0100
+@@ -24,6 +24,7 @@
+
+ /* Get declarations of GNU message catalog functions. */
+ # include <libintl.h>
++# include <locale.h>
+
+ #else
+
diff --git a/sys-apps/dnotify/metadata.xml b/sys-apps/dnotify/metadata.xml
new file mode 100644
index 000000000000..96a2d586367d
--- /dev/null
+++ b/sys-apps/dnotify/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>base-system</herd>
+</pkgmetadata>