summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xsetleds')
-rw-r--r--x11-misc/xsetleds/Manifest1
-rw-r--r--x11-misc/xsetleds/files/xsetleds-0.1.3-assignment.patch11
-rw-r--r--x11-misc/xsetleds/files/xsetleds-0.1.3-isalpha.patch13
-rw-r--r--x11-misc/xsetleds/metadata.xml11
-rw-r--r--x11-misc/xsetleds/xsetleds-0.1.3-r1.ebuild34
-rw-r--r--x11-misc/xsetleds/xsetleds-0.1.3.ebuild34
6 files changed, 104 insertions, 0 deletions
diff --git a/x11-misc/xsetleds/Manifest b/x11-misc/xsetleds/Manifest
new file mode 100644
index 000000000000..652f5ea0de23
--- /dev/null
+++ b/x11-misc/xsetleds/Manifest
@@ -0,0 +1 @@
+DIST xsetleds-0.1.3.tar.gz 221399 SHA256 e844ea61a11bde39e9b46f2eacd08b88bfadd29ee7857fc0b8455357640d3b96 SHA512 7fe6baa77b4b2c8f57dfc331776bb457520facdb2f54a5c101764c590d7c5556cd00477e56d36e64cb7264a8de28698422b99ec4852798069189fbe6c1c19f72 WHIRLPOOL 1d3edc2247595f283846ea4f25bffbc226a33dc541d79af842a014e5d4f6ebe6eb8f177e4a5897e86cb6c1c559539393d662cb46d76dc8cab22a1a9f8c8b8616
diff --git a/x11-misc/xsetleds/files/xsetleds-0.1.3-assignment.patch b/x11-misc/xsetleds/files/xsetleds-0.1.3-assignment.patch
new file mode 100644
index 000000000000..bc929813a3fc
--- /dev/null
+++ b/x11-misc/xsetleds/files/xsetleds-0.1.3-assignment.patch
@@ -0,0 +1,11 @@
+--- a/src/utils.c
++++ b/src/utils.c
+@@ -38,7 +38,7 @@
+ {
+ const char *p;
+
+- if (p = strrchr (filename, '/'))
++ if ((p = strrchr (filename, '/')))
+ p = strrchr (filename, '/') + 1;
+ else
+ p = filename;
diff --git a/x11-misc/xsetleds/files/xsetleds-0.1.3-isalpha.patch b/x11-misc/xsetleds/files/xsetleds-0.1.3-isalpha.patch
new file mode 100644
index 000000000000..b256bdb2da66
--- /dev/null
+++ b/x11-misc/xsetleds/files/xsetleds-0.1.3-isalpha.patch
@@ -0,0 +1,13 @@
+--- a/src/xsetleds.c
++++ b/src/xsetleds.c
+@@ -29,8 +29,9 @@
+ #include <string.h>
+ #include <stdlib.h>
+ #include <stdarg.h>
++#include <ctype.h> /* isalpha() */
+
+-#include <xsetleds.h>
++#include "xsetleds.h"
+
+
+ struct key keytab[] = {
diff --git a/x11-misc/xsetleds/metadata.xml b/x11-misc/xsetleds/metadata.xml
new file mode 100644
index 000000000000..09b04e7fe07d
--- /dev/null
+++ b/x11-misc/xsetleds/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+ <herd>proxy-maintainers</herd>
+<maintainer>
+ <email>jss2k2@chello.no</email>
+ <name>Unknown</name>
+ <description>seemant@gentoo.org as a proxy maintainer. Please refer to jss2k2</description>
+</maintainer>
+</pkgmetadata>
diff --git a/x11-misc/xsetleds/xsetleds-0.1.3-r1.ebuild b/x11-misc/xsetleds/xsetleds-0.1.3-r1.ebuild
new file mode 100644
index 000000000000..042721f90317
--- /dev/null
+++ b/x11-misc/xsetleds/xsetleds-0.1.3-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="small tool to report and change the keyboard LED states of an X display"
+HOMEPAGE="ftp://ftp.unix-ag.org/user/bmeurer/xsetleds/"
+SRC_URI="ftp://ftp.unix-ag.org/user/bmeurer/xsetleds/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXtst
+"
+DEPEND="
+ ${RDEPEND}
+ x11-proto/inputproto
+ x11-proto/xextproto
+ x11-proto/xproto
+"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-assignment.patch \
+ "${FILESDIR}"/${P}-isalpha.patch
+ tc-export CC
+}
+
+DOCS=( AUTHORS ChangeLog README TODO )
diff --git a/x11-misc/xsetleds/xsetleds-0.1.3.ebuild b/x11-misc/xsetleds/xsetleds-0.1.3.ebuild
new file mode 100644
index 000000000000..db42b1f96781
--- /dev/null
+++ b/x11-misc/xsetleds/xsetleds-0.1.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="small tool to report and change the keyboard LED states of an X display"
+HOMEPAGE="ftp://ftp.unix-ag.org/user/bmeurer/xsetleds/"
+SRC_URI="ftp://ftp.unix-ag.org/user/bmeurer/xsetleds/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc sparc alpha hppa ~mips amd64 ia64"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXtst
+"
+DEPEND="
+ ${RDEPEND}
+ x11-proto/inputproto
+ x11-proto/xextproto
+ x11-proto/xproto
+"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-assignment.patch \
+ "${FILESDIR}"/${P}-isalpha.patch
+ tc-export CC
+}
+
+DOCS=( AUTHORS ChangeLog README TODO )