From 46b408901995189deded6cffab95bc21cf9dc4eb Mon Sep 17 00:00:00 2001
From: Marek Szuba <marecki@gentoo.org>
Date: Wed, 9 Jan 2019 11:40:10 +0000
Subject: net-p2p/syncthing: bump to 1.0.0

Note that this is *not* in fact a major version change - it is simply a
renamed 0.14.55. For details, see
https://forum.syncthing.net/t/syncthing-graduation-day/12617

Closes: https://bugs.gentoo.org/show_bug.cgi?id=674928

Signed-off-by: Marek Szuba <marecki@gentoo.org>
Package-Manager: Portage-2.3.51, Repoman-2.3.11
---
 net-p2p/syncthing/Manifest               |  1 +
 net-p2p/syncthing/syncthing-1.0.0.ebuild | 92 ++++++++++++++++++++++++++++++++
 2 files changed, 93 insertions(+)
 create mode 100644 net-p2p/syncthing/syncthing-1.0.0.ebuild

diff --git a/net-p2p/syncthing/Manifest b/net-p2p/syncthing/Manifest
index 28981de16212..a16b5b7fbe42 100644
--- a/net-p2p/syncthing/Manifest
+++ b/net-p2p/syncthing/Manifest
@@ -1,3 +1,4 @@
 DIST syncthing-0.14.38.tar.gz 8246629 BLAKE2B 93c01750fedd57cc07bffa14fe65d98fc1cf48b43eaf965fc3ff9546a24acada411a89a19b47e2f5b5e7508e57646d0560559c35bb3c378b7c04e3db14b7ffaa SHA512 be5f7527d63e8db427705c34b26d783d9abd7cb5727d3dcf08ee62b1ace5454b7dfed4f030ec53e847a34f560cf349460f68c859a1008c5105aef65ef42c5cc5
 DIST syncthing-0.14.51.tar.gz 10970620 BLAKE2B ba41debaddf217069b47901d0c43f163ff0ae3ca4aadb8689401195cfc9f11a3ed641d2d96a590821adac62d12d0ff83df26a4a336ca09476d755b8230a63c87 SHA512 d670b1df341c8da95d38170e03b40deb19dfcdf0c0df9b4630c74b4fcc979bd9a863c0ca0510e28739bac14b1aad51ce40abe695765186acad78ea0d7eb3a20c
 DIST syncthing-0.14.52.tar.gz 10583112 BLAKE2B cceaf0aba9dff96df0551d7aab855cb716be3d252fd677b82e20560f0a2e9eabf513ca7c7acdf4f1a3b4d3d8f6409692df7d2e92b86b1be1753bdd8913e06952 SHA512 cff48ea1d1286c8b1fe971b00423ad64ef10c9b0555f0cae6e008efc07a21698d54d402fe1a0ac3161c0b5180e5ca0099a0a302fd7e7c5da0f227bdb7e2853ce
+DIST syncthing-1.0.0.tar.gz 10601948 BLAKE2B f9b509b78850efb315e33afff49f8468e3ea97a4aac90752e07851604960e817dbdcdb9824f2a6174b1f066ac277a119eea5aff75f6247a43652b70a5ff4f9af SHA512 79adbce03524665d02c1ca772fdf5aca68d9e41ee4bc02bcb9ac6ed0d8dca2fe8582139f52a0fe895ad5eb15c372d686277077ff884b67de1d45419e19407603
diff --git a/net-p2p/syncthing/syncthing-1.0.0.ebuild b/net-p2p/syncthing/syncthing-1.0.0.ebuild
new file mode 100644
index 000000000000..d81107f9c516
--- /dev/null
+++ b/net-p2p/syncthing/syncthing-1.0.0.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_PN="github.com/${PN}/${PN}"
+
+inherit golang-vcs-snapshot systemd user eapi7-ver
+
+DESCRIPTION="Open Source Continuous File Synchronization"
+HOMEPAGE="https://syncthing.net"
+SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="selinux tools"
+
+RDEPEND="selinux? ( sec-policy/selinux-syncthing )"
+
+DOCS=( README.md AUTHORS CONTRIBUTING.md )
+
+pkg_setup() {
+	enewgroup ${PN}
+	enewuser ${PN} -1 -1 /var/lib/${PN} ${PN}
+
+	if use tools ; then
+		# separate user for the relay server
+		enewgroup strelaysrv
+		enewuser strelaysrv -1 -1 /var/lib/strelaysrv strelaysrv
+		# and his home folder
+		keepdir /var/lib/strelaysrv
+		fowners strelaysrv:strelaysrv /var/lib/strelaysrv
+	fi
+}
+
+src_prepare() {
+	default
+	sed -i \
+		's|^ExecStart=.*|ExecStart=/usr/libexec/syncthing/strelaysrv|' \
+		src/${EGO_PN}/cmd/strelaysrv/etc/linux-systemd/strelaysrv.service \
+		|| die
+}
+
+src_compile() {
+	export GOPATH="${S}:$(get_golibdir_gopath)"
+	cd src/${EGO_PN} || die
+	go run build.go -version "v${PV}" -no-upgrade install \
+		$(usex tools "all" "") || die "build failed"
+}
+
+src_test() {
+	cd src/${EGO_PN} || die
+	go run build.go test || die "test failed"
+}
+
+src_install() {
+	pushd src/${EGO_PN} >& /dev/null || die
+	doman man/*.[157]
+	einstalldocs
+
+	dobin bin/syncthing
+	if use tools ; then
+		exeinto /usr/libexec/syncthing
+		local exe
+		for exe in bin/* ; do
+			[[ "${exe}" == "bin/syncthing" ]] || doexe "${exe}"
+		done
+	fi
+	popd >& /dev/null || die
+
+	# openrc and systemd service files
+	systemd_dounit src/${EGO_PN}/etc/linux-systemd/system/${PN}{@,-resume}.service
+	systemd_douserunit src/${EGO_PN}/etc/linux-systemd/user/${PN}.service
+	newconfd "${FILESDIR}/${PN}.confd" ${PN}
+	newinitd "${FILESDIR}/${PN}.initd" ${PN}
+
+	keepdir /var/{lib,log}/${PN}
+	fowners ${PN}:${PN} /var/{lib,log}/${PN}
+	insinto /etc/logrotate.d
+	newins "${FILESDIR}/${PN}.logrotate" ${PN}
+
+	if use tools ; then
+		# openrc and systemd service files
+		systemd_dounit src/${EGO_PN}/cmd/strelaysrv/etc/linux-systemd/strelaysrv.service
+		newconfd "${FILESDIR}/strelaysrv.confd" strelaysrv
+		newinitd "${FILESDIR}/strelaysrv.initd" strelaysrv
+
+		insinto /etc/logrotate.d
+		newins "${FILESDIR}/strelaysrv.logrotate" strelaysrv
+	fi
+}
-- 
cgit v1.2.3-65-gdbad