From e712457ed85b518489070d27b00720b2dbba2744 Mon Sep 17 00:00:00 2001
From: Nicolas Bock <nicolasbock@gentoo.org>
Date: Wed, 27 Dec 2017 07:31:55 -0700
Subject: app-crypt/keybase: Version bump keybase-1.0.39

Package-Manager: Portage-2.3.13, Repoman-2.3.3
---
 app-crypt/kbfs/kbfs-1.0.36.ebuild | 52 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 52 insertions(+)
 create mode 100644 app-crypt/kbfs/kbfs-1.0.36.ebuild

(limited to 'app-crypt/kbfs')

diff --git a/app-crypt/kbfs/kbfs-1.0.36.ebuild b/app-crypt/kbfs/kbfs-1.0.36.ebuild
new file mode 100644
index 000000000000..b084faeb8f15
--- /dev/null
+++ b/app-crypt/kbfs/kbfs-1.0.36.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit git-r3
+
+DESCRIPTION="Keybase Filesystem (KBFS)"
+HOMEPAGE="https://keybase.io/docs/kbfs"
+EGIT_REPO_URI="https://github.com/keybase/kbfs.git"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+IUSE="git"
+
+DEPEND="
+	>=dev-lang/go-1.6:0
+	>=app-crypt/keybase-1.0.17
+	"
+RDEPEND="
+	app-crypt/gnupg
+	sys-fs/fuse
+	"
+
+S="${WORKDIR}/src/github.com/keybase/kbfs"
+
+src_unpack() {
+	git-r3_src_unpack
+	mkdir -p "$(dirname "${S}")" || die
+	ln -s "${WORKDIR}/${P}" "${S}" || die
+}
+
+src_compile() {
+	GOPATH="${WORKDIR}" \
+		go build -v -x \
+		-tags production \
+		-o "${T}/kbfsfuse" \
+		github.com/keybase/kbfs/kbfsfuse
+	use git && \
+		GOPATH="${WORKDIR}" \
+		go build -v -x \
+		-tags production \
+		-o "${T}/git-remote-keybase" \
+		github.com/keybase/kbfs/kbfsgit/git-remote-keybase
+}
+
+src_install() {
+	dobin "${T}/kbfsfuse"
+	use git && \
+		dobin "${T}/git-remote-keybase"
+}
-- 
cgit v1.2.3-65-gdbad