From 82e42fc71fbb1be48d44533ad636a144c4e451a1 Mon Sep 17 00:00:00 2001
From: Kerin Millar <kfm@plushkava.net>
Date: Sun, 4 Dec 2022 10:36:08 +0000
Subject: app-dicts/*: Apply patsub_replacement defences

Per bug #881383, string replacing forms of parameter expansion must take care
to quote - or appropriately escape - any nested parameter expansions, assuming
that their values are intended to be taken literally (as is almost invariably
the case). This has long been the case, but the introduction of the new
patsub_replacement option in bash >=5.2 has brought the issue to the fore.

In the case of the app-dicts package category, the improper quoting is not yet
causing any issues. Still, it is better to write the code properly to begin
with, especially considering the demonstrative value of robust code.

Signed-off-by: Kerin Millar <kfm@plushkava.net>
Bug: https://bugs.gentoo.org/881383
Signed-off-by: Sam James <sam@gentoo.org>
---
 app-dicts/aspell-sr/aspell-sr-0.02-r1.ebuild | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

(limited to 'app-dicts/aspell-sr')

diff --git a/app-dicts/aspell-sr/aspell-sr-0.02-r1.ebuild b/app-dicts/aspell-sr/aspell-sr-0.02-r1.ebuild
index e730744bf8f7..5223b4b3f4fc 100644
--- a/app-dicts/aspell-sr/aspell-sr-0.02-r1.ebuild
+++ b/app-dicts/aspell-sr/aspell-sr-0.02-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=8
 
 ASPELL_LANG="Serbian"
 ASPELL_VERSION=6
-MY_P="${PN/aspell/aspell${ASPELL_VERSION}}-${PV}"
+MY_P="${PN/aspell/aspell"${ASPELL_VERSION}"}-${PV}"
 
 inherit aspell-dict-r1
 
-- 
cgit v1.2.3-65-gdbad