From e7ee697a31ec4b8d90421e3aafd6bc9649675633 Mon Sep 17 00:00:00 2001
From: Florian Schmaus <flow@gentoo.org>
Date: Fri, 4 Oct 2024 22:31:17 +0200
Subject: app-office/texstudio: disable qt5 automagic

Closes: https://bugs.gentoo.org/940747
Signed-off-by: Florian Schmaus <flow@gentoo.org>
---
 app-office/texstudio/texstudio-4.8.4-r1.ebuild | 69 ++++++++++++++++++++++++++
 app-office/texstudio/texstudio-4.8.4.ebuild    | 66 ------------------------
 2 files changed, 69 insertions(+), 66 deletions(-)
 create mode 100644 app-office/texstudio/texstudio-4.8.4-r1.ebuild
 delete mode 100644 app-office/texstudio/texstudio-4.8.4.ebuild

(limited to 'app-office/texstudio')

diff --git a/app-office/texstudio/texstudio-4.8.4-r1.ebuild b/app-office/texstudio/texstudio-4.8.4-r1.ebuild
new file mode 100644
index 000000000000..43bd8a076684
--- /dev/null
+++ b/app-office/texstudio/texstudio-4.8.4-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake desktop xdg
+
+MY_PV="${PV/_/}"
+DESCRIPTION="Free cross-platform LaTeX editor (fork from texmakerX)"
+HOMEPAGE="https://www.texstudio.org https://github.com/texstudio-org/texstudio"
+SRC_URI="https://github.com/texstudio-org/texstudio/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+DEPEND="
+	app-text/hunspell:=
+	app-text/poppler:=[qt6]
+	>=dev-libs/quazip-1.0:0=[qt6(+)]
+	dev-qt/qt5compat:6
+	dev-qt/qtbase:6[concurrent,gui,network,widgets,xml]
+	dev-qt/qtdeclarative:6
+	dev-qt/qtmultimedia:6
+	dev-qt/qtsvg:6
+	dev-qt/qttools:6[widgets]
+	sys-libs/zlib
+	x11-libs/libX11
+"
+RDEPEND="
+	${DEPEND}
+	app-text/ghostscript-gpl
+	app-text/psutils
+	media-libs/netpbm
+	virtual/latex-base
+"
+BDEPEND="
+	dev-qt/qttools:6[linguist]
+	virtual/pkgconfig
+"
+
+src_prepare() {
+	local dir
+	for dir in src/quazip src/hunspell utilities/poppler-data; do
+		rm -r "${dir}" || die "Failed to delete ${dir}"
+	done
+
+	# https://bugs.gentoo.org/940747
+	sed -i 's/Qt5 //' CMakeLists.txt || die
+
+	cmake_src_prepare
+}
+
+src_configure() {
+	local mycmakeargs=(
+		-DQT_VERSION_MAJOR=6
+	)
+	cmake_src_configure
+}
+
+src_install() {
+	cmake_src_install
+
+	local i
+	for i in 16x16 22x22 32x32 48x48 64x64 128x128; do
+		newicon -s ${i} utilities/${PN}${i}.png ${PN}.png
+	done
+}
diff --git a/app-office/texstudio/texstudio-4.8.4.ebuild b/app-office/texstudio/texstudio-4.8.4.ebuild
deleted file mode 100644
index 859bcaad2a9b..000000000000
--- a/app-office/texstudio/texstudio-4.8.4.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake desktop xdg
-
-MY_PV="${PV/_/}"
-DESCRIPTION="Free cross-platform LaTeX editor (fork from texmakerX)"
-HOMEPAGE="https://www.texstudio.org https://github.com/texstudio-org/texstudio"
-SRC_URI="https://github.com/texstudio-org/texstudio/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
-
-DEPEND="
-	app-text/hunspell:=
-	app-text/poppler:=[qt6]
-	>=dev-libs/quazip-1.0:0=[qt6(+)]
-	dev-qt/qt5compat:6
-	dev-qt/qtbase:6[concurrent,gui,network,widgets,xml]
-	dev-qt/qtdeclarative:6
-	dev-qt/qtmultimedia:6
-	dev-qt/qtsvg:6
-	dev-qt/qttools:6[widgets]
-	sys-libs/zlib
-	x11-libs/libX11
-"
-RDEPEND="
-	${DEPEND}
-	app-text/ghostscript-gpl
-	app-text/psutils
-	media-libs/netpbm
-	virtual/latex-base
-"
-BDEPEND="
-	dev-qt/qttools:6[linguist]
-	virtual/pkgconfig
-"
-
-src_prepare() {
-	local dir
-	for dir in src/quazip src/hunspell utilities/poppler-data; do
-		rm -r "${dir}" || die "Failed to delete ${dir}"
-	done
-
-	cmake_src_prepare
-}
-
-src_configure() {
-	local mycmakeargs=(
-		-DQT_VERSION_MAJOR=6
-	)
-	cmake_src_configure
-}
-
-src_install() {
-	cmake_src_install
-
-	local i
-	for i in 16x16 22x22 32x32 48x48 64x64 128x128; do
-		newicon -s ${i} utilities/${PN}${i}.png ${PN}.png
-	done
-}
-- 
cgit v1.2.3-65-gdbad