From 919af65cd6e25616f2a435062cf0399669e18212 Mon Sep 17 00:00:00 2001
From: Ahmed Charles <me@ahmedcharles.com>
Date: Sun, 13 Feb 2022 22:39:27 -0600
Subject: dev-lang/lua: 5.4.4 bump

Bug: https://bugs.gentoo.org/831053
Closes: #24027
Signed-off-by: Ahmed Charles <me@ahmedcharles.com>
Signed-off-by: William Hubbs <williamh@gentoo.org>
---
 dev-lang/lua/Manifest         |   2 +
 dev-lang/lua/lua-5.4.4.ebuild | 203 ++++++++++++++++++++++++++++++++++++++++++
 2 files changed, 205 insertions(+)
 create mode 100644 dev-lang/lua/lua-5.4.4.ebuild

(limited to 'dev-lang/lua')

diff --git a/dev-lang/lua/Manifest b/dev-lang/lua/Manifest
index 142b030f57d5..9c5d059a97a0 100644
--- a/dev-lang/lua/Manifest
+++ b/dev-lang/lua/Manifest
@@ -3,3 +3,5 @@ DIST lua-5.3.4-tests.tar.gz 103438 BLAKE2B ac82708022e7729039111c3df4fe24302c8d0
 DIST lua-5.3.6.tar.gz 303770 BLAKE2B 07c37c56f43095a4f6ca8eb8b3adf19afd53107c02b62b2bcb3619565cb2100d5f823493eef93092d5e312b30fc28885a6d9e8f0ba5a23b5bed86dc4515a5d61 SHA512 ccc380d5e114d54504de0bfb0321ca25ec325d6ff1bfee44b11870b660762d1a9bf120490c027a0088128b58bb6b5271bbc648400cab84d2dc22b512c4841681
 DIST lua-5.4.2-tests.tar.gz 128901 BLAKE2B 10e4f0e8760f9cbd4761fa26665008ae7412539f79a6a7687029808f08f0ae4a24721e787e2e87e5080c16e9dcce8577a7a39ddc6d3e483a3cfe11756139594e SHA512 1516c59deca211c38444bbf97b18e988e939209b03915d3691d756eeed31b52e8d3a1f05b71ac0b561965274c7b6f3afc4244cd2e9069995696e737e2d9dd40b
 DIST lua-5.4.2.tar.gz 353472 BLAKE2B 7e0e642684df635ed1c48db45989e86a2638024e30a170addf700b0c7d32276f1eaef80898539c671039c20cb0bed4861b12c58f4b8211653a17e89bad278d87 SHA512 9454a6ffd973598f2f4a2399834c31c4d5090bd12e716776e3189aa57760319d114ee64a8338bbc2ef5e08150bf0adc2ad94a1b2677f38538a43359969d4d920
+DIST lua-5.4.4-tests.tar.gz 134094 BLAKE2B 63f5888a506f504f849fb2000cf551960df8eca3107601dcc8243e8ea5a1b13a70bff7dea4aebe3ab35b7e9df58c2ca44a7a27aa4de82240877eb8d7a017642e SHA512 08b3d764b3f362a2cddf5a23e71b16eea96a234a970fa0048bab358ebbd77f99d9bd132af12254383c5bb5426516e1ce2107e529e88d3963869255f5a41198ef
+DIST lua-5.4.4.tar.gz 360876 BLAKE2B 8747ef5c83bd4c54b73eeaad6991ab5fccc54ee000973afd9cf3367b8945f03c54e843ec88c48043003cd9d3b42281c593cb485b7165add2744cfea06d8b7668 SHA512 af0c35d5ba00fecbb2dd617bd7b825edf7418a16a73076e04f2a0df58cdbf098dc3ff4402e974afd789eb5d86d2e12ec6df9c84b99b23656ea694a85f83bcd21
diff --git a/dev-lang/lua/lua-5.4.4.ebuild b/dev-lang/lua/lua-5.4.4.ebuild
new file mode 100644
index 000000000000..b87dce6f5938
--- /dev/null
+++ b/dev-lang/lua/lua-5.4.4.ebuild
@@ -0,0 +1,203 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools multilib multilib-minimal portability toolchain-funcs
+
+DESCRIPTION="A powerful light-weight programming language designed for extending applications"
+HOMEPAGE="https://www.lua.org/"
+TEST_PV="5.4.4"
+TEST_P="${PN}-${TEST_PV}-tests"
+SRC_URI="
+	https://www.lua.org/ftp/${P}.tar.gz
+	test? ( https://www.lua.org/tests/${TEST_P}.tar.gz )"
+
+LICENSE="MIT"
+SLOT="5.4"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="+deprecated readline test test-complete"
+
+COMMON_DEPEND="
+	>=app-eselect/eselect-lua-3
+	readline? ( sys-libs/readline:0= )
+	!dev-lang/lua:0"
+# Cross-compiling note:
+# Must use libtool from the target system (DEPEND) because
+# libtool from the build system (BDEPEND) is for building
+# native binaries.
+DEPEND="
+	${COMMON_DEPEND}
+	sys-devel/libtool"
+RDEPEND="${COMMON_DEPEND}"
+
+RESTRICT="!test? ( test )"
+
+MULTILIB_WRAPPED_HEADERS=(
+	/usr/include/lua${SLOT}/luaconf.h
+)
+
+PATCHES=(
+	"${FILESDIR}"/lua-5.4.2-make.patch
+)
+
+src_prepare() {
+	default
+	# use glibtool on Darwin (versus Apple libtool)
+	if [[ ${CHOST} == *-darwin* ]] ; then
+		sed -i -e '/LIBTOOL = /s:/libtool:/glibtool:' \
+			Makefile src/Makefile || die
+	fi
+
+	# correct lua versioning
+	sed -i -e 's/\(LIB_VERSION = \)6:1:1/\10:0:0/' src/Makefile || die
+
+	sed -i -e 's:\(/README\)\("\):\1.gz\2:g' doc/readme.html || die
+
+	# Using dynamic linked lua is not recommended for performance
+	# reasons. http://article.gmane.org/gmane.comp.lang.lua.general/18519
+	# Mainly, this is of concern if your arch is poor with GPRs, like x86
+	# Note that this only affects the interpreter binary (named lua), not the lua
+	# compiler (built statically) nor the lua libraries.
+
+	# upstream does not use libtool, but we do (see bug #336167)
+	cp "${FILESDIR}/configure.in" "${S}/configure.ac" || die
+	eautoreconf
+
+	# custom Makefiles
+	multilib_copy_sources
+}
+
+multilib_src_configure() {
+	sed -i \
+		-e 's:\(define LUA_ROOT\s*\).*:\1"'${EPREFIX}'/usr/":' \
+		-e "s:\(define LUA_CDIR\s*LUA_ROOT \"\)lib:\1$(get_libdir):" \
+		src/luaconf.h \
+	|| die "failed patching luaconf.h"
+
+	econf
+}
+
+multilib_src_compile() {
+	tc-export CC
+
+	# what to link to liblua
+	liblibs="-lm"
+	liblibs="${liblibs} $(dlopen_lib)"
+
+	# what to link to the executables
+	mylibs=
+	use readline && mylibs="-lreadline"
+
+	cd src
+
+	local myCFLAGS=""
+	use deprecated && myCFLAGS+="-DLUA_COMPAT_5_3 "
+	use readline && myCFLAGS+="-DLUA_USE_READLINE "
+
+	case "${CHOST}" in
+		*-mingw*) : ;;
+		*) myCFLAGS+="-DLUA_USE_LINUX " ;;
+	esac
+
+	emake CC="${CC}" CFLAGS="${myCFLAGS} ${CFLAGS}" \
+			SYSLDFLAGS="${LDFLAGS}" \
+			RPATH="${EPREFIX}/usr/$(get_libdir)/" \
+			LUA_LIBS="${mylibs}" \
+			LIB_LIBS="${liblibs}" \
+			V=$(ver_cut 1-2) \
+			LIBTOOL="${ESYSROOT}/usr/bin/libtool" \
+			gentoo_all
+}
+
+multilib_src_install() {
+	emake INSTALL_TOP="${ED}/usr" INSTALL_LIB="${ED}/usr/$(get_libdir)" \
+			V=${SLOT} gentoo_install
+
+	case $SLOT in
+		0)
+			LIBNAME="lua"
+			INCLUDEDIR_SUFFIX=''
+			;;
+		*)	LIBNAME="lua${SLOT}"
+			INCLUDEDIR_SUFFIX="/lua${SLOT}"
+			;;
+	esac
+
+	# We want packages to find our things...
+	# A slotted Lua uses different directories for headers & names for
+	# libraries, and pkgconfig should reflect that.
+	local PATCH_PV=$(ver_cut 1-2)
+	cp "${FILESDIR}/lua.pc" "${WORKDIR}" || die
+	sed -r -i \
+		-e "/^INSTALL_INC=/s,(/include)$,\1/lua${SLOT}," \
+		-e "s:^prefix= :prefix= ${EPREFIX}:" \
+		-e "s:^V=.*:V= ${PATCH_PV}:" \
+		-e "s:^R=.*:R= ${PV}:" \
+		-e "s:/,lib,:/$(get_libdir):g" \
+		-e "/^Libs:/s:( )(-llua)($| ):\1-l${LIBNAME}\3:" \
+		-e "/^includedir=/s:include$:include${INCLUDEDIR_SUFFIX}:" \
+		"${WORKDIR}/lua.pc" || die
+
+	insinto "/usr/$(get_libdir)/pkgconfig"
+	newins "${WORKDIR}/lua.pc" "lua${SLOT}.pc"
+	# Copy Debian's symlink support:
+	# https://salsa.debian.org/lua-team/lua5.3/blob/master/debian/rules#L19
+	# FreeBSD calls the pkgconfig 'lua-5.3.pc'
+	# Older systems called it 'lua53.pc'
+	dosym "lua${SLOT}.pc" "/usr/$(get_libdir)/pkgconfig/lua-${SLOT}.pc"
+	dosym "lua${SLOT}.pc" "/usr/$(get_libdir)/pkgconfig/lua${SLOT/.}.pc"
+}
+
+multilib_src_install_all() {
+	DOCS="README"
+	HTML_DOCS="doc/*.html doc/*.png doc/*.css doc/*.gif"
+	einstalldocs
+	newman doc/lua.1 lua${SLOT}.1
+	newman doc/luac.1 luac${SLOT}.1
+	find "${ED}" -name '*.la' -delete || die
+	find "${ED}" -name 'liblua*.a' -delete || die
+}
+
+# Makefile contains a dummy target that doesn't do tests
+# but causes issues with slotted lua (bug #510360)
+src_test() {
+	debug-print-function ${FUNCNAME} "$@"
+	cd "${WORKDIR}/lua-${TEST_PV}-tests" || die
+	# https://www.lua.org/tests/
+	# There are two sets:
+	# basic
+	# complete.
+	#
+	# The basic subset is selected by passing -e'_U=true'
+	# The complete set is noted to contain tests that may consume too much memory or have non-portable tests.
+	# attrib.lua for example needs some multilib customization (have to compile the stuff in libs/ for each ABI)
+	TEST_OPTS="$(usex test-complete '' '-e_U=true')"
+	TEST_MARKER="${T}/test.failed"
+	rm -f "${TEST_MARKER}"
+
+	# If we are failing, set the marker file, and only check it after done all ABIs
+	abi_src_test() {
+		debug-print-function ${FUNCNAME} "$@"
+		TEST_LOG="${T}/test.${MULTIBUILD_ID}.log"
+		eval "${BUILD_DIR}"/src/lua${SLOT} ${TEST_OPTS} all.lua 2>&1 | tee "${TEST_LOG}" || die
+		grep -sq -e "final OK" "${TEST_LOG}" || echo "FAIL ${MULTIBUILD_ID}" >>"${TEST_MARKER}"
+		return 0
+	}
+
+	multilib_foreach_abi abi_src_test
+
+	if [ -e "${TEST_MARKER}" ]; then
+		cat "${TEST_MARKER}"
+		die "Tests failed"
+	fi
+}
+
+pkg_postinst() {
+	eselect lua set --if-unset "${PN}${SLOT}"
+
+	if has_version "app-editor/emacs"; then
+		if ! has_version "app-emacs/lua-mode"; then
+			einfo "Install app-emacs/lua-mode for lua support for emacs"
+		fi
+	fi
+}
-- 
cgit v1.2.3-65-gdbad