From 064af661d0c9a31cecdf348632bc5603333a9149 Mon Sep 17 00:00:00 2001
From: Michał Górny <mgorny@gentoo.org>
Date: Tue, 10 Dec 2019 23:02:54 +0100
Subject: */*: [QA] Fix trivial cases of MissingTestRestrict
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

The result was achieved via the following pipeline:

    pkgcheck scan -c RestrictTestCheck -R FormatReporter \
      --format '{category}/{package}/{package}-{version}.ebuild' |
    xargs -n32 grep -L RESTRICT |
    xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"'

The resulting metadata was compared before and after the change.
Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip
added by the eclass.  Two ebuilds have to be fixed because of multiline
IUSE.

Suggested-by: Robin H. Johnson <robbat2@gentoo.org>
Closes: https://github.com/gentoo/gentoo/pull/13942
Signed-off-by: Michał Górny <mgorny@gentoo.org>
---
 dev-python/deprecation/deprecation-2.0.6.ebuild | 1 +
 dev-python/deprecation/deprecation-2.0.7.ebuild | 1 +
 2 files changed, 2 insertions(+)

(limited to 'dev-python/deprecation')

diff --git a/dev-python/deprecation/deprecation-2.0.6.ebuild b/dev-python/deprecation/deprecation-2.0.6.ebuild
index 73bd41c2de64..aaf9394dc847 100644
--- a/dev-python/deprecation/deprecation-2.0.6.ebuild
+++ b/dev-python/deprecation/deprecation-2.0.6.ebuild
@@ -15,6 +15,7 @@ LICENSE="Apache-2.0"
 SLOT="0"
 KEYWORDS="~amd64 ~arm64 ~x86"
 IUSE="test"
+RESTRICT="!test? ( test )"
 
 RDEPEND="dev-python/packaging[${PYTHON_USEDEP}]"
 BDEPEND="
diff --git a/dev-python/deprecation/deprecation-2.0.7.ebuild b/dev-python/deprecation/deprecation-2.0.7.ebuild
index 7b4f8a12a278..1bb27c7c37d9 100644
--- a/dev-python/deprecation/deprecation-2.0.7.ebuild
+++ b/dev-python/deprecation/deprecation-2.0.7.ebuild
@@ -15,6 +15,7 @@ LICENSE="Apache-2.0"
 SLOT="0"
 KEYWORDS="~amd64 ~arm64 ~x86"
 IUSE="doc test"
+RESTRICT="!test? ( test )"
 
 RDEPEND="dev-python/packaging[${PYTHON_USEDEP}]"
 BDEPEND="
-- 
cgit v1.2.3-65-gdbad