From 1e6b0a07cff60174c67b7baf4546b43a99eeb10f Mon Sep 17 00:00:00 2001
From: Michał Górny <mgorny@gentoo.org>
Date: Tue, 27 Feb 2024 07:29:52 +0100
Subject: dev-python/marshmallow: Bump to 3.21.0
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

Signed-off-by: Michał Górny <mgorny@gentoo.org>
---
 dev-python/marshmallow/Manifest                  |  1 +
 dev-python/marshmallow/marshmallow-3.21.0.ebuild | 36 ++++++++++++++++++++++++
 2 files changed, 37 insertions(+)
 create mode 100644 dev-python/marshmallow/marshmallow-3.21.0.ebuild

(limited to 'dev-python/marshmallow')

diff --git a/dev-python/marshmallow/Manifest b/dev-python/marshmallow/Manifest
index 88f9a0120259..c18b24621aae 100644
--- a/dev-python/marshmallow/Manifest
+++ b/dev-python/marshmallow/Manifest
@@ -1 +1,2 @@
 DIST marshmallow-3.20.2.gh.tar.gz 183876 BLAKE2B 84cf8ca23069ad1d2353ffa9299556298457485fa459746b948835f04f92ef3949d5429e8285e084be7398fb294b3d74eba1b38ef21b469daed401f1e6affcdb SHA512 8305693405a976c53333b0c6ef074a12af4736f9620ca37c7c2ec6318fac2b19086426344ce8c2f515e95becdba8b2bb1c20aca5a9dffb4145cb27fee00dc080
+DIST marshmallow-3.21.0.gh.tar.gz 183738 BLAKE2B 9f9b9203be93e6feecbd6b7e1da32f737ba33ca8e386e062d091e20480f5241c1d73f77afd542cb24816a48aa5a948aaa20edcfe9d0fdfa847f6e405e89cff20 SHA512 d08e4eedafc1d6f2bfab463357febc75013e8a548195ab85aac55fa225f2180a4f1646d68f8586d369dd108a793086c5bb8522c7543a51540ec4ee6de5305ad3
diff --git a/dev-python/marshmallow/marshmallow-3.21.0.ebuild b/dev-python/marshmallow/marshmallow-3.21.0.ebuild
new file mode 100644
index 000000000000..2adebae08366
--- /dev/null
+++ b/dev-python/marshmallow/marshmallow-3.21.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A library for converting to and from native Python datatypes"
+HOMEPAGE="
+	https://github.com/marshmallow-code/marshmallow/
+	https://pypi.org/project/marshmallow/
+"
+SRC_URI="
+	https://github.com/marshmallow-code/marshmallow/archive/${PV}.tar.gz
+		-> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+	>=dev-python/packaging-17.0[${PYTHON_USEDEP}]
+	dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+BDEPEND="
+	test? (
+		dev-python/pytz[${PYTHON_USEDEP}]
+		dev-python/simplejson[${PYTHON_USEDEP}]
+	)
+"
+
+distutils_enable_tests pytest
-- 
cgit v1.2.3-65-gdbad