From 1750f61b002c73639f8038a8d73c0ad2b68c56d8 Mon Sep 17 00:00:00 2001
From: Michał Górny <mgorny@gentoo.org>
Date: Mon, 10 Jun 2024 16:18:50 +0200
Subject: dev-python/jupyterlab: Bump to 4.2.2
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

Signed-off-by: Michał Górny <mgorny@gentoo.org>
---
 dev-python/jupyterlab/Manifest                |  1 +
 dev-python/jupyterlab/jupyterlab-4.2.2.ebuild | 81 +++++++++++++++++++++++++++
 2 files changed, 82 insertions(+)
 create mode 100644 dev-python/jupyterlab/jupyterlab-4.2.2.ebuild

(limited to 'dev-python')

diff --git a/dev-python/jupyterlab/Manifest b/dev-python/jupyterlab/Manifest
index cd0d3ada8275..ba6bccb794b0 100644
--- a/dev-python/jupyterlab/Manifest
+++ b/dev-python/jupyterlab/Manifest
@@ -1 +1,2 @@
 DIST jupyterlab-4.2.1.tar.gz 21505297 BLAKE2B 10f3ed9a3f223623b7414f24791dfe488bc5b94a1bef8c4dae462c246c03fc265254516d39452c79a9226a44afd0fb0a8d3a1b5958f8fd34b125b79c0694e85a SHA512 0235d1561a043c75613289204242c349dcee55ae2c30e4fb3dd04ac4ca5bc13d57d13926603e46a64dcc46aeb3cbc8b5eaad56c3824760ac54e62d20d6eb2b8c
+DIST jupyterlab-4.2.2.tar.gz 21505687 BLAKE2B 3a55aa4cb51c3c8972b44793c1f65c9a773c284d3248c31b0e5e4b1ec26531cecd3504cd7e226a9e237a0783b823b71539f1ebb90a195271f9853267c367b64c SHA512 2e93bcdb0948d1db05e7053582e6a427c1f7133fbb96aa0a7205b6d6eb14e050dde1076807cedc1231e27fd9729acb7a88dff3e6369a8b300b73e093783efcd7
diff --git a/dev-python/jupyterlab/jupyterlab-4.2.2.ebuild b/dev-python/jupyterlab/jupyterlab-4.2.2.ebuild
new file mode 100644
index 000000000000..70f94aa414ed
--- /dev/null
+++ b/dev-python/jupyterlab/jupyterlab-4.2.2.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi xdg
+
+DESCRIPTION="JupyterLab computational environment"
+HOMEPAGE="
+	https://jupyter.org/
+	https://github.com/jupyterlab/jupyterlab/
+	https://pypi.org/project/jupyterlab/
+"
+
+LICENSE="BSD MIT GPL-3 Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+	dev-python/async-lru[${PYTHON_USEDEP}]
+	>=dev-python/httpx-0.25.0[${PYTHON_USEDEP}]
+	>=dev-python/ipykernel-6.5.0[${PYTHON_USEDEP}]
+	>=dev-python/jinja-3.0.3[${PYTHON_USEDEP}]
+	dev-python/jupyter-core[${PYTHON_USEDEP}]
+	>=dev-python/jupyter-lsp-2.0.0[${PYTHON_USEDEP}]
+	>=dev-python/jupyter-server-2.4.0[${PYTHON_USEDEP}]
+	<dev-python/jupyter-server-3[${PYTHON_USEDEP}]
+	>=dev-python/jupyterlab-server-2.27.1[${PYTHON_USEDEP}]
+	<dev-python/jupyterlab-server-3[${PYTHON_USEDEP}]
+	>=dev-python/notebook-shim-0.2[${PYTHON_USEDEP}]
+	dev-python/packaging[${PYTHON_USEDEP}]
+	>=dev-python/setuptools-40.0.1[${PYTHON_USEDEP}]
+	$(python_gen_cond_dep '
+		>=dev-python/tomli-1.2.2[${PYTHON_USEDEP}]
+	' 3.10)
+	>=dev-python/tornado-6.2.0[${PYTHON_USEDEP}]
+	dev-python/traitlets[${PYTHON_USEDEP}]
+	net-libs/nodejs
+"
+
+BDEPEND="
+	dev-python/hatch-jupyter-builder[${PYTHON_USEDEP}]
+	test? (
+		dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
+		>=dev-python/pytest-jupyter-0.5.3[${PYTHON_USEDEP}]
+		dev-python/pytest-tornasync[${PYTHON_USEDEP}]
+		dev-python/pytest-timeout[${PYTHON_USEDEP}]
+		dev-python/requests[${PYTHON_USEDEP}]
+		dev-python/requests-cache[${PYTHON_USEDEP}]
+		dev-python/virtualenv[${PYTHON_USEDEP}]
+	)
+"
+
+EPYTEST_DESELECT=(
+	# These tests call npm and want internet
+	jupyterlab/tests/test_jupyterlab.py::TestExtension::test_uninstall_core_extension
+	jupyterlab/tests/test_jupyterlab.py::TestExtension::test_install_and_uninstall_pinned_folder
+	jupyterlab/tests/test_jupyterlab.py::TestExtension::test_install_and_uninstall_pinned
+	jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_custom_minimal_core_config
+	jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_custom
+	jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_check
+	jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build
+	jupyterlab/tests/test_build_api.py::TestBuildAPI::test_clear
+	jupyterlab/tests/test_build_api.py::TestBuildAPI::test_build
+)
+
+EPYTEST_IGNORE=(
+	jupyterlab/tests/test_announcements.py
+)
+
+distutils_enable_tests pytest
+# TODO: package sphinx_copybutton
+#distutils_enable_sphinx docs/source dev-python/sphinx-rtd-theme dev-python/myst-parser
+
+python_install_all() {
+	distutils-r1_python_install_all
+	mv "${ED}/usr/etc" "${ED}/etc" || die
+}
-- 
cgit v1.2.3-65-gdbad