From 4ab18c0eb95f77f908684abe6e9b9a5a02cea66b Mon Sep 17 00:00:00 2001
From: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
Date: Fri, 25 Nov 2016 15:53:58 +0100
Subject: kde5.eclass: Fix install with L10N=""

---
 eclass/kde5.eclass | 16 ++++++++++------
 1 file changed, 10 insertions(+), 6 deletions(-)

(limited to 'eclass')

diff --git a/eclass/kde5.eclass b/eclass/kde5.eclass
index a6fdfa404f1c..53b5eb4d832f 100644
--- a/eclass/kde5.eclass
+++ b/eclass/kde5.eclass
@@ -500,13 +500,17 @@ kde5_src_prepare() {
 			rm -r kde-l10n-sr-${PV} || die "Failed to remove sr parent lingua"
 		fi
 
-		# add all l10n directories to cmake
 		cat <<-EOF > CMakeLists.txt || die
-project(${PN})
-cmake_minimum_required(VERSION 2.8.12)
-$(printf "add_subdirectory( %s )\n" \
-	`find . -mindepth 1 -maxdepth 1 -type d | sed -e "s:^\./::"`)
-EOF
+		project(${PN})
+		cmake_minimum_required(VERSION 2.8.12)
+		EOF
+		# add all l10n directories to cmake
+		if [[ -n ${A} ]]; then
+			cat <<-EOF >> CMakeLists.txt || die
+			$(printf "add_subdirectory( %s )\n" \
+				`find . -mindepth 1 -maxdepth 1 -type d | sed -e "s:^\./::"`)
+			EOF
+		fi
 
 		# for KF5: drop KDE4-based part; for KDE4: drop KF5-based part
 		case ${l10npart} in
-- 
cgit v1.2.3-65-gdbad