From 8e425bad1f85cff1d86e657e630c9b1d687bc7ec Mon Sep 17 00:00:00 2001
From: David Seifert <soap@gentoo.org>
Date: Sat, 21 Nov 2020 21:38:01 +0100
Subject: games-arcade/spout: Port to EAPI 7

Closes: https://bugs.gentoo.org/707266
Package-Manager: Portage-3.0.9, Repoman-3.0.2
Signed-off-by: David Seifert <soap@gentoo.org>
---
 .../spout/files/spout-1.3-fno-common.patch         | 18 ++++++++++++
 games-arcade/spout/spout-1.3-r1.ebuild             | 34 ++++++++++++----------
 2 files changed, 36 insertions(+), 16 deletions(-)
 create mode 100644 games-arcade/spout/files/spout-1.3-fno-common.patch

(limited to 'games-arcade/spout')

diff --git a/games-arcade/spout/files/spout-1.3-fno-common.patch b/games-arcade/spout/files/spout-1.3-fno-common.patch
new file mode 100644
index 000000000000..37c1098b0826
--- /dev/null
+++ b/games-arcade/spout/files/spout-1.3-fno-common.patch
@@ -0,0 +1,18 @@
+--- a/piece.c
++++ b/piece.c
+@@ -11,6 +11,7 @@
+ 
+ SDL_Surface *video, *layer;
+ SDL_Rect layerRect;
++int zoom, fullscreen;
+ 
+ unsigned char *vBuffer = NULL;
+ 
+--- a/piece.h
++++ b/piece.h
+@@ -53,4 +53,4 @@
+ 
+ int pcePadGet ();
+ 
+-int zoom, fullscreen;
++extern int zoom, fullscreen;
diff --git a/games-arcade/spout/spout-1.3-r1.ebuild b/games-arcade/spout/spout-1.3-r1.ebuild
index 876b18d55681..2057b0f1b3be 100644
--- a/games-arcade/spout/spout-1.3-r1.ebuild
+++ b/games-arcade/spout/spout-1.3-r1.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
+
 inherit desktop readme.gentoo-r1
 
 MY_P="spout-unix-${PV}"
+
 DESCRIPTION="Abstract Japanese caveflier / shooter"
 HOMEPAGE="http://freshmeat.net/projects/spout/"
 SRC_URI="http://rohanpm.net/files/old/${MY_P}.tar.bz2"
@@ -12,31 +14,31 @@ SRC_URI="http://rohanpm.net/files/old/${MY_P}.tar.bz2"
 LICENSE="LGPL-2"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
-IUSE=""
 
 DEPEND=">=media-libs/libsdl-1.2.6"
 RDEPEND="${DEPEND}"
 
 S="${WORKDIR}/${MY_P}"
 
-DISABLE_AUTOFORMATTING="yes"
-DOC_CONTENTS="
-To play in fullscreen mode, do 'spout f'.
-To play in a greater resolution, do 'spout x', where
-x is an integer; the larger x is, the higher the resolution.
-
-To play:
-* Accelerate - spacebar, enter, z, x
-* Pause - escape
-* Exit - shift+escape
-* Rotate - left or right
-"
+PATCHES=( "${FILESDIR}"/${P}-fno-common.patch )
 
 src_install() {
 	dobin spout
+	einstalldocs
+
 	doicon spout.png
 	make_desktop_entry spout "Spout"
-	einstalldocs
+
+	local DOC_CONTENTS="
+	To play in fullscreen mode, do 'spout f'.
+	To play in a greater resolution, do 'spout x', where
+	x is an integer; the larger x is, the higher the resolution.
+
+	To play:
+	* Accelerate - spacebar, enter, z, x
+	* Pause - escape
+	* Exit - shift+escape
+	* Rotate - left or right"
 	readme.gentoo_create_doc
 }
 
-- 
cgit v1.2.3-65-gdbad