From f108aece8a44161ce4f4a6b957ca737b989d11e1 Mon Sep 17 00:00:00 2001
From: "Anthony G. Basile" <blueness@gentoo.org>
Date: Fri, 23 Feb 2018 20:20:56 -0500
Subject: net-misc/ntpsec: fix config files and remove strip executables

Package-Manager: Portage-2.3.19, Repoman-2.3.6
---
 net-misc/ntpsec/metadata.xml           |   1 +
 net-misc/ntpsec/ntpsec-1.0.0-r1.ebuild | 116 +++++++++++++++++++++++++++++++++
 net-misc/ntpsec/ntpsec-1.0.0.ebuild    | 106 ------------------------------
 3 files changed, 117 insertions(+), 106 deletions(-)
 create mode 100644 net-misc/ntpsec/ntpsec-1.0.0-r1.ebuild
 delete mode 100644 net-misc/ntpsec/ntpsec-1.0.0.ebuild

(limited to 'net-misc/ntpsec')

diff --git a/net-misc/ntpsec/metadata.xml b/net-misc/ntpsec/metadata.xml
index 7bb04cc47d2c..018f5f40f71b 100644
--- a/net-misc/ntpsec/metadata.xml
+++ b/net-misc/ntpsec/metadata.xml
@@ -15,6 +15,7 @@ NTPsec project - a secure, hardened, and improved implementation of Network Time
 	<use>
 		<flag name="early">Drop root privileges early</flag>
 		<flag name="gdb">Enable debugging with gdb</flag>
+		<flag name="heat">Install contrib heat generating scripts</flag>
 		<flag name="nist">Enable lockclock</flag>
 		<flag name="ntpviz">Make visualizations of offsets, jiffies, etc.</flag>
 		<flag name="rclock_oncore">Oncore driver</flag>
diff --git a/net-misc/ntpsec/ntpsec-1.0.0-r1.ebuild b/net-misc/ntpsec/ntpsec-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..91a7ea1e911c
--- /dev/null
+++ b/net-misc/ntpsec/ntpsec-1.0.0-r1.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+PYTHON_REQ_USE='threads(+)'
+
+inherit flag-o-matic python-any-r1 waf-utils systemd user
+
+if [[ ${PV} == *9999* ]]; then
+	inherit git-r3
+	EGIT_REPO_URI="https://gitlab.com/NTPsec/ntpsec.git"
+	BDEPEND=""
+	KEYWORDS=""
+else
+	SRC_URI="ftp://ftp.ntpsec.org/pub/releases/${PN}-${PV}.tar.gz"
+	RESTRICT="mirror"
+	BDEPEND=""
+	KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="The NTP reference implementation, refactored"
+HOMEPAGE="https://www.ntpsec.org/"
+
+NTPSEC_REFCLOCK=(
+	oncore trimble truetime gpsd jjy generic spectracom
+	shm pps hpgps zyfer arbiter nmea neoclock modem
+	local)
+
+IUSE_NTPSEC_REFCLOCK=${NTPSEC_REFCLOCK[@]/#/rclock_}
+
+LICENSE="HPND MIT BSD-2 BSD CC-BY-SA-4.0"
+SLOT="0"
+IUSE="${IUSE_NTPSEC_REFCLOCK} debug doc early gdb heat libressl nist ntpviz samba seccomp smear tests" #ionice
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# net-misc/pps-tools oncore,pps
+CDEPEND="${PYTHON_DEPS}
+	${BDEPEND}
+	sys-libs/libcap
+	dev-python/psutil
+	libressl? ( dev-libs/libressl:0= )
+	!libressl? ( dev-libs/openssl:0= )
+	seccomp? ( sys-libs/libseccomp )
+"
+RDEPEND="${CDEPEND}
+	ntpviz? ( sci-visualization/gnuplot media-fonts/liberation-fonts )
+"
+DEPEND="${CDEPEND}
+	app-text/asciidoc
+	app-text/docbook-xsl-stylesheets
+	sys-devel/bison
+	rclock_oncore? ( net-misc/pps-tools )
+	rclock_pps? ( net-misc/pps-tools )
+	!net-misc/ntp
+	!net-misc/openntpd
+"
+
+pkg_setup() {
+	python-any-r1_pkg_setup
+	enewgroup ntp 123
+	enewuser ntp 123 -1 /dev/null ntp
+}
+
+src_configure() {
+	is-flagq -flto* && filter-flags -flto* -fuse-linker-plugin
+
+	local string_127=""
+	local rclocks="";
+	local CLOCKSTRING=""
+
+	for refclock in ${NTPSEC_REFCLOCK[@]} ; do
+		if use rclock_${refclock} ; then
+			string_127+="$refclock,"
+		fi
+	done
+	CLOCKSTRING="`echo ${string_127}|sed 's|,$||'`"
+
+	# Remove autostripping of binaries
+	sed -i -e '/Strip binaries/d' wscript
+
+	waf-utils_src_configure --nopyc --nopyo --refclock="${CLOCKSTRING}" \
+		$(use	doc			&& echo "--enable-doc") \
+		$(use	early		&& echo "--enable-early-droproot") \
+		$(use	gdb			&& echo "--enable-debug-gdb") \
+		$(use	nist		&& echo "--enable-lockclock") \
+		$(use	samba		&& echo "--enable-mssntp") \
+		$(use	seccomp		&& echo "--enable-seccomp") \
+		$(use	smear		&& echo "--enable-leap-smear") \
+		$(use	tests		&& echo "--alltests") \
+		$(use_enable debug debug)
+}
+
+src_install() {
+	waf-utils_src_install
+
+	# Install heat generating scripts
+	use heat && dosbin "${S}/contrib/ntpheat"{,usb}
+
+	# Install the openrc files
+	newinitd "${FILESDIR}/ntpd.rc-r1" "ntp"
+	newconfd "${FILESDIR}/ntpd.confd" "ntp"
+
+	# Install the systemd unit file
+	systemd_newunit "${FILESDIR}/ntpd.service" ntpd.service
+
+	# Install a log rotate script
+	mkdir -pv "${ED}/etc/"logrotate.d
+	cp -v "${S}/etc/logrotate-config.ntpd" "${ED}/etc/logrotate.d/ntpd"
+
+	# Install the configuration files
+	cp -Rv "${S}/etc/ntp.d/" "${ED}/etc/"
+	mv -v "${ED}/etc/ntp.d/default.conf" "${ED}/etc/ntp.conf"
+	sed "s|includefile |includefile ntp.d/|" -i "${ED}/etc/ntp.conf"
+}
diff --git a/net-misc/ntpsec/ntpsec-1.0.0.ebuild b/net-misc/ntpsec/ntpsec-1.0.0.ebuild
deleted file mode 100644
index d4cca435dbb5..000000000000
--- a/net-misc/ntpsec/ntpsec-1.0.0.ebuild
+++ /dev/null
@@ -1,106 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{4,5,6} )
-PYTHON_REQ_USE='threads(+)'
-
-inherit flag-o-matic python-any-r1 waf-utils systemd user
-
-if [[ ${PV} == *9999* ]]; then
-	inherit git-r3
-	EGIT_REPO_URI="https://gitlab.com/NTPsec/ntpsec.git"
-	BDEPEND=""
-	KEYWORDS=""
-else
-	SRC_URI="ftp://ftp.ntpsec.org/pub/releases/${PN}-${PV}.tar.gz"
-	RESTRICT="mirror"
-	BDEPEND=""
-	KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-fi
-
-DESCRIPTION="The NTP reference implementation, refactored"
-HOMEPAGE="https://www.ntpsec.org/"
-
-NTPSEC_REFCLOCK=(
-	oncore trimble truetime gpsd jjy generic spectracom
-	shm pps hpgps zyfer arbiter nmea neoclock modem
-	local)
-
-IUSE_NTPSEC_REFCLOCK=${NTPSEC_REFCLOCK[@]/#/rclock_}
-
-LICENSE="HPND MIT BSD-2 BSD CC-BY-SA-4.0"
-SLOT="0"
-IUSE="${IUSE_NTPSEC_REFCLOCK} debug doc early gdb nist ntpviz samba seccomp smear tests" #ionice
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-# net-misc/pps-tools oncore,pps
-CDEPEND="${PYTHON_DEPS}
-	${BDEPEND}
-	sys-libs/libcap
-	dev-python/psutil
-	dev-libs/openssl:*
-	seccomp? ( sys-libs/libseccomp )
-"
-RDEPEND="${CDEPEND}
-	ntpviz? ( sci-visualization/gnuplot media-fonts/liberation-fonts )
-"
-DEPEND="${CDEPEND}
-	app-text/asciidoc
-	app-text/docbook-xsl-stylesheets
-	sys-devel/bison
-	rclock_oncore? ( net-misc/pps-tools )
-	rclock_pps? ( net-misc/pps-tools )
-	!net-misc/ntp
-	!net-misc/openntpd
-"
-
-pkg_setup() {
-	python-any-r1_pkg_setup
-	enewgroup ntp 123
-	enewuser ntp 123 -1 /dev/null ntp
-}
-
-src_configure() {
-	is-flagq -flto* && filter-flags -flto* -fuse-linker-plugin
-
-	local string_127=""
-	local rclocks="";
-	local CLOCKSTRING=""
-	for refclock in ${NTPSEC_REFCLOCK[@]} ; do
-		if use  rclock_${refclock} ; then
-			string_127+="$refclock,"
-		fi
-	done
-	CLOCKSTRING="`echo ${string_127}|sed 's|,$||'`"
-	waf-utils_src_configure --nopyc --nopyo --refclock="${CLOCKSTRING}" \
-		$(use	doc		&& echo "--enable-doc") \
-		$(use	early		&& echo "--enable-early-droproot") \
-		$(use	gdb		&& echo "--enable-debug-gdb") \
-		$(use	nist		&& echo "--enable-lockclock") \
-		$(use	samba		&& echo "--enable-mssntp") \
-		$(use	seccomp		&& echo "--enable-seccomp") \
-		$(use	smear		&& echo "--enable-leap-smear") \
-		$(use	tests		&& echo "--alltests") \
-		$(use_enable debug debug)
-}
-
-src_install() {
-	waf-utils_src_install
-	mv -v "${ED}/usr/"{,share/}man
-	dosbin	"${S}/contrib/ntpheat"{,usb}
-	dodoc	"${S}/contrib/logrotate-ntpd"
-	systemd_newunit "${FILESDIR}/ntpd.service" ntpd.service
-	newinitd "${FILESDIR}/ntpd.rc-r1" "ntp"
-	newconfd "${FILESDIR}/ntpd.confd" "ntp"
-	mkdir "${ED}/etc/systemd/system/"
-	cp -v "${FILESDIR}/ntpd.service" "${ED}/etc/systemd/system/"
-	# ntpd.confd  ntpd.rc-r1  ntpd.service
-
-	mkdir -pv "${ED}/etc/"{logrotate,ntp-conf}.d
-	cp -v "${S}/etc/logrotate-config.ntpd" "${ED}/etc/logrotate.d/ntpd"
-	cp -Rv "${S}/etc/ntp.d/" "${ED}/etc/"
-	mv -v "${ED}/etc/ntp.d/example.conf" "${ED}/etc/ntp.conf"
-	sed "s|includefile |includefile ntp-conf.d/|" -i "${ED}/etc/ntp.conf"
-}
-- 
cgit v1.2.3-65-gdbad