From adf34e8306457defbc95512c3c42836a5a7b7f65 Mon Sep 17 00:00:00 2001
From: Michael Palimaka <kensington@gentoo.org>
Date: Thu, 11 Oct 2018 23:13:14 +1100
Subject: x11-misc/albert: fix build with Qt 5.11

Closes: https://bugs.gentoo.org/666998
Signed-off-by: Michael Palimaka <kensington@gentoo.org>
Package-Manager: Portage-2.3.49, Repoman-2.3.11
---
 x11-misc/albert/albert-0.14.22.ebuild              |  4 +++-
 x11-misc/albert/files/albert-0.14.22-qt-5.11.patch | 26 ++++++++++++++++++++++
 2 files changed, 29 insertions(+), 1 deletion(-)
 create mode 100644 x11-misc/albert/files/albert-0.14.22-qt-5.11.patch

(limited to 'x11-misc/albert')

diff --git a/x11-misc/albert/albert-0.14.22.ebuild b/x11-misc/albert/albert-0.14.22.ebuild
index 3eb4aa9e5eb3..7c672bb96f35 100644
--- a/x11-misc/albert/albert-0.14.22.ebuild
+++ b/x11-misc/albert/albert-0.14.22.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -34,6 +34,8 @@ RDEPEND="
 "
 DEPEND="${RDEPEND}"
 
+PATCHES=( "${FILESDIR}/${P}-qt-5.11.patch" )
+
 src_prepare() {
 	mv "${WORKDIR}"/plugins-${PLUGINS_HASH}/* "${S}"/plugins/ || die
 
diff --git a/x11-misc/albert/files/albert-0.14.22-qt-5.11.patch b/x11-misc/albert/files/albert-0.14.22-qt-5.11.patch
new file mode 100644
index 000000000000..1fa8a2fa7126
--- /dev/null
+++ b/x11-misc/albert/files/albert-0.14.22-qt-5.11.patch
@@ -0,0 +1,26 @@
+Bug: https://bugs.gentoo.org/666998
+
+From 97fdca06dc7f82c92e5bb71e05f4fd7e74bbc616 Mon Sep 17 00:00:00 2001
+From: Michael Palimaka <kensington@gentoo.org>
+Date: Thu, 11 Oct 2018 23:09:51 +1100
+Subject: [PATCH] Add missing include.
+
+---
+ lib/albertcore/src/core/telemetry.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/lib/albertcore/src/core/telemetry.cpp b/lib/albertcore/src/core/telemetry.cpp
+index 1fd6b06..09b7713 100644
+--- a/lib/albertcore/src/core/telemetry.cpp
++++ b/lib/albertcore/src/core/telemetry.cpp
+@@ -2,6 +2,7 @@
+ 
+ #include <QApplication>
+ #include <QDateTime>
++#include <QDebug>
+ #include <QJsonDocument>
+ #include <QMessageBox>
+ #include <QNetworkAccessManager>
+-- 
+2.18.1
+
-- 
cgit v1.2.3-65-gdbad