# Copyright 2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

# Auto-Generated by cargo-ebuild 0.5.4

EAPI=8

CRATES="
	adler-1.0.2
	adler32-1.2.0
	aho-corasick-0.7.18
	android_system_properties-0.1.4
	ansi_term-0.12.1
	anyhow-1.0.65
	atty-0.2.14
	autocfg-1.1.0
	bitflags-1.3.2
	bumpalo-3.12.0
	byteorder-1.4.3
	camino-1.1.1
	cargo-platform-0.1.2
	cargo_metadata-0.15.2
	cc-1.0.73
	cfg-if-1.0.0
	chrono-0.4.23
	clap-2.34.0
	core-foundation-sys-0.8.3
	coveralls-api-0.5.0
	crc32fast-1.3.2
	curl-0.4.44
	curl-sys-0.4.56+curl-7.83.1
	deflate-0.8.6
	errno-0.2.8
	errno-dragonfly-0.1.2
	fallible-iterator-0.2.0
	fastrand-1.8.0
	flate2-1.0.24
	fnv-1.0.7
	form_urlencoded-1.0.1
	gimli-0.27.1
	git2-0.16.1
	glob-0.3.1
	gzip-header-0.3.0
	hashbrown-0.11.2
	hermit-abi-0.1.19
	hermit-abi-0.2.6
	hex-0.4.3
	humantime-2.1.0
	humantime-serde-1.1.1
	iana-time-zone-0.1.46
	idna-0.2.3
	indexmap-1.8.2
	instant-0.1.12
	io-lifetimes-1.0.3
	itoa-1.0.3
	jobserver-0.1.24
	js-sys-0.3.59
	lazy_static-1.4.0
	lcov-0.8.1
	leb128-0.2.5
	libc-0.2.137
	libgit2-sys-0.14.2+1.5.1
	libssh2-sys-0.2.23
	libz-sys-1.1.8
	linux-raw-sys-0.1.3
	llvm_profparser-0.3.1
	log-0.4.17
	matchers-0.0.1
	matches-0.1.9
	md5-0.7.0
	memchr-2.5.0
	minimal-lexical-0.2.1
	miniz_oxide-0.5.3
	nix-0.26.2
	nom-7.1.1
	num-integer-0.1.45
	num-traits-0.2.15
	num_cpus-1.15.0
	object-0.26.2
	object-0.30.3
	once_cell-1.13.1
	openssl-probe-0.1.5
	openssl-src-111.22.0+1.1.1q
	openssl-sys-0.9.75
	percent-encoding-2.1.0
	pin-project-lite-0.2.9
	pkg-config-0.3.25
	proc-macro2-1.0.50
	procfs-0.14.2
	quick-error-1.2.3
	quick-xml-0.27.1
	quote-1.0.23
	redox_syscall-0.2.16
	regex-1.7.1
	regex-automata-0.1.10
	regex-syntax-0.6.27
	remove_dir_all-0.5.3
	rustc-demangle-0.1.21
	rustc_version-0.4.0
	rustix-0.36.4
	rusty-fork-0.3.0
	ryu-1.0.11
	same-file-1.0.6
	schannel-0.1.20
	semver-1.0.13
	serde-1.0.152
	serde_derive-1.0.152
	serde_json-1.0.91
	sharded-slab-0.1.4
	smallvec-1.9.0
	socket2-0.4.4
	stable_deref_trait-1.2.0
	static_assertions-1.1.0
	strsim-0.8.0
	syn-1.0.107
	tempfile-3.3.0
	textwrap-0.11.0
	thiserror-1.0.32
	thiserror-impl-1.0.32
	thread_local-1.1.4
	time-0.1.44
	tinyvec-1.6.0
	tinyvec_macros-0.1.0
	toml-0.5.11
	tracing-0.1.37
	tracing-attributes-0.1.23
	tracing-core-0.1.30
	tracing-log-0.1.3
	tracing-subscriber-0.2.25
	unicode-bidi-0.3.8
	unicode-ident-1.0.3
	unicode-normalization-0.1.21
	unicode-width-0.1.9
	url-2.2.2
	valuable-0.1.0
	vcpkg-0.2.15
	vec_map-0.8.2
	wait-timeout-0.2.0
	walkdir-2.3.2
	wasi-0.10.0+wasi-snapshot-preview1
	wasm-bindgen-0.2.82
	wasm-bindgen-backend-0.2.82
	wasm-bindgen-macro-0.2.82
	wasm-bindgen-macro-support-0.2.82
	wasm-bindgen-shared-0.2.82
	winapi-0.3.9
	winapi-i686-pc-windows-gnu-0.4.0
	winapi-util-0.1.5
	winapi-x86_64-pc-windows-gnu-0.4.0
	windows-sys-0.36.1
	windows-sys-0.42.0
	windows_aarch64_gnullvm-0.42.0
	windows_aarch64_msvc-0.36.1
	windows_aarch64_msvc-0.42.0
	windows_i686_gnu-0.36.1
	windows_i686_gnu-0.42.0
	windows_i686_msvc-0.36.1
	windows_i686_msvc-0.42.0
	windows_x86_64_gnu-0.36.1
	windows_x86_64_gnu-0.42.0
	windows_x86_64_gnullvm-0.42.0
	windows_x86_64_msvc-0.36.1
	windows_x86_64_msvc-0.42.0
"

inherit cargo

DESCRIPTION="Cargo-Tarpaulin is a tool to determine code coverage achieved via tests"
# Double check the homepage as the cargo_metadata crate
# does not provide this value so instead repository is used
HOMEPAGE="https://github.com/xd009642/tarpaulin"
SRC_URI="
	https://github.com/xd009642/tarpaulin/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz
	$(cargo_crate_uris)
"
S="${WORKDIR}/${P#cargo-}"

# License set may be more restrictive as OR is not respected
# use cargo-license for a more accurate license picture
LICENSE="0BSD Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD Boost-1.0 MIT Unicode-DFS-2016 Unlicense ZLIB"
SLOT="0"
KEYWORDS="~amd64"

QA_FLAGS_IGNORED="/usr/bin/cargo-tarpaulin"

PATCHES=(
	# integration tests require internet access
	"${FILESDIR}/cargo-tarpaulin-0.20.1-tests.patch"
	# test fails when not in a git repo
	"${FILESDIR}/cargo-tarpaulin-0.25.0-tests.patch"
)

DOCS=(
	CHANGELOG.md
	CONTRIBUTING.md
	README.md
)

src_install() {
	cargo_src_install

	dodoc "${DOCS[@]}"
}