aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlice Sell <quarkyalice@disroot.org>2022-07-07 13:04:48 -0700
committerAlice Sell <quarkyalice@disroot.org>2022-07-07 13:08:00 -0700
commit8ac2e455c466f3fc136da27a15a66069ac3e48fc (patch)
tree548234a333b9695ffc6152978b2d8390d584d804 /app-portage
downloadalicela1n-8ac2e455c466f3fc136da27a15a66069ac3e48fc.tar.gz
alicela1n-8ac2e455c466f3fc136da27a15a66069ac3e48fc.tar.bz2
alicela1n-8ac2e455c466f3fc136da27a15a66069ac3e48fc.zip
initial commit
Signed-off-by: Alice Sell <quarkyalice@disroot.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/gentoo-update/Manifest3
-rw-r--r--app-portage/gentoo-update/gentoo-update-1.3.ebuild36
-rw-r--r--app-portage/gentoo-update/gentoo-update-9999.ebuild36
-rw-r--r--app-portage/porthash/Manifest4
-rw-r--r--app-portage/porthash/files/sakaki-autosign-public-key.asc-141
-rw-r--r--app-portage/porthash/metadata.xml35
-rw-r--r--app-portage/porthash/porthash-1.0.8.ebuild37
-rw-r--r--app-portage/porthole/Manifest1
-rw-r--r--app-portage/porthole/porthole-9999.ebuild72
-rw-r--r--app-portage/showem/Manifest5
-rw-r--r--app-portage/showem/metadata.xml22
-rw-r--r--app-portage/showem/showem-1.0.3.ebuild33
-rw-r--r--app-portage/showem/showem-1.0.4.ebuild32
13 files changed, 357 insertions, 0 deletions
diff --git a/app-portage/gentoo-update/Manifest b/app-portage/gentoo-update/Manifest
new file mode 100644
index 0000000..2d0a556
--- /dev/null
+++ b/app-portage/gentoo-update/Manifest
@@ -0,0 +1,3 @@
+DIST 1.3.tar.gz 10704 BLAKE2B 0252b62c6d421b84d8385bddaf24cf03929bb80be0f3d75193681833b1285045e3b3c176482e3555601fc5da8af6a456ac6af7762891eb95ef5a2c2a516729f7 SHA512 a35fd541e87c745bb697ba88b9fcef8e37b6703d784928346749fe1f3c47c8c14dbe67ad31d470fdede46ddc3ae8a9962e0fc96a888c71dcf6e36e4411d39842
+EBUILD gentoo-update-1.3.ebuild 690 BLAKE2B 789ab3cc34fa177666089978672dd36336245199c708795f007175b2548177dc1c5994b9716805e45197e78071250660460dddf3bf495d00e95dda392655c714 SHA512 2fb0f8439defb644454b9c4df971f7bd5f5b423b4dfd33c2213620ca6d7d4f3bc08c16b0ad05851b37d6ca70a6e0fc63c45c7a7cd7e42e5c70e89beaee20a5bc
+EBUILD gentoo-update-9999.ebuild 690 BLAKE2B 789ab3cc34fa177666089978672dd36336245199c708795f007175b2548177dc1c5994b9716805e45197e78071250660460dddf3bf495d00e95dda392655c714 SHA512 2fb0f8439defb644454b9c4df971f7bd5f5b423b4dfd33c2213620ca6d7d4f3bc08c16b0ad05851b37d6ca70a6e0fc63c45c7a7cd7e42e5c70e89beaee20a5bc
diff --git a/app-portage/gentoo-update/gentoo-update-1.3.ebuild b/app-portage/gentoo-update/gentoo-update-1.3.ebuild
new file mode 100644
index 0000000..b457503
--- /dev/null
+++ b/app-portage/gentoo-update/gentoo-update-1.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Gentoo system upgrade script"
+HOMEPAGE="https://github.com/alicela1n/gentoo-update"
+
+LICENSE="GPL-2"
+SLOT="0"
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/alicela1n/gentoo-update.git"
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/alicela1n/gentoo-update/archive/${PV}.tar.gz"
+fi
+
+IUSE=""
+
+RESTRICT="mirror"
+
+S=${WORKDIR}/gentoo-update-${PV}
+
+DEPEND="
+ app-portage/eix
+ app-portage/gentoolkit
+"
+
+src_install () {
+ insinto /etc
+ doins "${S}"/gentoo-update.conf
+
+ exeinto /usr/bin
+ doexe gentoo-update
+}
diff --git a/app-portage/gentoo-update/gentoo-update-9999.ebuild b/app-portage/gentoo-update/gentoo-update-9999.ebuild
new file mode 100644
index 0000000..b457503
--- /dev/null
+++ b/app-portage/gentoo-update/gentoo-update-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Gentoo system upgrade script"
+HOMEPAGE="https://github.com/alicela1n/gentoo-update"
+
+LICENSE="GPL-2"
+SLOT="0"
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/alicela1n/gentoo-update.git"
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/alicela1n/gentoo-update/archive/${PV}.tar.gz"
+fi
+
+IUSE=""
+
+RESTRICT="mirror"
+
+S=${WORKDIR}/gentoo-update-${PV}
+
+DEPEND="
+ app-portage/eix
+ app-portage/gentoolkit
+"
+
+src_install () {
+ insinto /etc
+ doins "${S}"/gentoo-update.conf
+
+ exeinto /usr/bin
+ doexe gentoo-update
+}
diff --git a/app-portage/porthash/Manifest b/app-portage/porthash/Manifest
new file mode 100644
index 0000000..4135921
--- /dev/null
+++ b/app-portage/porthash/Manifest
@@ -0,0 +1,4 @@
+AUX sakaki-autosign-public-key.asc-1 2444 BLAKE2B 44d92ee9bcf6f97128d13b58b3c3456f75da6ee42a4a071b444440fa6a3f4099bdb278cc44ab38f6f39a8fb53803aee6ff506df4f196f05039b5763cb0c1cf83 SHA512 019b5eecedba5bdac98fd095c4f2c802ca3add43be26c9999505729e5c7760791b512c8b24e9a971ed758d50a9643872eb9980c5440dd6824d1f21fa29fadf97
+DIST porthash-1.0.8.tar.gz 18514 BLAKE2B 75e7e4d64bf1cb4b11b6398f39c0fc029a973a1eab5ad092bef03c8b35ff304b8a482fb947c965d6ac76fc361d853cde637b9df119e142868827b3ac8c383ad6 SHA512 f4f3bca852dbf5000cf330d61e1f5e951d015e8c18886a4881ede365def33f4dc578b2e66b1f9852a28b3360f599bc148c594f6e25fb5796d8799c05c0478ae1
+EBUILD porthash-1.0.8.ebuild 905 BLAKE2B e3afcba8c32403bd8c78dcb99a9a96fc9b41b6e0ae126ef3465b77088772a71a982008cc06e758cbb077514aa52fff57c2f620b38cccfbb25fc208705bda9814 SHA512 81660d4ba353e366d497251dd0f9417e11e873bd821f42a645b914087095e82d4a4a15b5f4487b54845f12b7b484c1d3ed2402ae6ded64c897073e10c7536bba
+MISC metadata.xml 1250 BLAKE2B 44d60ceab013572737a0588f7599a1af33451cbfb6220cfa702496efce533eef160cf4e4ca6c1c2a561b1a0ecd9015a214af582a1dc9dd7c5b2c6e854e0135ea SHA512 ad3bfc5fe46d2fec962966986208e06ff7c7034fd44c6cf660a07ee7bc12311ed68ba2d339f7e074323f2c3e20852e3f479d85d8c9662964384a31c02c7109fa
diff --git a/app-portage/porthash/files/sakaki-autosign-public-key.asc-1 b/app-portage/porthash/files/sakaki-autosign-public-key.asc-1
new file mode 100644
index 0000000..8195e0a
--- /dev/null
+++ b/app-portage/porthash/files/sakaki-autosign-public-key.asc-1
@@ -0,0 +1,41 @@
+-----BEGIN PGP PUBLIC KEY BLOCK-----
+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+=AIkb
+-----END PGP PUBLIC KEY BLOCK-----
diff --git a/app-portage/porthash/metadata.xml b/app-portage/porthash/metadata.xml
new file mode 100644
index 0000000..12d4927
--- /dev/null
+++ b/app-portage/porthash/metadata.xml
@@ -0,0 +1,35 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer status="active">
+ <email>sakaki@deciban.com</email>
+ <name>sakaki</name>
+</maintainer>
+<upstream>
+ <maintainer status="active">
+ <email>sakaki@deciban.com</email>
+ <name>sakaki</name>
+ </maintainer>
+ <bugs-to>mailto:sakaki@deciban.com</bugs-to>
+</upstream>
+<longdescription>
+ Simple script to save, or by default verify, a signed
+ sha512 master hash of the specified Portage repository tree
+ (by default, /usr/portage).
+
+ The cascaded ("master") hash covers the contents of all files
+ in the repository tree (excluding distfiles/..., packages/...,
+ and .git/...) together with some metadata about these files
+ and their containing directories (name, perms, type, owner,
+ and group).
+
+ It is intended to provide assurance - when distributing
+ a Portage repo snapshot (whether of main gentoo repo, or a
+ custom overlay) over an unauthenticated channel
+ (such as rsync) - that the consitutent ebuilds, manifests
+ etc. have not been tampered with in transit.
+</longdescription>
+<use>
+ <flag name='add-pubkey'>Add bundled automatic signing key into gpg.</flag>
+</use>
+</pkgmetadata>
diff --git a/app-portage/porthash/porthash-1.0.8.ebuild b/app-portage/porthash/porthash-1.0.8.ebuild
new file mode 100644
index 0000000..2e57582
--- /dev/null
+++ b/app-portage/porthash/porthash-1.0.8.ebuild
@@ -0,0 +1,37 @@
+# Copyright (c) 2017 sakaki <sakaki@deciban.com>
+# License: GPL v3+
+# NO WARRANTY
+
+EAPI=7
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc"
+
+DESCRIPTION="Compute, or verify, the signed hash of a Portage repo tree"
+BASE_SERVER_URI="https://github.com/sakaki-"
+HOMEPAGE="${BASE_SERVER_URI}/${PN}"
+SRC_URI="${BASE_SERVER_URI}/${PN}/releases/download/${PV}/${P}.tar.gz"
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="+add-pubkey"
+
+RESTRICT="mirror"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ >=app-crypt/gnupg-2.1.18
+ >=app-shells/bash-4.2"
+
+src_install() {
+ dobin "${PN}"
+ doman "${PN}.1"
+ insinto "/usr/share/${PN}"
+ newins "${FILESDIR}/sakaki-autosign-public-key.asc-1" sakaki-autosign-public-key.asc
+}
+
+pkg_postinst() {
+ if use add-pubkey; then
+ elog "Importing sakaki's autosigning public key into root keyring"
+ gpg --homedir /root/.gnupg --import "/usr/share/${PN}/sakaki-autosign-public-key.asc" || die "Failed to import public key"
+ fi
+}
+
diff --git a/app-portage/porthole/Manifest b/app-portage/porthole/Manifest
new file mode 100644
index 0000000..5122cc1
--- /dev/null
+++ b/app-portage/porthole/Manifest
@@ -0,0 +1 @@
+EBUILD porthole-9999.ebuild 1714 BLAKE2B 049b63e3ff7b3905979ae924979765a02bf49b39840211b70278dcc1be17eded975b73fca70338f53c8243ac7fdf0e807305354572d1b7b4182d27bc4da8ad31 SHA512 8fc6ffa96ba0ad28a77ac59d1a421b0c26889997ea56f4c8dbbf314ae1d0c8fe8e4efa21ae7094c132795913ec10693ab9db6c8c635c8e89371c8c4ffdf1042f
diff --git a/app-portage/porthole/porthole-9999.ebuild b/app-portage/porthole/porthole-9999.ebuild
new file mode 100644
index 0000000..9ea16a4
--- /dev/null
+++ b/app-portage/porthole/porthole-9999.ebuild
@@ -0,0 +1,72 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A fork of porthole rewritten for python 3"
+HOMEPAGE="https://gitlab.com/quarkyalice/porthole"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+inherit distutils-r1
+inherit python-r1
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/quarkyalice/porthole.git"
+else
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~sparc ~x86"
+fi
+
+RESTRICT="mirror"
+
+S=${WORKDIR}/porthole-${PV}
+
+RDEPEND="
+ dev-lang/python
+ sys-apps/portage
+ gnome-base/libglade
+ dev-python/beautifulsoup4
+ x11-libs/gtksourceview
+"
+DEPEND="${RDEPEND}
+"
+
+src_install() {
+ distutils-r1_src_install
+
+ dodoc TODO README NEWS AUTHORS
+
+ keepdir /var/log/porthole
+ fperms g+w /var/log/porthole
+ keepdir /var/db/porthole
+ fperms g+w /var/db/porthole
+
+ rm -rf "${D}/usr/share/${PN}"/{pocompile,dopot}.sh
+}
+
+python_install() {
+ distutils-r1_python_install
+ python_doexe scripts/porthole
+
+ cp -rv "${WORKDIR}/porthole-${PV}/scripts" \
+ "${D}/usr/lib/python3.9/site-packages/porthole-0.7.0-py3.9.egg-info"
+}
+
+pkg_preinst() {
+ chgrp portage "${D}"/var/log/porthole
+ chgrp portage "${D}"/var/db/porthole
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Porthole has updated the way that the upgrades are sent to emerge."
+ einfo "In this new way the user needs to set any 'Settings' menu emerge options"
+ einfo "Porthole automatically adds '--oneshot' for all upgrades selections"
+ einfo "Other options recommended are '--noreplace' along with '--update'"
+ einfo "They allow for portage to skip any packages that might have already"
+ einfo "been upgraded as a dependency of another previously upgraded package"
+ einfo
+}
diff --git a/app-portage/showem/Manifest b/app-portage/showem/Manifest
new file mode 100644
index 0000000..03dd015
--- /dev/null
+++ b/app-portage/showem/Manifest
@@ -0,0 +1,5 @@
+DIST 1.0.4.tar.gz 16824 BLAKE2B 288d8ac3e4ef0aac81a3932e8b77cb1e8430aca75dccf7963e59d0742103785aa989e428686aebfa723b8835f901fd948eea06d53d8e318a241cade2a5c202ec SHA512 d0b612ef21c5854c758cce8a43f994f70413506877ce3db86b4d75f3cd5b7c31ce1584d3528c386d7c34920a4842dc2d272de71f606fc1f9436b07e5c9ec0634
+DIST showem-1.0.3.tar.gz 16581 BLAKE2B acbb043c05dc1b1bd6f28036e813cd9069d5a7f88da5b90707f58170100761397e56b83fb292e31e5487469b8ed202f096deea79e42c736a23c803b0e36a71d3 SHA512 333dd83e98c028618996ba6b392d419bf6b9399200e2d22952c36da6ae57793d521edef0c16dfe01b0adb5c106e969b5288e89514c59f0a36cfe1e4e654aab4d
+EBUILD showem-1.0.3.ebuild 654 BLAKE2B 766b2a99844efb69df3137514029046c7b1eeba2c06d67a9212d1a20a442488252896f980ebd2e5891fd5074663fc6da248d730b19a776e2d51c8e618cd92df6 SHA512 4b182aa3165a3f52a35516c0cb4f97891fc1a486250f90f7bbf47926837519ea06ebead7736659cce0ce0d702cac1493c1717ecd2c5b4ef821bf7eaa646cd2a0
+EBUILD showem-1.0.4.ebuild 659 BLAKE2B 51774956925783aacacc55773c192e845462766d30e0440d50b3863bb3e5efe5873fad3f367ab0290be10a7d1bda96f8910dd643fea3f3dd115be53cb0139ce9 SHA512 aea0180763d37c4446e78d209c4362e1295291c67897b990d0f27ca7325d9b0dfd6bd5b8f60f184a53d223abe5d1155395e9f8ba99c4c29e52a5fd600be95e86
+MISC metadata.xml 780 BLAKE2B e40d7b7ba957104e37d8e4a8d83590c06dbcddd893f2b7a425c8a9ebd7c4b0d4cbf9fe876dd5e181c65b48af7aa5b5c23ddc106b787815455e995cf76d633bde SHA512 ce8e68776e1ccddfc31f07d660df59623afeff35bec16d2b736065720da4a735d1e2b8ccc97cfa2e799c75a8cfdee3e8acc79e59bc7879e05f313f7af76d9a7f
diff --git a/app-portage/showem/metadata.xml b/app-portage/showem/metadata.xml
new file mode 100644
index 0000000..107a5d6
--- /dev/null
+++ b/app-portage/showem/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer status="active">
+ <email>sakaki@deciban.com</email>
+ <name>sakaki</name>
+</maintainer>
+<upstream>
+ <maintainer status="active">
+ <email>sakaki@deciban.com</email>
+ <name>sakaki</name>
+ </maintainer>
+ <bugs-to>mailto:sakaki@deciban.com</bugs-to>
+</upstream>
+<longdescription>
+ This is a very simple utility script, which allows you to monitor the
+ progress of a parallel emerge. When invoked, it shows a split-screen
+ display, which updates once a second. The top part shows the tail of
+ the current Portage download log, and the lower part shows the tail
+ of the most recent Portage build log.
+</longdescription>
+</pkgmetadata>
diff --git a/app-portage/showem/showem-1.0.3.ebuild b/app-portage/showem/showem-1.0.3.ebuild
new file mode 100644
index 0000000..c670b14
--- /dev/null
+++ b/app-portage/showem/showem-1.0.3.ebuild
@@ -0,0 +1,33 @@
+# ebuild for showem (a simple emerge progress viewer)
+# Copyright (c) 2015 sakaki <sakaki@deciban.com>
+# License: GPL v2
+# NO WARRANTY
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="View output of a parallel emerge from a separate terminal"
+BASE_SERVER_URI="https://github.com/sakaki-"
+HOMEPAGE="${BASE_SERVER_URI}/${PN}"
+SRC_URI="${BASE_SERVER_URI}/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~arm ~ppc"
+
+RESTRICT="mirror"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ >=sys-libs/ncurses-5.9-r2
+ >=app-shells/bash-4.2"
+
+# ebuild function overrides
+src_prepare() {
+ epatch_user
+}
+src_install() {
+ dobin "${PN}"
+ doman "${PN}.1"
+}
diff --git a/app-portage/showem/showem-1.0.4.ebuild b/app-portage/showem/showem-1.0.4.ebuild
new file mode 100644
index 0000000..3a55a0f
--- /dev/null
+++ b/app-portage/showem/showem-1.0.4.ebuild
@@ -0,0 +1,32 @@
+# ebuild for showem (a simple emerge progress viewer)
+# Copyright (c) 2015 sakaki <sakaki@deciban.com>
+# (c) 2021 quarkyalice <quarkyalice@disroot.org>
+# License: GPL v2
+# NO WARRANTY
+
+EAPI=7
+
+inherit eutils
+
+DESCRIPTION="View output of a parallel emerge from a separate terminal"
+BASE_SERVER_URI="https://github.com/alicela1n"
+HOMEPAGE="${BASE_SERVER_URI}/${PN}"
+SRC_URI="${BASE_SERVER_URI}/${PN}/archive/${PV}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~arm ~ppc"
+
+RESTRICT="mirror"
+
+S=${WORKDIR}/${PN}-${PV}
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ >=sys-libs/ncurses-5.9-r2
+ >=app-shells/bash-4.2"
+
+src_install() {
+ dobin "${PN}"
+ doman "${PN}.1"
+}