aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlice Sell <quarkyalice@disroot.org>2022-07-07 13:04:48 -0700
committerAlice Sell <quarkyalice@disroot.org>2022-07-07 13:08:00 -0700
commit8ac2e455c466f3fc136da27a15a66069ac3e48fc (patch)
tree548234a333b9695ffc6152978b2d8390d584d804 /sys-boot/preloader-signed/preloader-signed-20130208.ebuild
downloadalicela1n-8ac2e455c466f3fc136da27a15a66069ac3e48fc.tar.gz
alicela1n-8ac2e455c466f3fc136da27a15a66069ac3e48fc.tar.bz2
alicela1n-8ac2e455c466f3fc136da27a15a66069ac3e48fc.zip
initial commit
Signed-off-by: Alice Sell <quarkyalice@disroot.org>
Diffstat (limited to 'sys-boot/preloader-signed/preloader-signed-20130208.ebuild')
-rw-r--r--sys-boot/preloader-signed/preloader-signed-20130208.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-boot/preloader-signed/preloader-signed-20130208.ebuild b/sys-boot/preloader-signed/preloader-signed-20130208.ebuild
new file mode 100644
index 0000000..622a6b2
--- /dev/null
+++ b/sys-boot/preloader-signed/preloader-signed-20130208.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Linux Foundation UEFI secure boot system (prebuilt X64 EFI binaries)"
+HOMEPAGE=""
+SRC_URI="
+ https://blog.hansenpartnership.com/wp-uploads/2013/PreLoader.efi
+ https://blog.hansenpartnership.com/wp-uploads/2013/HashTool.efi
+"
+
+RESTRICT="mirror"
+
+LICENSE="LGPL2.1"
+SLOT="0"
+KEYWORDS="amd64"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+S="${DISTDIR}"
+
+src_install() {
+ insinto /usr/share/preloader-signed
+ doins *.efi
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Installed into /usr/share/preloader-signed/PreLoader.efi"
+ einfo "/usr/share/preloader-signed/HashTool.efi"
+ einfo
+}