aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-pda/libirecovery/libirecovery-1.0.0.ebuild')
-rw-r--r--app-pda/libirecovery/libirecovery-1.0.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-pda/libirecovery/libirecovery-1.0.0.ebuild b/app-pda/libirecovery/libirecovery-1.0.0.ebuild
new file mode 100644
index 0000000..d644125
--- /dev/null
+++ b/app-pda/libirecovery/libirecovery-1.0.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2018-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="Library and utility to talk to iBoot/iBSS via USB."
+HOMEPAGE="https://github.com/libimobiledevice/libirecovery"
+SRC_URI="https://github.com/libimobiledevice/${PN}/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~arm ~arm64"
+IUSE="udev"
+
+RESTRICT="mirror"
+
+DEPEND="sys-libs/readline
+ virtual/libusb:1"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ myconf=$(use_with udev)
+ econf "${myconf}"
+}