aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/uefitool/uefitool-0.28.0.ebuild')
-rw-r--r--dev-util/uefitool/uefitool-0.28.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-util/uefitool/uefitool-0.28.0.ebuild b/dev-util/uefitool/uefitool-0.28.0.ebuild
new file mode 100644
index 0000000..7514fc9
--- /dev/null
+++ b/dev-util/uefitool/uefitool-0.28.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils
+
+DESCRIPTION="UEFI firmware image viewer and editor"
+HOMEPAGE="https://github.com/LongSoft/UEFITool"
+SRC_URI="https://github.com/LongSoft/UEFITool/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+RESTRICT="mirror"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="
+ ${RDEPEND}
+ dev-qt/qtcore:5
+"
+
+S="${WORKDIR}/UEFITool-${PV}"
+
+src_configure() {
+ eqmake5 .
+}
+
+src_install() {
+ dobin UEFITool
+}