aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/coreboot-utils/Manifest4
-rw-r--r--sys-apps/coreboot-utils/coreboot-utils-4.14.ebuild51
-rw-r--r--sys-apps/coreboot-utils/files/coreboot-utils-4.14-fix-install-path.patch39
-rw-r--r--sys-apps/coreboot-utils/metadata.xml14
-rw-r--r--sys-apps/me_cleaner/Manifest3
-rw-r--r--sys-apps/me_cleaner/me_cleaner-1.2-r1.ebuild30
-rw-r--r--sys-apps/me_cleaner/metadata.xml18
7 files changed, 159 insertions, 0 deletions
diff --git a/sys-apps/coreboot-utils/Manifest b/sys-apps/coreboot-utils/Manifest
new file mode 100644
index 0000000..543b7c0
--- /dev/null
+++ b/sys-apps/coreboot-utils/Manifest
@@ -0,0 +1,4 @@
+AUX coreboot-utils-4.14-fix-install-path.patch 1214 BLAKE2B abf70ee31a747528e9855fbbb000acee23d2f175bb0cd20823a28e284d674b06313c0d5bdfe4e3f017af6befad70ba369aaba772f16aa11f741d1ec5bfe2001f SHA512 9d7ed819220328a58cb15d4f5a28d171453db7cc93a706acd644718b54aec46a431510a84909370a84574e53660285b3981f4a828e1c70802e6cdf2e16e16f63
+DIST coreboot-utils-4.14.tar.xz 52485764 BLAKE2B b13529680f38ae7295b7812ec7e9b0d2ba4ca1ab07a934f99b7cfd8deec442f345ce083e02611d78236a9371a34008582e3ec01579c2906bf23df301e15ffc67 SHA512 14c615472dfe00682e4b0b41b6a04ed3b201395427350f7b53497152f2acc8cbef8144bad06517b413c4076422108bccab2e4732491f5e6fcc4703b14d062b19
+EBUILD coreboot-utils-4.14.ebuild 1024 BLAKE2B f07a67db719902d28e81a0138e9489d741003aa5d744d73eb1a565cab3cd14d2901b8be20255becd627283f673f79a7fd83fc6cb0e9f905eed3f5850e8b9376f SHA512 d2a353e7c418815b65231a2c27e52b9bbd795676e40730e273e6136e601c0a455a30ff2911cb95e39585bf6e30156902699701eeffb496f1ea23d6414b33d7e8
+MISC metadata.xml 495 BLAKE2B 823c4f0d25adcd05266b03c49c45c7e3dbf05fc17c05b40235ad0c22eab9ef2ae29890f5fe9d176b4706da308c8a473e9920971b05596c8d296ace143f70a0d2 SHA512 f98d0261a30ffa6be66311716c5ed23e95c0f26e79b519d7b71bce514e78e7e36e2e93a813eff0a8fad37ce55d93144ae044e494af95f04b197fa30ca3eb29f1
diff --git a/sys-apps/coreboot-utils/coreboot-utils-4.14.ebuild b/sys-apps/coreboot-utils/coreboot-utils-4.14.ebuild
new file mode 100644
index 0000000..9b7851d
--- /dev/null
+++ b/sys-apps/coreboot-utils/coreboot-utils-4.14.ebuild
@@ -0,0 +1,51 @@
+# Copyright (c) 2017 sakaki <sakaki@deciban.com>
+# (c) 2021 quarkyalice <quarkyalice@disroot.org>
+# License: GPL v3+
+# NO WARRANTY
+
+EAPI=8
+inherit toolchain-funcs
+
+KEYWORDS="~amd64 ~arm ~arm64"
+
+DESCRIPTION="Selected utilities from the coreboot project"
+HOMEPAGE="https://www.coreboot.org"
+SRC_URI="https://coreboot.org/releases/coreboot-${PV}.tar.xz -> ${P}.tar.xz"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+RESTRICT="mirror"
+
+S="${WORKDIR}/coreboot-${PV}"
+
+DEPEND="amd64? ( >=sys-apps/pciutils-3.4.1 )
+ "
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-fix-install-path.patch" )
+
+src_compile() {
+ cd "${S}/util/cbfstool"
+ emake clean
+ emake
+ cd "${S}/util/ifdtool"
+ emake clean
+ emake
+ if use amd64; then
+ # intelmetool has a slightly nicer Makefile
+ cd "${S}/util/intelmetool"
+ emake clean
+ emake
+ fi
+}
+
+src_install() {
+ cd "${S}/util/cbfstool"
+ emake DESTDIR="${D}" install
+ cd "${S}/util/ifdtool"
+ emake DESTDIR="${D}" install
+ if use amd64; then
+ cd "${S}/util/intelmetool"
+ emake DESTDIR="${D}" install
+ fi
+}
diff --git a/sys-apps/coreboot-utils/files/coreboot-utils-4.14-fix-install-path.patch b/sys-apps/coreboot-utils/files/coreboot-utils-4.14-fix-install-path.patch
new file mode 100644
index 0000000..87a9900
--- /dev/null
+++ b/sys-apps/coreboot-utils/files/coreboot-utils-4.14-fix-install-path.patch
@@ -0,0 +1,39 @@
+diff --git a/util/cbfstool/Makefile b/util/cbfstool/Makefile
+index 7ef46a72..2b61a5de 100644
+--- a/util/cbfstool/Makefile
++++ b/util/cbfstool/Makefile
+@@ -4,7 +4,7 @@ objutil ?= $(top)/util
+ CONFIG_FMD_GENPARSER ?= n
+
+ HOSTCC ?= $(CC)
+-PREFIX ?= /usr/local
++PREFIX ?= /usr
+ BINDIR ?= $(PREFIX)/bin
+ INSTALL ?= /usr/bin/env install
+ OBJCOPY ?= objcopy
+diff --git a/coreboot-4.14/util/ifdtool/Makefile b/util/ifdtool/Makefile
+index e8d818c0..9f56cff3 100644
+--- a/util/ifdtool/Makefile
++++ b/util/ifdtool/Makefile
+@@ -6,7 +6,7 @@ PROGRAM = ifdtool
+
+ CC ?= gcc
+ INSTALL = /usr/bin/env install
+-PREFIX = /usr/local
++PREFIX = /usr
+ CFLAGS = -O2 -g -Wall -Wextra -Wmissing-prototypes -Werror
+ CFLAGS += -I../../src/commonlib/include -I../../src/commonlib/bsd/include
+ CFLAGS += -I../cbfstool/flashmap
+diff --git a/util/intelmetool/Makefile b/util/intelmetool/Makefile
+index a97f380d..8b48bcda 100644
+--- a/util/intelmetool/Makefile
++++ b/util/intelmetool/Makefile
+@@ -4,7 +4,7 @@ PROGRAM = intelmetool
+
+ CC ?= gcc
+ INSTALL ?= /usr/bin/env install
+-PREFIX ?= /usr/local
++PREFIX ?= /usr
+ CFLAGS ?= -O0 -g -Wall -Wextra -Wno-unused-parameter -Wno-sign-compare -Wno-unused-function
+ LDFLAGS += -lpci -lz
+
diff --git a/sys-apps/coreboot-utils/metadata.xml b/sys-apps/coreboot-utils/metadata.xml
new file mode 100644
index 0000000..2ef3b9d
--- /dev/null
+++ b/sys-apps/coreboot-utils/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>sakaki@deciban.com</email>
+ <name>sakaki</name>
+</maintainer>
+<longdescription>
+ Selected utilities from the coreboot project. Currently contains
+ ifdtool (to parse and modify flash dumps of Intel firmware) and
+ (for amd64 only) intelmetool (to query the status of the Intel
+ Management Engine).
+</longdescription>
+</pkgmetadata>
diff --git a/sys-apps/me_cleaner/Manifest b/sys-apps/me_cleaner/Manifest
new file mode 100644
index 0000000..e3c35c6
--- /dev/null
+++ b/sys-apps/me_cleaner/Manifest
@@ -0,0 +1,3 @@
+DIST me_cleaner-1.2.tar.gz 25247 BLAKE2B 975fe7695c11a5d95a53bb8fadea0796d196e0af09c373b80e8317ac44e933a0a45969c9c872718065052de515bbf1ed44f9fada440b77ab196d77ba970b7578 SHA512 e7d7da61e86542bca965350e4bdfd66c9cf9ef08fb6175c02f580960a9590a4ead10e47c91c38d7df3f7b8d30bf3666160834d381a8f1f3b513f1a4d94be56ff
+EBUILD me_cleaner-1.2-r1.ebuild 653 BLAKE2B 09799f419fda3fe72d1d70a06fb571963be9d039731bcfb3da322588d857c0fbb5f2ee49e498224a3aa515c318b26f963c14e0d593823e39b1b3df1b4a547340 SHA512 ae5c40944d99a3fdcdcee448e319bb0e8445f3d83f304d162f8d390f8183a441e2875d1833de8da4f8ce7cb1cd66caf1a039bdd60d764e0578d0302585d790a7
+MISC metadata.xml 521 BLAKE2B 9cfea116dc496999c0960637e3256c83f39e8cd6118249f0add695d259bbc01883722d1e601c02696237850c7870d35387d274d627ab7df46a66501718f8133c SHA512 5a13008db9b429740a63333b443a0f7f656eaff804e383100ef6b96cdc2c41fbfde931cafbf359ca9503c7a98a7b0648da2282674c431d8c3da0d8ddf70ee418
diff --git a/sys-apps/me_cleaner/me_cleaner-1.2-r1.ebuild b/sys-apps/me_cleaner/me_cleaner-1.2-r1.ebuild
new file mode 100644
index 0000000..90de11d
--- /dev/null
+++ b/sys-apps/me_cleaner/me_cleaner-1.2-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright (c) 2018 sakaki <sakaki@deciban.com>
+# (c) 2021 quarkyalice <devfusediboot@protonmail.com>
+# License: GPL v3+
+# NO WARRANTY
+
+EAPI=8
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit python-r1
+
+DESCRIPTION="Tool for partial deblobbing of Intel ME/TXE firmware images"
+HOMEPAGE="https://github.com/corna/me_cleaner"
+SRC_URI=""
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE=""
+RESTRICT="mirror"
+KEYWORDS="~amd64 ~arm ~arm64"
+
+SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+RDEPEND=${PYTHON_DEPS}
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+src_install() {
+ python_foreach_impl python_newscript "${PN}"{.py,}
+ dodoc "README.md"
+ doman "man/${PN}.1"
+}
+
diff --git a/sys-apps/me_cleaner/metadata.xml b/sys-apps/me_cleaner/metadata.xml
new file mode 100644
index 0000000..99a92b4
--- /dev/null
+++ b/sys-apps/me_cleaner/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>sakaki@deciban.com</email>
+ <name>sakaki</name>
+</maintainer>
+<upstream>
+ <maintainer status="active">
+ <name>Nicola Corna</name>
+ </maintainer>
+ <remote-id type="github">corna/me_cleaner</remote-id>
+</upstream>
+<longdescription>
+ A tool to effectively disable the Intel Management Engine, by
+ modifying its firmware.
+</longdescription>
+</pkgmetadata>