summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2013-12-01 15:09:27 +0100
committerMartin Väth <martin@mvath.de>2015-10-11 10:49:04 +0200
commit7d35dc70721e275af837474df2491589f1023235 (patch)
tree0d2c02d90045fc582ff4cd56ceaf8c82b20e7d56 /app-shells
parentBump noscript (diff)
downloadmv-7d35dc70721e275af837474df2491589f1023235.tar.gz
mv-7d35dc70721e275af837474df2491589f1023235.tar.bz2
mv-7d35dc70721e275af837474df2491589f1023235.zip
zsh-completion: Auto-enable and restructure COMPLETION
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/zsh-completion/ChangeLog3
-rw-r--r--app-shells/zsh-completion/zsh-completion-99999999.ebuild46
2 files changed, 24 insertions, 25 deletions
diff --git a/app-shells/zsh-completion/ChangeLog b/app-shells/zsh-completion/ChangeLog
index 535a3c0e..2baa7962 100644
--- a/app-shells/zsh-completion/ChangeLog
+++ b/app-shells/zsh-completion/ChangeLog
@@ -4,6 +4,9 @@
*zsh-completion-20130808.ebuild (09 Aug 2013)
+ 01 Dec 2013; Martin Väth <martin@mvath.de>:
+ Update to new completion files. Auto-enable and restructure COMPLETION=...
+
06 Nov 2013; Martin Väth <martin@mvath.de>:
Update to new completion files
diff --git a/app-shells/zsh-completion/zsh-completion-99999999.ebuild b/app-shells/zsh-completion/zsh-completion-99999999.ebuild
index 447f3ccb..32665002 100644
--- a/app-shells/zsh-completion/zsh-completion-99999999.ebuild
+++ b/app-shells/zsh-completion/zsh-completion-99999999.ebuild
@@ -31,32 +31,28 @@ declare -a COMPLETIONS FILES
COMPLETIONS=()
FILES=()
for completion in \
- 'Android _adb _android _emulator' \
+ '+Android _adb _android _emulator' \
'+Gentoo _baselayout _eselect _gcc-config _genlop _gentoo_packages _gentoolkit _layman _portage _portage_utils' \
- 'Google _google' \
- '+Unix _logger' \
- 'bumblebee _optirun' \
- 'database _redis-cli _pgsql_utils' \
- 'dev _choc _gradle _geany _manage.py _mvn _pear _play _symfony _thor _vagrant _veewee' \
- 'disk _sdd _smartmontools _srm' \
- 'distribute _celery _fab _knife _mina _mussh' \
- 'dzen _dzen2' \
- 'git _git-flow _git-pulls' \
- 'haskell _cabal' \
- 'id3 _id3 _id3v2' \
- 'managers _brew _debuild _lein _packagekit _pactree _pkcon _port _yaourt' \
- 'net _dhcpcd _httpie _mosh _socat _ssh-copy-id _vpnc _vnstat' \
- 'perf _perf' \
- 'perl _cpanm' \
- 'primus _primus' \
- 'python _bpython _pip _pygmentize _setup.py' \
- 'ruby _bundle _cap _ditz _gas _gem _gist _github _git-wtf _lunchy _rails _rvm _jekyll' \
- 'search _ack _ag _jq' \
- 'session _attach _teamocil _tmuxinator _wemux' \
- 'showoff _showoff' \
- 'subtitles _language_codes _periscope _subliminal' \
- 'virtualbox _virtualbox' \
- 'web _coffee _docpad _gradle _heroku _jonas _jmeter _jmeter-plugins _lunar _middleman _node _nvm _ralio _salt _sbt _scala _svm'
+ '+Google _google' \
+ '+Unix _dzen2 _logger' \
+ '+database _redis-cli _pgsql_utils' \
+ '+dev _choc _gradle _geany _manage.py _mvn _pear _play _symfony _thor _vagrant _veewee' \
+ '+disk _sdd _smartmontools _srm' \
+ '+distribute _celery _fab _knife _mina _mussh' \
+ '+git _git-flow _git-pulls' \
+ '+hardware _optirun _perf _primus' \
+ '+haskell _cabal' \
+ '+managers _brew _debuild _lein _packagekit _pactree _pkcon _port _yaourt' \
+ '+multimedia _id3 _id3v2 _mpv _showoff' \
+ '+net _dget _dhcpcd _httpie _mosh _socat _ssh-copy-id _vpnc _vnstat' \
+ '+perl _cpanm' \
+ '+python _bpython _pip _pygmentize _setup.py' \
+ '+ruby _bundle _cap _ditz _gas _gem _gist _github _git-wtf _lunchy _rails _rvm _jekyll' \
+ '+search _ack _ag _jq' \
+ '+session _attach _teamocil _tmuxinator _wemux' \
+ '+subtitles _language_codes _periscope _subliminal' \
+ '+virtualbox _virtualbox' \
+ '+web _coffee _docpad _gradle _heroku _jonas _jmeter _jmeter-plugins _lunar _middleman _node _nvm _ralio _salt _sbt _scala _svm'
do curr=${completion%% *}
case ${curr} in
'+'*)