aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.travis.yml2
-rwxr-xr-xbin/runtests2
-rw-r--r--okupy/tests/acceptance/__init__.py1
-rw-r--r--okupy/tests/integration/__init__.py5
-rw-r--r--okupy/tests/models.py0
-rw-r--r--okupy/tests/settings.py3
-rw-r--r--okupy/tests/unit/__init__.py6
-rw-r--r--requirements.txt1
-rwxr-xr-xsetup.py1
9 files changed, 18 insertions, 3 deletions
diff --git a/.travis.yml b/.travis.yml
index 28b7c09..4aa14f7 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -9,7 +9,7 @@ install:
branches:
only:
- master
-script: coverage run manage.py test --settings=okupy.tests.settings tests
+script: coverage run manage.py test --settings=okupy.tests.settings
after_success:
- coveralls
notifications:
diff --git a/bin/runtests b/bin/runtests
index 5615818..f7f2197 100755
--- a/bin/runtests
+++ b/bin/runtests
@@ -10,8 +10,6 @@ while getopts sa:dc arg; do
esac
done
-[[ -z ${APPS} ]] && APPS="tests"
-
if [[ -n ${TDAEMON} ]]; then
[[ -n ${COVERAGE} ]] && COVERAGE="-c"
${TDAEMON} ${COVERAGE} --custom-args="${SETTINGS} ${APPS}"
diff --git a/okupy/tests/acceptance/__init__.py b/okupy/tests/acceptance/__init__.py
index e69de29..3d916e2 100644
--- a/okupy/tests/acceptance/__init__.py
+++ b/okupy/tests/acceptance/__init__.py
@@ -0,0 +1 @@
+# vim:fileencoding=utf8:et:ts=4:sts=4:sw=4:ft=python
diff --git a/okupy/tests/integration/__init__.py b/okupy/tests/integration/__init__.py
index e69de29..3defde1 100644
--- a/okupy/tests/integration/__init__.py
+++ b/okupy/tests/integration/__init__.py
@@ -0,0 +1,5 @@
+# vim:fileencoding=utf8:et:ts=4:sts=4:sw=4:ft=python
+
+from .index import *
+from .login import *
+from .signup import *
diff --git a/okupy/tests/models.py b/okupy/tests/models.py
deleted file mode 100644
index e69de29..0000000
--- a/okupy/tests/models.py
+++ /dev/null
diff --git a/okupy/tests/settings.py b/okupy/tests/settings.py
index 0af4ce4..f71b4fe 100644
--- a/okupy/tests/settings.py
+++ b/okupy/tests/settings.py
@@ -55,6 +55,7 @@ INSTALLED_APPS = (
'django.contrib.staticfiles',
'django_auth_ldap',
'django_otp',
+ 'discover_runner',
'okupy.accounts',
'okupy.otp',
'okupy.otp.sotp',
@@ -295,6 +296,8 @@ DATABASES['ldap'] = {
DATABASE_ROUTERS = ['ldapdb.router.Router']
+TEST_RUNNER = 'discover_runner.DiscoverRunner'
+
DIRECTORY = {
"o=test": {},
"cn=anon,o=test": {
diff --git a/okupy/tests/unit/__init__.py b/okupy/tests/unit/__init__.py
index e69de29..5c1286c 100644
--- a/okupy/tests/unit/__init__.py
+++ b/okupy/tests/unit/__init__.py
@@ -0,0 +1,6 @@
+# vim:fileencoding=utf8:et:ts=4:sts=4:sw=4:ft=python
+
+from .connection import *
+from .index import *
+from .login import *
+from .signup import *
diff --git a/requirements.txt b/requirements.txt
index 9b3c8a7..aa3a692 100644
--- a/requirements.txt
+++ b/requirements.txt
@@ -1,6 +1,7 @@
django>=1.5
django-auth-ldap>=1.1.4
django-compressor>=1.3
+django-discover-runner>=1.0
django-otp>=0.1.7
git+https://github.com/tampakrap/django-ldapdb@okupy#egg=django-ldapdb
edpwd>=0.0.7
diff --git a/setup.py b/setup.py
index 44d14d2..6d6109c 100755
--- a/setup.py
+++ b/setup.py
@@ -50,6 +50,7 @@ setup(
'setuptools>=0.6c11',
],
tests_require=[
+ 'django-discover-runner>=1.0',
'mockldap',
'mock>=1.0.1',
],