summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2014-11-19 03:06:58 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2014-11-19 03:06:58 +0000
commit00d764cea69a8dcbdd035937ced394601b557405 (patch)
tree0051c88eace56f152d0debf5f311dafcad012cdb
parentRemove unneeded useflags from metadata.xml (diff)
downloadgentoo-2-00d764cea69a8dcbdd035937ced394601b557405.tar.gz
gentoo-2-00d764cea69a8dcbdd035937ced394601b557405.tar.bz2
gentoo-2-00d764cea69a8dcbdd035937ced394601b557405.zip
build with ncurses[tinfo] (bug #529738)
(Portage version: 2.2.8-r2/cvs/Linux x86_64, unsigned Manifest commit)
-rw-r--r--games-arcade/stardork/ChangeLog7
-rw-r--r--games-arcade/stardork/stardork-0.7.ebuild14
2 files changed, 13 insertions, 8 deletions
diff --git a/games-arcade/stardork/ChangeLog b/games-arcade/stardork/ChangeLog
index 459cb460ab95..4287a9d8407c 100644
--- a/games-arcade/stardork/ChangeLog
+++ b/games-arcade/stardork/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-arcade/stardork
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/stardork/ChangeLog,v 1.12 2013/01/30 22:48:15 mr_bones_ Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/stardork/ChangeLog,v 1.13 2014/11/19 03:06:58 mr_bones_ Exp $
+
+ 19 Nov 2014; Michael Sterrett <mr_bones_@gentoo.org> stardork-0.7.ebuild:
+ build with ncurses[tinfo] (bug #529738)
30 Jan 2013; Michael Sterrett <mr_bones_@gentoo.org> -stardork-0.6.ebuild:
old
diff --git a/games-arcade/stardork/stardork-0.7.ebuild b/games-arcade/stardork/stardork-0.7.ebuild
index ab9cde04e88a..3eaea0155b5a 100644
--- a/games-arcade/stardork/stardork-0.7.ebuild
+++ b/games-arcade/stardork/stardork-0.7.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/stardork/stardork-0.7.ebuild,v 1.2 2012/01/28 14:55:58 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/stardork/stardork-0.7.ebuild,v 1.3 2014/11/19 03:06:58 mr_bones_ Exp $
-EAPI=2
+EAPI=5
inherit toolchain-funcs games
DESCRIPTION="An ncurses-based space shooter"
@@ -14,18 +14,20 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 x86"
IUSE=""
-DEPEND="sys-libs/ncurses"
+RDEPEND="sys-libs/ncurses"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
src_prepare() {
rm -f Makefile
}
src_compile() {
- emake CC="$(tc-getCC)" LDLIBS=-lncurses ${PN} || die
+ emake CC="$(tc-getCC)" LDLIBS="$(pkg-config ncurses --libs)" ${PN}
}
src_install() {
- dogamesbin ${PN} || die
+ dogamesbin ${PN}
dodoc README
prepgamesdirs
}