summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2005-05-16 04:30:10 +0000
committerMamoru Komachi <usata@gentoo.org>2005-05-16 04:30:10 +0000
commit073c8823e7b6aeb99c278d7a615a37c73da24925 (patch)
tree6feadb9389547207ddde219e4e75417efbf3624c
parentuse toolchain-funcs.eclass instead of gcc.eclass; bug #92745. (diff)
downloadgentoo-2-073c8823e7b6aeb99c278d7a615a37c73da24925.tar.gz
gentoo-2-073c8823e7b6aeb99c278d7a615a37c73da24925.tar.bz2
gentoo-2-073c8823e7b6aeb99c278d7a615a37c73da24925.zip
use toolchain-funcs.eclass instead of gcc.eclass; bug #92745.
(Portage version: 2.0.51.21-r1)
-rw-r--r--app-text/html2text/html2text-1.3.2.ebuild8
-rw-r--r--app-text/vlna/vlna-1.2.ebuild6
-rw-r--r--dev-tex/csindex/csindex-2.11c.ebuild8
-rw-r--r--media-gfx/w3mimgfb/w3mimgfb-0.9.1.ebuild6
4 files changed, 14 insertions, 14 deletions
diff --git a/app-text/html2text/html2text-1.3.2.ebuild b/app-text/html2text/html2text-1.3.2.ebuild
index 062e2bad75a0..ce20ca94d499 100644
--- a/app-text/html2text/html2text-1.3.2.ebuild
+++ b/app-text/html2text/html2text-1.3.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/html2text/html2text-1.3.2.ebuild,v 1.8 2005/04/01 03:48:07 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/html2text/html2text-1.3.2.ebuild,v 1.9 2005/05/16 04:25:29 usata Exp $
-inherit eutils gcc
+inherit eutils toolchain-funcs
DESCRIPTION="A HTML to text converter"
HOMEPAGE="http://userpage.fu-berlin.de/~mbayer/tools/html2text.html"
@@ -10,7 +10,7 @@ SRC_URI="http://userpage.fu-berlin.de/~mbayer/tools/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~sparc ~amd64 ~ppc ppc64 ~alpha ia64"
+KEYWORDS="x86 ~sparc ~amd64 ~ppc ppc64 ~alpha ia64"
IUSE=""
DEPEND="virtual/libc"
@@ -26,7 +26,7 @@ src_unpack() {
src_compile() {
econf || die
- emake || die
+ emake CXX="$(tc-getCXX)" || die
}
src_install() {
diff --git a/app-text/vlna/vlna-1.2.ebuild b/app-text/vlna/vlna-1.2.ebuild
index 6a6b796ceb1b..024e98ad0cdc 100644
--- a/app-text/vlna/vlna-1.2.ebuild
+++ b/app-text/vlna/vlna-1.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/vlna/vlna-1.2.ebuild,v 1.8 2005/04/21 20:34:30 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/vlna/vlna-1.2.ebuild,v 1.9 2005/05/16 04:26:37 usata Exp $
-inherit gcc
+inherit toolchain-funcs
DESCRIPTION="Add nonbreakable spaces after some prepositions in Czech texts"
HOMEPAGE="http://math.feld.cvut.cz/olsak/cstex/"
@@ -18,7 +18,7 @@ DEPEND="virtual/libc"
S=${WORKDIR}/${PN}
src_compile() {
- emake CC="$(gcc-getCC)" CFLAGS="${CFLAGS}" || die "make failed"
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "make failed"
}
src_install() {
diff --git a/dev-tex/csindex/csindex-2.11c.ebuild b/dev-tex/csindex/csindex-2.11c.ebuild
index 9b3715930547..cd0a444b97ce 100644
--- a/dev-tex/csindex/csindex-2.11c.ebuild
+++ b/dev-tex/csindex/csindex-2.11c.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/csindex/csindex-2.11c.ebuild,v 1.5 2004/07/02 05:02:24 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/csindex/csindex-2.11c.ebuild,v 1.6 2005/05/16 04:28:14 usata Exp $
-inherit gcc
+inherit toolchain-funcs
MY_P="${PN}-19980713"
@@ -20,7 +20,7 @@ DEPEND="virtual/libc"
S=${WORKDIR}/${MY_P}
src_compile() {
- emake CC="$(gcc-getCC)" CFLAGS="${CFLAGS}" || die "make failed"
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "make failed"
}
src_install() {
diff --git a/media-gfx/w3mimgfb/w3mimgfb-0.9.1.ebuild b/media-gfx/w3mimgfb/w3mimgfb-0.9.1.ebuild
index 5aca375e0192..2440adcca7b1 100644
--- a/media-gfx/w3mimgfb/w3mimgfb-0.9.1.ebuild
+++ b/media-gfx/w3mimgfb/w3mimgfb-0.9.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/w3mimgfb/w3mimgfb-0.9.1.ebuild,v 1.7 2005/05/01 18:04:33 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/w3mimgfb/w3mimgfb-0.9.1.ebuild,v 1.8 2005/05/16 04:30:10 usata Exp $
-inherit gcc
+inherit toolchain-funcs
DESCRIPTION="Image viewer for w3m under frame buffer environment"
HOMEPAGE="http://homepage3.nifty.com/slokar/fb/w3mimg.html"
@@ -17,7 +17,7 @@ DEPEND=">=media-libs/stimg-0.1.0
virtual/w3m"
src_compile() {
- emake CC="$(gcc-getCC)" CFLAGS="${CFLAGS}" || die "emake failed"
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "emake failed"
}
src_install() {