summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-08-22 19:35:19 +0000
committerNick Hadaway <raker@gentoo.org>2002-08-22 19:35:19 +0000
commit0846ac40d8a727eb3581b0d8a680ad023332b9a4 (patch)
treee12fa96815f218bf9b6ab5087659c5ecf855066e
parentremoved two comments (diff)
downloadgentoo-2-0846ac40d8a727eb3581b0d8a680ad023332b9a4.tar.gz
gentoo-2-0846ac40d8a727eb3581b0d8a680ad023332b9a4.tar.bz2
gentoo-2-0846ac40d8a727eb3581b0d8a680ad023332b9a4.zip
Disabling glcanvas and gizmos extensions temporarily.
-rw-r--r--dev-python/wxPython/ChangeLog7
-rw-r--r--dev-python/wxPython/files/nogizmos.diff160
-rw-r--r--dev-python/wxPython/files/noglcanvas.diff93
-rw-r--r--dev-python/wxPython/wxPython-2.3.2.1-r1.ebuild29
4 files changed, 277 insertions, 12 deletions
diff --git a/dev-python/wxPython/ChangeLog b/dev-python/wxPython/ChangeLog
index 8ff214b00d75..c39530b3bfe9 100644
--- a/dev-python/wxPython/ChangeLog
+++ b/dev-python/wxPython/ChangeLog
@@ -1,9 +1,14 @@
# ChangeLog for dev-python/wxPython
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxPython/ChangeLog,v 1.3 2002/07/03 03:41:16 jnelson Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxPython/ChangeLog,v 1.4 2002/08/22 19:35:19 raker Exp $
*wxPython-2.3.2.1-r1 (2 Jul 2002)
+ 22 Aug 2002; Nick Hadaway <raker@gentoo.org> wxPython-2.3.2.1-r1,
+ files/noglcanvas.diff, files/nogizmos.diff :
+ Ebuild disables glcancas and gizmos extensions as they currently are
+ not building correctly.
+
2 Jul 2002; Jon Nelson <jnelson@gentoo.org> wxPython-2.3.2.1-r1:
Make lintool happy
expressly don't build GLCANVAS
diff --git a/dev-python/wxPython/files/nogizmos.diff b/dev-python/wxPython/files/nogizmos.diff
new file mode 100644
index 000000000000..239406689893
--- /dev/null
+++ b/dev-python/wxPython/files/nogizmos.diff
@@ -0,0 +1,160 @@
+diff -urN wxPython-2.3.2.1/setup.py wxPython-2.3.2.1-modified/setup.py
+--- wxPython-2.3.2.1/setup.py Thu Dec 20 11:33:42 2001
++++ wxPython-2.3.2.1-modified/setup.py Thu Aug 22 14:07:18 2002
+@@ -32,8 +32,8 @@
+ BUILD_OGL = 1 # If true, build the contrib/ogl extension module
+ BUILD_STC = 1 # If true, build the contrib/stc extension module
+ BUILD_XRC = 1 # XML based resource system
+-BUILD_GIZMOS = 1 # Build a module for the gizmos contrib library
+-BUILD_DLLWIDGET = 1# Build a module for the gizmos contrib library
++BUILD_GIZMOS = 0 # Build a module for the gizmos contrib library
++BUILD_DLLWIDGET = 0# Build a module for the gizmos contrib library
+
+ BUILD_IEWIN = 0 # Internet Explorer wrapper (experimental)
+
+@@ -757,46 +757,46 @@
+ #----------------------------------------------------------------------
+ # Define the GIZMOS extension module
+ #----------------------------------------------------------------------
+-
+-if not GL_ONLY and BUILD_GIZMOS:
+- msg('Preparing GIZMOS...')
+- location = 'contrib/gizmos'
+- GIZMOLOC = opj(location, 'contrib/src/gizmos')
+- GIZMOINC = opj(location, 'contrib/include')
+-
+- swig_files = ['gizmos.i']
+-
+- swig_sources = run_swig(swig_files, location, '', PKGDIR,
+- USE_SWIG, swig_force, swig_args)
+-
+- gizmos_includes = includes[:]
+- gizmos_includes.append(GIZMOINC)
+-
+-
+- # make sure local copy of contrib files are up to date
+- if IN_CVS_TREE:
+- contrib_copy_tree(opj(CTRB_INC, 'gizmos'), opj(GIZMOINC, 'wx/gizmos'))
+- contrib_copy_tree(opj(CTRB_SRC, 'gizmos'), GIZMOLOC)
+-
+- ext = Extension('gizmosc', [
+- '%s/dynamicsash.cpp' % GIZMOLOC,
+- '%s/editlbox.cpp' % GIZMOLOC,
+- #'%s/multicell.cpp' % GIZMOLOC,
+- '%s/splittree.cpp' % GIZMOLOC,
+- '%s/ledctrl.cpp' % GIZMOLOC,
+- ] + swig_sources,
+-
+- include_dirs = gizmos_includes,
+- define_macros = defines,
+-
+- library_dirs = libdirs,
+- libraries = libs,
+-
+- extra_compile_args = cflags,
+- extra_link_args = lflags,
+- )
+-
+- wxpExtensions.append(ext)
++#
++#if not GL_ONLY and BUILD_GIZMOS:
++# msg('Preparing GIZMOS...')
++# location = 'contrib/gizmos'
++# GIZMOLOC = opj(location, 'contrib/src/gizmos')
++# GIZMOINC = opj(location, 'contrib/include')
++#
++# swig_files = ['gizmos.i']
++#
++# swig_sources = run_swig(swig_files, location, '', PKGDIR,
++# USE_SWIG, swig_force, swig_args)
++#
++# gizmos_includes = includes[:]
++# gizmos_includes.append(GIZMOINC)
++#
++#
++# # make sure local copy of contrib files are up to date
++# if IN_CVS_TREE:
++# contrib_copy_tree(opj(CTRB_INC, 'gizmos'), opj(GIZMOINC, 'wx/gizmos'))
++# contrib_copy_tree(opj(CTRB_SRC, 'gizmos'), GIZMOLOC)
++#
++# ext = Extension('gizmosc', [
++# '%s/dynamicsash.cpp' % GIZMOLOC,
++# '%s/editlbox.cpp' % GIZMOLOC,
++# #'%s/multicell.cpp' % GIZMOLOC,
++# '%s/splittree.cpp' % GIZMOLOC,
++# '%s/ledctrl.cpp' % GIZMOLOC,
++# ] + swig_sources,
++#
++# include_dirs = gizmos_includes,
++# define_macros = defines,
++#
++# library_dirs = libdirs,
++# libraries = libs,
++#
++# extra_compile_args = cflags,
++# extra_link_args = lflags,
++# )
++#
++# wxpExtensions.append(ext)
+
+
+
+@@ -804,32 +804,32 @@
+ # Define the DLLWIDGET extension module
+ #----------------------------------------------------------------------
+
+-if not GL_ONLY and BUILD_DLLWIDGET:
+- msg('Preparing DLLWIDGET...')
+- location = 'contrib/dllwidget'
+- swig_files = ['dllwidget_.i']
+-
+- swig_sources = run_swig(swig_files, location, '', PKGDIR,
+- USE_SWIG, swig_force, swig_args)
+-
+- # copy a contrib project specific py module to the main package dir
+- copy_file(opj(location, 'dllwidget.py'), PKGDIR, update=1, verbose=0)
+-
+- ext = Extension('dllwidget_c', [
+- '%s/dllwidget.cpp' % location,
+- ] + swig_sources,
+-
+- include_dirs = includes,
+- define_macros = defines,
+-
+- library_dirs = libdirs,
+- libraries = libs,
+-
+- extra_compile_args = cflags,
+- extra_link_args = lflags,
+- )
+-
+- wxpExtensions.append(ext)
++#if not GL_ONLY and BUILD_DLLWIDGET:
++# msg('Preparing DLLWIDGET...')
++# location = 'contrib/dllwidget'
++# swig_files = ['dllwidget_.i']
++#
++# swig_sources = run_swig(swig_files, location, '', PKGDIR,
++# USE_SWIG, swig_force, swig_args)
++#
++# # copy a contrib project specific py module to the main package dir
++# copy_file(opj(location, 'dllwidget.py'), PKGDIR, update=1, verbose=0)
++#
++# ext = Extension('dllwidget_c', [
++# '%s/dllwidget.cpp' % location,
++# ] + swig_sources,
++#
++# include_dirs = includes,
++# define_macros = defines,
++#
++# library_dirs = libdirs,
++# libraries = libs,
++#
++# extra_compile_args = cflags,
++# extra_link_args = lflags,
++# )
++#
++# wxpExtensions.append(ext)
+
+
+ #----------------------------------------------------------------------
diff --git a/dev-python/wxPython/files/noglcanvas.diff b/dev-python/wxPython/files/noglcanvas.diff
new file mode 100644
index 000000000000..cfd4ebff7838
--- /dev/null
+++ b/dev-python/wxPython/files/noglcanvas.diff
@@ -0,0 +1,93 @@
+diff -urN wxPython-2.3.2.1/setup.py wxPython-2.3.2.1-modified/setup.py
+--- wxPython-2.3.2.1/setup.py Thu Dec 20 11:33:42 2001
++++ wxPython-2.3.2.1-modified/setup.py Thu Aug 22 14:04:04 2002
+@@ -28,7 +28,7 @@
+ """
+
+
+-BUILD_GLCANVAS = 1 # If true, build the contrib/glcanvas extension module
++BUILD_GLCANVAS = 0 # If true, build the contrib/glcanvas extension module
+ BUILD_OGL = 1 # If true, build the contrib/ogl extension module
+ BUILD_STC = 1 # If true, build the contrib/stc extension module
+ BUILD_XRC = 1 # XML based resource system
+@@ -435,43 +435,43 @@
+ #----------------------------------------------------------------------
+ # Define the GLCanvas extension module
+ #----------------------------------------------------------------------
+-
+-CTRB_SRC = opj(WXDIR, 'contrib/src')
+-CTRB_INC = opj(WXDIR, 'contrib/include/wx')
+-
+-if BUILD_GLCANVAS or GL_ONLY:
+- msg('Preparing GLCANVAS...')
+- location = 'contrib/glcanvas'
+- swig_files = ['glcanvas.i']
+- other_sources = []
+-
+- swig_sources = run_swig(swig_files, location, GENDIR, PKGDIR,
+- USE_SWIG, swig_force, swig_args)
+-
+- gl_libs = []
+- if os.name == 'posix':
+- gl_config = os.popen(WX_CONFIG + ' --gl-libs', 'r').read()[:-1]
+- gl_lflags = string.split(gl_config) + lflags
+- gl_libs = libs
+- else:
+- other_sources = [opj(location, 'msw/myglcanvas.cpp')]
+- gl_libs = libs + ['opengl32', 'glu32']
+- gl_lflags = lflags
+-
+- ext = Extension('glcanvasc',
+- swig_sources + other_sources,
+-
+- include_dirs = includes,
+- define_macros = defines,
+-
+- library_dirs = libdirs,
+- libraries = gl_libs,
+-
+- extra_compile_args = cflags,
+- extra_link_args = gl_lflags,
+- )
+-
+- wxpExtensions.append(ext)
++#
++#CTRB_SRC = opj(WXDIR, 'contrib/src')
++#CTRB_INC = opj(WXDIR, 'contrib/include/wx')
++#
++#if BUILD_GLCANVAS or GL_ONLY:
++# msg('Preparing GLCANVAS...')
++# location = 'contrib/glcanvas'
++# swig_files = ['glcanvas.i']
++# other_sources = []
++#
++# swig_sources = run_swig(swig_files, location, GENDIR, PKGDIR,
++# USE_SWIG, swig_force, swig_args)
++#
++# gl_libs = []
++# if os.name == 'posix':
++# gl_config = os.popen(WX_CONFIG + ' --gl-libs', 'r').read()[:-1]
++# gl_lflags = string.split(gl_config) + lflags
++# gl_libs = libs
++# else:
++# other_sources = [opj(location, 'msw/myglcanvas.cpp')]
++# gl_libs = libs + ['opengl32', 'glu32']
++# gl_lflags = lflags
++#
++# ext = Extension('glcanvasc',
++# swig_sources + other_sources,
++#
++# include_dirs = includes,
++# define_macros = defines,
++#
++# library_dirs = libdirs,
++# libraries = gl_libs,
++#
++# extra_compile_args = cflags,
++# extra_link_args = gl_lflags,
++# )
++#
++# wxpExtensions.append(ext)
+
+
+ #----------------------------------------------------------------------
diff --git a/dev-python/wxPython/wxPython-2.3.2.1-r1.ebuild b/dev-python/wxPython/wxPython-2.3.2.1-r1.ebuild
index b0842d774eac..65812679f939 100644
--- a/dev-python/wxPython/wxPython-2.3.2.1-r1.ebuild
+++ b/dev-python/wxPython/wxPython-2.3.2.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxPython/wxPython-2.3.2.1-r1.ebuild,v 1.3 2002/08/16 02:49:58 murphy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxPython/wxPython-2.3.2.1-r1.ebuild,v 1.4 2002/08/22 19:35:19 raker Exp $
S=${WORKDIR}/${P}
DESCRIPTION="A blending of the wxWindows C++ class library with Python."
@@ -19,14 +19,14 @@ LICENSE="LGPL-2"
KEYWORDS="x86 sparc sparc64"
src_compile() {
- local myconf
- myconf=""
-
- if use opengl; then
- myconf="${myconf} BUILD_GLCANVAS=1"
- else
- myconf="${myconf} BUILD_GLCANVAS=0"
- fi
+# local myconf
+# myconf=""
+#
+# if use opengl; then
+# myconf="${myconf} BUILD_GLCANVAS=1"
+# else
+# myconf="${myconf} BUILD_GLCANVAS=0"
+# fi
#Other possible configuration variables are BUILD_OGL and BUILD_STC.
#BUILD_OGL builds the Object Graphics Library extension module.
@@ -37,8 +37,15 @@ src_compile() {
# this doesn't work yet with opengl, thus,
# force the issue for now.
# It *builds* but sigsegs at runtime.
- myconf="BUILD_GLCANVAS=0"
- python setup.py build ${myconf} || die
+ # myconf="BUILD_GLCANVAS=0"
+ cd ${S}
+ patch -p1 < ${FILESDIR}/noglcanvas.diff || die "patch failed"
+
+ # gizmos currently fails compiling on gcc3
+ # myconf="${myconf} BUILD_GIZMOS=0"
+ patch -p1 < ${FILESDIR}/nogizmos.diff || die "patch failed"
+
+ python setup.py build || die
}
src_install () {