summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2009-07-21 11:59:35 +0000
committerAlfredo Tupone <tupone@gentoo.org>2009-07-21 11:59:35 +0000
commit0a7275e50e9dcffd593cd21cb6e9abbc0aa9aebf (patch)
tree2df0fb103db7e8b00b4f7bcc55657a6487a67c42
parentUSE soap wrt #138038. (diff)
downloadgentoo-2-0a7275e50e9dcffd593cd21cb6e9abbc0aa9aebf.tar.gz
gentoo-2-0a7275e50e9dcffd593cd21cb6e9abbc0aa9aebf.tar.bz2
gentoo-2-0a7275e50e9dcffd593cd21cb6e9abbc0aa9aebf.zip
Fix emerging with test enabled. Bug #278184
(Portage version: 2.1.6.13/cvs/Linux x86_64)
-rw-r--r--dev-games/poker-eval/ChangeLog6
-rw-r--r--dev-games/poker-eval/files/poker-eval-135.0-bash40.patch32
-rw-r--r--dev-games/poker-eval/poker-eval-135.0.ebuild12
3 files changed, 46 insertions, 4 deletions
diff --git a/dev-games/poker-eval/ChangeLog b/dev-games/poker-eval/ChangeLog
index c00745796650..eae863be3fca 100644
--- a/dev-games/poker-eval/ChangeLog
+++ b/dev-games/poker-eval/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-games/poker-eval
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/poker-eval/ChangeLog,v 1.14 2009/01/01 22:26:40 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/poker-eval/ChangeLog,v 1.15 2009/07/21 11:59:35 tupone Exp $
+
+ 21 Jul 2009; Alfredo Tupone <tupone@gentoo.org>
+ +files/poker-eval-135.0-bash40.patch, poker-eval-135.0.ebuild:
+ Fix emerging with test enabled. Bug #278184 by flameeyes@gentoo.org
*poker-eval-135.0 (01 Jan 2009)
diff --git a/dev-games/poker-eval/files/poker-eval-135.0-bash40.patch b/dev-games/poker-eval/files/poker-eval-135.0-bash40.patch
new file mode 100644
index 000000000000..f9cc96388f50
--- /dev/null
+++ b/dev-games/poker-eval/files/poker-eval-135.0-bash40.patch
@@ -0,0 +1,32 @@
+--- tests/bug1823.old 2009-07-21 13:45:13.000000000 +0200
++++ tests/bug1823 2009-07-21 13:45:52.000000000 +0200
+@@ -27,7 +27,8 @@
+ cards scoop HIwin HIlos HItie LOwin LOlos LOtie EV
+ As Qs Kh Jh 500 715 15 90 0 0 0 0.796
+ Ac Kd 5d 7h 15 15 715 90 224 0 0 0.204
+-EOF)
++EOF
++)
+ if test "$r" != "$e" ; then
+ diff -u <(echo "$e") <(echo "$r")
+ exit 1
+@@ -39,7 +40,8 @@
+ cards scoop HIwin HIlos HItie LOwin LOlos LOtie EV
+ As 6s 7h 5h 250 324 0 496 0 0 168 0.675
+ Ac 7d 6d 5d 0 0 324 496 0 0 168 0.325
+-EOF)
++EOF
++)
+ if test "$r" != "$e" ; then
+ diff -u <(echo "$e") <(echo "$r")
+ exit 1
+@@ -51,7 +53,8 @@
+ cards scoop HIwin HIlos HItie LOwin LOlos LOtie EV
+ As 6s 7h 5h 289 381 352 87 12 0 157 0.504
+ Ac 8d 6d 5d 314 352 381 87 0 12 157 0.496
+-EOF)
++EOF
++)
+ if test "$r" != "$e" ; then
+ diff -u <(echo "$e") <(echo "$r")
+ exit 1
diff --git a/dev-games/poker-eval/poker-eval-135.0.ebuild b/dev-games/poker-eval/poker-eval-135.0.ebuild
index 340f09cc7b86..c3938b814579 100644
--- a/dev-games/poker-eval/poker-eval-135.0.ebuild
+++ b/dev-games/poker-eval/poker-eval-135.0.ebuild
@@ -1,6 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/poker-eval/poker-eval-135.0.ebuild,v 1.1 2009/01/01 22:26:40 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/poker-eval/poker-eval-135.0.ebuild,v 1.2 2009/07/21 11:59:35 tupone Exp $
+EAPI=2
+
+inherit eutils
DESCRIPTION="A fast C library for evaluating poker hands"
HOMEPAGE="http://pokersource.info/"
@@ -11,9 +14,12 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~x86"
IUSE=""
-src_compile() {
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-bash40.patch
+}
+
+src_configure() {
econf --without-ccache || die
- emake || die "emake failed"
}
src_install() {